Inconsistent package_ensure parameter name

Bug #1668732 reported by Mathieu Gagné on 2017-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-aodh
Medium
zhongshengping
puppet-barbican
Medium
zhongshengping
puppet-ceph
Medium
zhongshengping
puppet-cinder
Medium
zhongshengping
puppet-cloudkitty
Medium
zhongshengping
puppet-designate
Medium
zhongshengping
puppet-glance
Medium
zhongshengping
puppet-glare
Medium
zhongshengping
puppet-gnocchi
Medium
zhongshengping
puppet-horizon
Medium
zhongshengping
puppet-ironic
Medium
zhongshengping
puppet-keystone
Medium
zhongshengping
puppet-monasca
Medium
zhongshengping
puppet-neutron
Medium
zhongshengping
puppet-nova
Medium
zhongshengping
puppet-octavia
Medium
zhongshengping
puppet-openstacklib
Medium
zhongshengping
puppet-oslo
Medium
zhongshengping
puppet-panko
Medium
zhongshengping
puppet-rally
Medium
zhongshengping
puppet-swift
Medium
zhongshengping
puppet-tempest
Medium
zhongshengping
puppet-trove
Medium
zhongshengping
puppet-vitrage
Medium
zhongshengping
puppet-watcher
Medium
zhongshengping

Bug Description

The parameter name used to enforce package state is inconsistent across manifests and modules.

I found the following occurrences of each names (found in repositories in the openstack/governance projects.yaml for the Puppet OpenStack project):

* ensure_package = 33
* package_ensure = 141

I suggest we settle on package_ensure since it's already widely used.

This means the following manifests will need to be updated accordingly:

* aodh::ensure_package
* barbican::api::ensure_package
* cloudkitty::ensure_package
* gnocchi::db::ensure_package
* gnocchi::ensure_package
* nova::api::ensure_package
* nova::cells::ensure_package
* nova::cert::ensure_package
* nova::compute::ensure_package
* nova::conductor::ensure_package
* nova::consoleauth::ensure_package
* nova::ensure_package
* nova::network::ensure_package
* nova::objectstore::ensure_package
* nova::scheduler::ensure_package
* nova::serialproxy::ensure_package
* nova::spicehtml5proxy::ensure_package
* nova::vncproxy::ensure_package
* nova::compute::libvirt::ensure_package
* nova::metadata::novajoin::api::ensure_package
* nova::wsgi::apache_placement::ensure_package
* octavia::ensure_package
* panko::ensure_package
* qdr::ensure_package
* qdr::install::ensure_package
* rally::ensure_package
* tempest::ensure_package
* trove::api::ensure_package
* trove::conductor::ensure_package
* trove::guestagent::ensure_package
* trove::taskmanager::ensure_package
* vitrage::ensure_package
* watcher::ensure_package

Changed in puppet-aodh:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-barbican:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-cloudkitty:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-gnocchi:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-nova:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-octavia:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-panko:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-rally:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-tempest:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-trove:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-vitrage:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-watcher:
status: New → Confirmed
Changed in puppet-cinder:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-ceph:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-designate:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-swift:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-glance:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-glare:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-horizon:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-ironic:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-keystone:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-monasca:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-neutron:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-openstacklib:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-oslo:
importance: Undecided → Medium
status: New → Confirmed
Changed in puppet-watcher:
importance: Undecided → Medium
Changed in puppet-panko:
assignee: nobody → Michael Glaser (mikeg451)
Changed in puppet-rally:
assignee: nobody → Michael Glaser (mikeg451)

Fix proposed to branch: master
Review: https://review.openstack.org/441947

Changed in puppet-panko:
status: Confirmed → In Progress
Changed in puppet-rally:
status: Confirmed → In Progress

Change abandoned by Michael Glaser (<email address hidden>) on branch: master
Review: https://review.openstack.org/441947

Change abandoned by Michael Glaser (<email address hidden>) on branch: master
Review: https://review.openstack.org/441948

Changed in puppet-panko:
assignee: Michael Glaser (mikeg451) → nobody
Changed in puppet-rally:
assignee: Michael Glaser (mikeg451) → nobody
Changed in puppet-panko:
status: In Progress → Confirmed
Changed in puppet-rally:
status: In Progress → Confirmed
Brent Eagles (beagles) on 2017-03-06
Changed in puppet-octavia:
assignee: nobody → Brent Eagles (beagles)
Changed in puppet-neutron:
assignee: nobody → Brent Eagles (beagles)
assignee: Brent Eagles (beagles) → nobody
Changed in puppet-octavia:
assignee: Brent Eagles (beagles) → nobody
Brent Eagles (beagles) wrote :

I was about to do this and then realized that while consistency is a good thing, there are some fairly significant repercussions to this change. Probably it would be best to "migrate changes" through some cycles, with the corresponding deprecation period etc. - with the understanding and the acceptance that something, somewhere down the line is going to break for someone.

zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-aodh:
assignee: nobody → zhongshengping (chdzsp)
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-barbican:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-ceph:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-aodh:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-cinder:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-cloudkitty:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-designate:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443001

Changed in puppet-barbican:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/443007

Changed in puppet-cloudkitty:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-glance:
assignee: nobody → zhongshengping (chdzsp)
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-glare:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443012

Changed in puppet-designate:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-gnocchi:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443028

Changed in puppet-gnocchi:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-horizon:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-ironic:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-keystone:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-monasca:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-neutron:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-octavia:
assignee: nobody → zhongshengping (chdzsp)
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-nova:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443035

Changed in puppet-octavia:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-panko:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443040

Changed in puppet-panko:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-rally:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443042

Changed in puppet-rally:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-tempest:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443043

Changed in puppet-tempest:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-trove:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-vitrage:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443046

Changed in puppet-vitrage:
status: Confirmed → In Progress
zhongshengping (chdzsp) on 2017-03-08
Changed in puppet-watcher:
assignee: nobody → zhongshengping (chdzsp)

Fix proposed to branch: master
Review: https://review.openstack.org/443049

Changed in puppet-watcher:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/443376

Changed in puppet-trove:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/443046
Committed: https://git.openstack.org/cgit/openstack/puppet-vitrage/commit/?id=2183b6f3f4fac6ef63104d509d596250d840c8a6
Submitter: Jenkins
Branch: master

commit 2183b6f3f4fac6ef63104d509d596250d840c8a6
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 18:03:44 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I52a903ad06efff389a731c845b8c8a1958bfdad5
    Closes-Bug: #1668732

Changed in puppet-vitrage:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443001
Committed: https://git.openstack.org/cgit/openstack/puppet-barbican/commit/?id=4ad8b2ce95310c93a7fcae5277f7966133388fb5
Submitter: Jenkins
Branch: master

commit 4ad8b2ce95310c93a7fcae5277f7966133388fb5
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 16:44:14 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: Ibd0ae9f702bdc740948d7530ab5729ec80c4ce2a
    Closes-Bug: #1668732

Changed in puppet-barbican:
status: In Progress → Fix Released
Changed in puppet-trove:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443376
Committed: https://git.openstack.org/cgit/openstack/puppet-trove/commit/?id=3cf985f57ef6f12a09fc4bdb0ad038814dd42db0
Submitter: Jenkins
Branch: master

commit 3cf985f57ef6f12a09fc4bdb0ad038814dd42db0
Author: ZhongShengping <chdzsp@163.com>
Date: Thu Mar 9 09:25:07 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I887e924d184d9b25c33b5fe617d82f170d0cee34
    Closes-Bug: #1668732

Changed in puppet-watcher:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443049
Committed: https://git.openstack.org/cgit/openstack/puppet-watcher/commit/?id=516c0e1ea4555a6212ac4e6d9039a4136a133e6b
Submitter: Jenkins
Branch: master

commit 516c0e1ea4555a6212ac4e6d9039a4136a133e6b
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 18:07:44 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I843bdc0b9f72b4758c19e6a8ddad1368c7d80977
    Closes-Bug: #1668732

Reviewed: https://review.openstack.org/443042
Committed: https://git.openstack.org/cgit/openstack/puppet-rally/commit/?id=bbb132280939c5bdecf34e9661ae65d8e39c5acc
Submitter: Jenkins
Branch: master

commit bbb132280939c5bdecf34e9661ae65d8e39c5acc
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:53:24 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: Id0e5a1864ed18a63bd1fb392b03eb8c22ae39acc
    Closes-Bug: #1668732

Changed in puppet-rally:
status: In Progress → Fix Released
Changed in puppet-cloudkitty:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443007
Committed: https://git.openstack.org/cgit/openstack/puppet-cloudkitty/commit/?id=7a0c3d0316de2968ecc2a31e4b2f5de087815908
Submitter: Jenkins
Branch: master

commit 7a0c3d0316de2968ecc2a31e4b2f5de087815908
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 16:54:17 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I5a413e7e70b4f534a3ff20b59eba21bc5e9b40fd
    Closes-Bug: #1668732

Reviewed: https://review.openstack.org/443035
Committed: https://git.openstack.org/cgit/openstack/puppet-octavia/commit/?id=04a76970fd1c4cefdacfd39dcad14ee65f1e6fd2
Submitter: Jenkins
Branch: master

commit 04a76970fd1c4cefdacfd39dcad14ee65f1e6fd2
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:43:48 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I3f0d04677723884a28a65f469305f89311b08da2
    Closes-Bug: #1668732

Changed in puppet-octavia:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/442990
Committed: https://git.openstack.org/cgit/openstack/puppet-aodh/commit/?id=75d16a7a31f56abc4777f5a7421eaad68838f1d1
Submitter: Jenkins
Branch: master

commit 75d16a7a31f56abc4777f5a7421eaad68838f1d1
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 16:24:16 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I4392919b99e51a11896ea88d7de431d01b99f8f3
    Closes-Bug: #1668732

Changed in puppet-aodh:
status: In Progress → Fix Released
Changed in puppet-designate:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443012
Committed: https://git.openstack.org/cgit/openstack/puppet-designate/commit/?id=e837bed3ff294879b2da19156e5f8cbfc40631bf
Submitter: Jenkins
Branch: master

commit e837bed3ff294879b2da19156e5f8cbfc40631bf
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:09:33 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I9868f954a032a0014b9304526daf5476b0922c5d
    Closes-Bug: #1668732

Reviewed: https://review.openstack.org/443028
Committed: https://git.openstack.org/cgit/openstack/puppet-gnocchi/commit/?id=c8dc4eb3f7cac586078aa2bc92bbe8f56fefb3e7
Submitter: Jenkins
Branch: master

commit c8dc4eb3f7cac586078aa2bc92bbe8f56fefb3e7
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:30:29 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I5f19aec39094c446904d5517e66141401ff149ae
    Closes-Bug: #1668732

Changed in puppet-gnocchi:
status: In Progress → Fix Released
Changed in puppet-tempest:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/443043
Committed: https://git.openstack.org/cgit/openstack/puppet-tempest/commit/?id=1701be4573607230e80ff02a67066ee75b076f0f
Submitter: Jenkins
Branch: master

commit 1701be4573607230e80ff02a67066ee75b076f0f
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:58:32 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: I1338c2eef3eae705b90f2fbaa97d0734c1a2bc05
    Closes-Bug: #1668732

Reviewed: https://review.openstack.org/443040
Committed: https://git.openstack.org/cgit/openstack/puppet-panko/commit/?id=e5bc09663335e26bc06f541974da4357d73e7c56
Submitter: Jenkins
Branch: master

commit e5bc09663335e26bc06f541974da4357d73e7c56
Author: ZhongShengping <chdzsp@163.com>
Date: Wed Mar 8 17:49:31 2017 +0800

    Inconsistent package_ensure parameter name

    The parameter name used to enforce package state is inconsistent across
    manifests and modules. I settle on package_ensure since it's already
    widely used.

    Change-Id: If11b95ddb6b6748d587d96dcad522d96fd58a91d
    Closes-Bug: #1668732

Changed in puppet-panko:
status: In Progress → Fix Released

This issue was fixed in the openstack/puppet-aodh 11.0.0 release.

This issue was fixed in the openstack/puppet-barbican 11.0.0 release.

This issue was fixed in the openstack/puppet-designate 11.0.0 release.

This issue was fixed in the openstack/puppet-gnocchi 11.0.0 release.

This issue was fixed in the openstack/puppet-octavia 11.0.0 release.

This issue was fixed in the openstack/puppet-panko 11.0.0 release.

This issue was fixed in the openstack/puppet-tempest 11.0.0 release.

This issue was fixed in the openstack/puppet-trove 11.0.0 release.

This issue was fixed in the openstack/puppet-watcher 11.0.0 release.

zhongshengping (chdzsp) on 2018-02-07
Changed in puppet-ceph:
status: Confirmed → Fix Released
Changed in puppet-openstacklib:
assignee: nobody → zhongshengping (chdzsp)
status: Confirmed → Fix Released
Changed in puppet-oslo:
assignee: nobody → zhongshengping (chdzsp)
status: Confirmed → Fix Released
Changed in puppet-swift:
assignee: nobody → zhongshengping (chdzsp)
status: Confirmed → Fix Released
Changed in puppet-cinder:
status: Confirmed → Fix Released
Changed in puppet-glance:
status: Confirmed → Fix Released
Changed in puppet-glare:
status: Confirmed → Fix Released
Changed in puppet-horizon:
status: Confirmed → Fix Released
Changed in puppet-ironic:
status: Confirmed → Fix Released
Changed in puppet-keystone:
status: Confirmed → Fix Released
zhongshengping (chdzsp) on 2018-02-07
Changed in puppet-monasca:
status: Confirmed → Fix Released
Changed in puppet-neutron:
status: Confirmed → Fix Released
Changed in puppet-nova:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers