ironic-inspector dnsmasq - points to ipxe.efi, which has been renamed snponly.efi

Bug #1952652 reported by Harald Jensås
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-ironic
Fix Released
Critical
Harald Jensås

Bug Description

In change[1] manifests/pxe.pp:

- file { "${tftp_root_real}/ipxe.efi":
+ file { "${tftp_root_real}/snponly.efi":

The efi iPXE file was renamed to snponly.efi in the tftproot.
The templates for inspector dnsmasq DHCP configuration was not updated, they still point to 'ipxe.efi' which no longer exists.

[1] https://opendev.org/openstack/puppet-ironic/commit/3864e15998b5b1eec7d2b1b4911add9bb899fdb8
[2] https://opendev.org/openstack/puppet-ironic/src/branch/master/templates/inspector_dnsmasq_http.erb
[3] https://opendev.org/openstack/puppet-ironic/src/branch/master/templates/inspector_dnsmasq_tftp.erb

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (master)
Changed in puppet-ironic:
status: New → In Progress
Changed in puppet-ironic:
importance: Undecided → Critical
assignee: nobody → Harald Jensås (harald-jensas)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (master)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/819663
Committed: https://opendev.org/openstack/puppet-ironic/commit/51ea0c95eabe8dd15493dd719b8ee34079ef3bb1
Submitter: "Zuul (22348)"
Branch: master

commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287

Changed in puppet-ironic:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (stable/xena)

Fix proposed to branch: stable/xena
Review: https://review.opendev.org/c/openstack/puppet-ironic/+/819833

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (stable/xena)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/819833
Committed: https://opendev.org/openstack/puppet-ironic/commit/2688458cb0eae1b09c50417477a27a8e8dba682b
Submitter: "Zuul (22348)"
Branch: stable/xena

commit 2688458cb0eae1b09c50417477a27a8e8dba682b
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287
    (cherry picked from commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1)

tags: added: in-stable-xena
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/puppet-ironic/+/820086

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/820086
Committed: https://opendev.org/openstack/puppet-ironic/commit/806261407470b0085046314d84b394af5bbf5759
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 806261407470b0085046314d84b394af5bbf5759
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Backport note:
    In stable/wallaby and older, the default uefi_ipxe_bootfile_name is
    ipxe.efi(this was updated during Xena cycle), so the inconsistent usage
    doesn't happen by default. However support for customizing
    uefi_ipxe_bootfile_name is incomplete and it is fixed by this change.

    Conflicts:
            manifests/inspector.pp

    Resolved conflict caused by c7966378a036a58018ec0c1155ee6b58f52a49ca

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287
    (cherry picked from commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1)
    (cherry picked from commit 2688458cb0eae1b09c50417477a27a8e8dba682b)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (stable/victoria)

Fix proposed to branch: stable/victoria
Review: https://review.opendev.org/c/openstack/puppet-ironic/+/821261

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (stable/ussuri)

Fix proposed to branch: stable/ussuri
Review: https://review.opendev.org/c/openstack/puppet-ironic/+/821262

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (stable/ussuri)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/821262
Committed: https://opendev.org/openstack/puppet-ironic/commit/0f3581d3b577814d11c14be28269adc617b5e576
Submitter: "Zuul (22348)"
Branch: stable/ussuri

commit 0f3581d3b577814d11c14be28269adc617b5e576
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Backport note:
    In stable/wallaby and older, the default uefi_ipxe_bootfile_name is
    ipxe.efi(this was updated during Xena cycle), so the inconsistent usage
    doesn't happen by default. However support for customizing
    uefi_ipxe_bootfile_name is incomplete and it is fixed by this change.

    Conflicts:
            manifests/inspector.pp

    Resolved conflict caused by c7966378a036a58018ec0c1155ee6b58f52a49ca

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287
    (cherry picked from commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1)
    (cherry picked from commit 2688458cb0eae1b09c50417477a27a8e8dba682b)
    (cherry picked from commit 806261407470b0085046314d84b394af5bbf5759)
    (cherry picked from commit d33a9f68d57a1c5cf391bd12cdbae8075991222a)

tags: added: in-stable-ussuri
tags: added: in-stable-victoria
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (stable/victoria)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/821261
Committed: https://opendev.org/openstack/puppet-ironic/commit/d33a9f68d57a1c5cf391bd12cdbae8075991222a
Submitter: "Zuul (22348)"
Branch: stable/victoria

commit d33a9f68d57a1c5cf391bd12cdbae8075991222a
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Backport note:
    In stable/wallaby and older, the default uefi_ipxe_bootfile_name is
    ipxe.efi(this was updated during Xena cycle), so the inconsistent usage
    doesn't happen by default. However support for customizing
    uefi_ipxe_bootfile_name is incomplete and it is fixed by this change.

    Conflicts:
            manifests/inspector.pp

    Resolved conflict caused by c7966378a036a58018ec0c1155ee6b58f52a49ca

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287
    (cherry picked from commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1)
    (cherry picked from commit 2688458cb0eae1b09c50417477a27a8e8dba682b)
    (cherry picked from commit 806261407470b0085046314d84b394af5bbf5759)

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (stable/train)

Fix proposed to branch: stable/train
Review: https://review.opendev.org/c/openstack/puppet-ironic/+/823615

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (stable/train)

Reviewed: https://review.opendev.org/c/openstack/puppet-ironic/+/823615
Committed: https://opendev.org/openstack/puppet-ironic/commit/3c15a738cecfbd19e376181685a1fcb9f5b98b2c
Submitter: "Zuul (22348)"
Branch: stable/train

commit 3c15a738cecfbd19e376181685a1fcb9f5b98b2c
Author: Harald Jensås <email address hidden>
Date: Mon Nov 29 18:43:05 2021 +0100

    Fix name of iPXE efi bootrom

    In change Ia30aff290ec24972f387612851f8f630ddc9403b
    the file in tftproot was renamed from ipxe.efi to
    snponly.efi. Later in the filename was parameterized
    in change I565e3ae6388812c358e86fac49b17e0cce97b9df.

    The dnsmasq DHCP configuration was not updated to
    point to use the new filename, nor the parameter.

    This change adds 'uefi_ipxe_bootfile_name' to
    ironic::pxe::common, updates the other manifests to
    use ironic::pxe::common::uefi_ipxe_bootfile_name if
    set.

    Also add the 'uefi_ipxe_bootfile_name' parameter to
    the ironic::inspector class and update the dnsmasq
    DHCP tempalte to use the parameter.

    Backport note:
    In stable/wallaby and older, the default uefi_ipxe_bootfile_name is
    ipxe.efi(this was updated during Xena cycle), so the inconsistent usage
    doesn't happen by default. However support for customizing
    uefi_ipxe_bootfile_name is incomplete and it is fixed by this change.

    Conflicts:
            manifests/inspector.pp

    Resolved conflict caused by c7966378a036a58018ec0c1155ee6b58f52a49ca

    (to train)
    Conflicts:
            manifests/drivers/pxe.pp
            manifests/inspector.pp
            spec/classes/ironic_inspector_spec.rb

    Closes-Bug: #1952652
    Change-Id: I1b3ccd8ad8f3ce66c66c58b1dfdca158d749c287
    (cherry picked from commit 51ea0c95eabe8dd15493dd719b8ee34079ef3bb1)
    (cherry picked from commit 2688458cb0eae1b09c50417477a27a8e8dba682b)
    (cherry picked from commit 806261407470b0085046314d84b394af5bbf5759)
    (cherry picked from commit d33a9f68d57a1c5cf391bd12cdbae8075991222a)
    (cherry picked from commit 0f3581d3b577814d11c14be28269adc617b5e576)

tags: added: in-stable-train
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ironic 16.5.0

This issue was fixed in the openstack/puppet-ironic 16.5.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ironic 20.1.0

This issue was fixed in the openstack/puppet-ironic 20.1.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ironic 18.6.0

This issue was fixed in the openstack/puppet-ironic 18.6.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ironic 17.5.0

This issue was fixed in the openstack/puppet-ironic 17.5.0 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers