provider implementation to retrive credentials is not consistent

Bug #1872691 reported by Takashi Kajinami on 2020-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-glance
Low
Takashi Kajinami

Bug Description

While we have some puppet modules which implements providers to access to OpenStack API, all of them have inconsistent implementation to load keystone credentials.

We should use the same consistent implementation for all modules so that we can more easily maintain these codes.

no longer affects: puppet-cinder
no longer affects: puppet-neutron
no longer affects: puppet-nova
Takashi Kajinami (kajinamit) wrote :

Seems like only puppet-glance has outdated implementation now.
Remove the other puppet modules from affected projects.

Changed in puppet-glance:
status: New → Confirmed
importance: Undecided → Low
Changed in puppet-glance:
assignee: nobody → Takashi Kajinami (kajinamit)
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/719759
Committed: https://git.openstack.org/cgit/openstack/puppet-glance/commit/?id=066f45758d974bb6343c0b92583c8185ef588823
Submitter: Zuul
Branch: master

commit 066f45758d974bb6343c0b92583c8185ef588823
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 14 17:20:19 2020 +0900

    Fix broken Puppet::Provider::Glance

    This patch fixes Puppet::Provider::Glance, broken because it still
    depends on glance_store/os_region_name, which was removed in [1].

    This patch also updates outdated provider implementation, and introduce
    the implementetion consisntent with other modules like puppet-nova or
    puppet-neutron.

    [1] 9e82f598ad86d99a5bc356ba5c118a52a1d5d9bc

    Closes-Bug: #1872656
    Closes-Bug: #1872691
    Change-Id: I1dfcb311c10c633788c24484c21277255b60e4e5

Changed in puppet-glance:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/720618
Committed: https://git.openstack.org/cgit/openstack/puppet-glance/commit/?id=43f3d5eab2b282d5baa6449f775ed64ee8eb59d6
Submitter: Zuul
Branch: stable/train

commit 43f3d5eab2b282d5baa6449f775ed64ee8eb59d6
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 14 17:20:19 2020 +0900

    Fix outdated get_glance_crednetials in Puppet::Provider::Glance

    This patch is a cherry pick of the change in master[2] to update
    outdated provider implementation, and introduce the implementetion
    consisntent with other modules like puppet-nova or puppet-neutron.

    [1] 066f45758d974bb6343c0b92583c8185ef588823

    Closes-Bug: #1872691
    Change-Id: I1dfcb311c10c633788c24484c21277255b60e4e5

tags: added: in-stable-train
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers