Puppet::Provider::Glance is broken because of missing os_region_name

Bug #1872656 reported by Takashi Kajinami on 2020-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-glance
Undecided
Takashi Kajinami

Bug Description

Current Puppet::Provider::Glance always fails with
 "File: /etc/glance/glance-api.conf does not contain all required sections."
because [glance_store]os_region_name is not set now.

[1] https://github.com/openstack/puppet-glance/commit/9e82f598ad86d99a5bc356ba5c118a52a1d5d9bc

We observe the failure in rdo job.
 https://logserver.rdoproject.org/ci.centos.org/weirdo-generic-packstack-scenario001/9012/weirdo-project/logs/latest/manifests/192.168.1.8_controller.pp.log.txt.gz

description: updated
Changed in puppet-glance:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.opendev.org/719759

Changed in puppet-glance:
assignee: nobody → Takashi Kajinami (kajinamit)
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/719759
Committed: https://git.openstack.org/cgit/openstack/puppet-glance/commit/?id=066f45758d974bb6343c0b92583c8185ef588823
Submitter: Zuul
Branch: master

commit 066f45758d974bb6343c0b92583c8185ef588823
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 14 17:20:19 2020 +0900

    Fix broken Puppet::Provider::Glance

    This patch fixes Puppet::Provider::Glance, broken because it still
    depends on glance_store/os_region_name, which was removed in [1].

    This patch also updates outdated provider implementation, and introduce
    the implementetion consisntent with other modules like puppet-nova or
    puppet-neutron.

    [1] 9e82f598ad86d99a5bc356ba5c118a52a1d5d9bc

    Closes-Bug: #1872656
    Closes-Bug: #1872691
    Change-Id: I1dfcb311c10c633788c24484c21277255b60e4e5

Changed in puppet-glance:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers