Comment 6 for bug 1493442

Reviewed: https://review.openstack.org/221644
Committed: https://git.openstack.org/cgit/openstack/puppet-glance/commit/?id=bce0eac01c193f565e1b915c9002725800b9a069
Submitter: Jenkins
Branch: master

commit bce0eac01c193f565e1b915c9002725800b9a069
Author: Dan Prince <email address hidden>
Date: Tue Sep 8 13:00:53 2015 -0400

    Autorequire correct package based on the distro

    Some distros (RHEL based) have a single glance package. On those
    distros the ensure_package/autorequire stuff doesn't quite work
    correctly as per the type code it is assumed two packages 'glance-api'
    and 'glance-registry'

    This commit makes sure that on RHEL based distros type only autorequire
    'openstack-glance' while on other distros it correctly autorequire
    'glance-api' and 'glance-registry'

    Change-Id: I17c84b2282beadaec80f4db42fa5696b7967159f
    Closes-bug: #1493442
    Co-Authored-By: Yanis Guenane <email address hidden>