No sound in ekiga when used with Pulse Audio

Bug #382234 reported by luca
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ekiga
Expired
High
PulseAudio
New
Undecided
Unassigned
ekiga (Ubuntu)
Low
Unassigned
pulseaudio (Fedora)
Fix Released
High

Bug Description

Binary package hint: ekiga

sound and mic work perfectly with other applications like sound recorder and skype. ubuntu jaunty on same pc with intrepid ekiga worked fine

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/ekiga
Package: ekiga 3.2.0-0ubuntu2
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: ekiga
Uname: Linux 2.6.28-12-generic i686

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

When using ekiga with pulseaudio, the audio is garbled and there is tons of spew in the log. Turning off (or bypassing) pulseaudio makes ekiga work again. I'm not sure who's fault it is, but I've attached a log from ekiga.

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

Created attachment 334820
ekiga log

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Which output did you select in ekiga?

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Also, what kind of 'spew' is in the logs?

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

I kept all defaults (i.e. "Default"). This should work out of the box, no?

The logs are attached, look for yourself.

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Logs? I only see ekiga logs...

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Hmm, those ekiga logs are not helpful at all. Comparing them with the actual code shows that those messages actually hide the actual cause of the problem.

http://www.opalvoip.org/websvn/filedetails.php?repname=Opal&path=%2Fptlib%2Ftrunk%2Fplugins%2Fsound_alsa%2Fsound_alsa.cxx

Most likely these are just underruns.The PA log output (with -vvvv) could prove that.

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

Sorry, pulseaudio logs attached (pulseaudio -vvvv 2>pulse.log).

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

Created attachment 337369
Log from pulse audio during an ekiga session which exhibits the symptoms

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

Any update?

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Hmm, it seems as if Ekiga misbheaves and underruns all the time and even reconnects. No clue. If I'd knew how to reproduce this I'd have a closer look.

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

1. Install ekiga
2. Sign up for an ekiga.net account
3. Make a call to <email address hidden> (the ekiga echo test)

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

That behaves correctly here, that's the problem.

Revision history for this message
In , Martin (martin-redhat-bugs) wrote :

same problem. to reproduce:

a ) start ekiga
b ) call <email address hidden>

I'm using the hda_intel driver. I noticed such output in dmesg:

ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32

It seems to depend on if an other application is accessing Pulseaudio. Because when Ekiga runs only, it works fine. When I have Rhythmbox running, play music, then start Ekiga and run the test, I have that bug. Would be nice if you could look into it. I'll also attach my pulse.log

Revision history for this message
In , Martin (martin-redhat-bugs) wrote :

Created attachment 344150
pulse.log

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

I too am using hda_intel... perhaps this is a driver bug?

Revision history for this message
luca (l-savio) wrote :
Revision history for this message
In , Bug (bug-redhat-bugs) wrote :

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Revision history for this message
In , Martin (martin-redhat-bugs) wrote :

whats up there? this bugs renders ekiga, a application that is shipped by default, completly unusable in a stable fedora release. i am a little bit disappointed.

Revision history for this message
In , Richard (richard-redhat-bugs) wrote :

Eugen Dedu mentions a couple things that might rectify this in the upstream bug[1]: A recent fix in opalvoip and the adventure of a pulse ptlib audio plugin. Due to a recent audio issue with Fedora[2], my audio sounds like hell and dies very quickly, so I'm not sure if my negative experiences with opal/ptlib/ekiga from HEAD are still related to this, or my new issue.

1. http://bugzilla.gnome.org/show_bug.cgi?id=586034
2. https://bugzilla.redhat.com/show_bug.cgi?id=506075

Revision history for this message
In , Matěj (matj-redhat-bugs) wrote :

Actually, according to http://bugzilla.gnome.org/show_bug.cgi?id=586034#c3 it might be worthy to upgrade opal (again), apparently it grew pulse audio plugin in meanwhile.

Revision history for this message
In , Eugen (eugen-redhat-bugs) wrote :

Hi,

"worthy to upgrade opal": Upgrading to opal/ekiga from unstable is not a good idea, as there are still a few important bugs to fix. Instead, you could add the ptlib pulse plugin as a patch (note: I have not compiled it against the stable version).

As for the the audio fix, you could also wait a few days (max one week), until 3.2.6 appears, it's as you wish.

Revision history for this message
In , Peter (peter-redhat-bugs) wrote :

(In reply to comment #19)
> Actually, according to http://bugzilla.gnome.org/show_bug.cgi?id=586034#c3 it
> might be worthy to upgrade opal (again), apparently it grew pulse audio plugin
> in meanwhile.

It has the support in the trunk. there is no stable release. It will go into rawhide when there is an ekiga 3.3 devel release but that will unlikely be for F-12. I had a look at just pulling in the pulseaudio support but it didn't work well (generally just locked up ekiga entirely)

Revision history for this message
In , Matěj (matj-redhat-bugs) wrote :

(In reply to comment #20)
> "worthy to upgrade opal": Upgrading to opal/ekiga from unstable is not a good
> idea, as there are still a few important bugs to fix. Instead, you could add
> the ptlib pulse plugin as a patch (note: I have not compiled it against the
> stable version).

Thanks for jumping here, even though my silly comments on b.g.o.

Revision history for this message
Yannick Defais (sevmek) wrote :

Hi,

I suspect an issue involving pulse audio.

Upstream is in the process of adding a pulse audio plugin, this might solve the issue.

Best regards,
Yannick

Changed in ekiga (Ubuntu):
status: New → In Progress
Revision history for this message
luca (l-savio) wrote :

Thanks:), will wait. next month I will try with karmic.

Revision history for this message
Yannick Defais (sevmek) wrote :

Thank you. :-)

Revision history for this message
In , Eugen (eugen-redhat-bugs) wrote :

From http://mail.gnome.org/archives/ekiga-list/2009-August/msg00054.html:

> > 2) I have pulseaudio running on my system and I have to use the
> > "Default" (PTLIB/ALSA) sink therefore, but my card (and webcam) are
> > constantly bombarded. If I have pavucontrol open and test any sound from
> > Ekiga, the cpu goes to 99% activity and I have to kill he stream.
> >
>
> Does it work better without pulse audio? If so, please report a bug to
> pulse audio.

Indeed if I kill the server or run with pasuspender and access the
soundcard directly then I don't see any difference in the audio quality
but I don't get the problems mentioned above. These issues are the usual
ones with Skype as well.

Changed in ekiga (Ubuntu):
importance: Undecided → Low
status: In Progress → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in ekiga (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
luca (l-savio) wrote :

Well, just tell me which are the missing information you need and I will send them.

Thanks :-)

Revision history for this message
In , Adam (adam-redhat-bugs) wrote :

Do we have a clear handle yet on the exact intersection of PA / Ekiga / kernel driver for this issue? FWIW, I use Ekiga 3.2.6 with Opal 3.6.6 in current F12, via a USB headset (so snd-usb-audio), and have not had any problem.

Lennart, is there sufficient information yet to pin down what's the source of trouble here? What other information might you need?

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Revision history for this message
In , Matěj (matj-redhat-bugs) wrote :

Actually, this might be really fixed. I have done extensive testing various SIP/Jingle clients (including ekiga) in the last month, and I haven't met any problems with Pulseaudio running.

Let's close it for now.

Revision history for this message
In , Lennart (lennart-redhat-bugs) wrote :

Okeydokey. Closing.

Revision history for this message
In , Adam (adam-redhat-bugs) wrote :

matej: were you testing on F11 or F12?

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Revision history for this message
In , Nathaniel (nathaniel-redhat-bugs) wrote :

I can confirm, works well for me on F12.

Revision history for this message
In , Adam (adam-redhat-bugs) wrote :

nathaniel: that's not a 'confirmation', this bug is for F11. it's possible for it to be OK on f12 but not on f11, since Ekiga in f12 is apparently using PulseAudio directly, while Ekiga on f11 is not.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Revision history for this message
In , Peter (peter-redhat-bugs) wrote :

(In reply to comment #29)
> nathaniel: that's not a 'confirmation', this bug is for F11. it's possible for
> it to be OK on f12 but not on f11, since Ekiga in f12 is apparently using
> PulseAudio directly, while Ekiga on f11 is not.

Ekiga in F-12 is using exactly the same methods and version for the audio as F-11. There's no difference in the packages. Real PulseAudio support in ekiga is not due until 3.4.x. If audio works better in F-12 rather than F-11 that is due to improvements in PulseAudio as the ekiga versions are for all intents and purposes identical.

Revision history for this message
In , Matěj (matj-redhat-bugs) wrote :

(In reply to comment #27)
> matej: were you testing on F11 or F12?

F12, but I think comment 30 is right ... it is irrelevant as far as Ekiga itself goes (of course, Pulseaudio in F11 is probably quite different than what F12 has). OTOH, this was closed with NEXTRELEASE, which may be an honest assesment of the situation. I don't know.

Revision history for this message
In , Adam (adam-redhat-bugs) wrote :

Ah, I see, thanks Peter - I misunderstood from earlier discussion that F12's Ekiga used a newer opal which did direct PA support, but F11's didn't. Thanks for the correction.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Revision history for this message
Oleksiy Krivoshey (oleksiyk) wrote :

I can confirm the problem - no sound from Ekiga since switched to Karmic. Even when simply using 'neighbors' connection between two PCs. What information do you need?

Revision history for this message
Oleksiy Krivoshey (oleksiyk) wrote :

>> We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments.

please show us which exactly comments describe the information you need from us? I don't see any.

Changed in ekiga (Ubuntu):
status: Invalid → New
Revision history for this message
Yannick Defais (sevmek) wrote :

Hi,

Would you be kind enough to check if the issue is the interaction with Pulse Audio?

The test I propose you is to disable pulse audio, then try to place a call to see if it makes any difference:

First kill pulseaudio:
$ pulseaudio -k

Remove the pulseaudio package:
$ sudo aptitude remove pulseaudio
(it will probably remove the meta package ubuntu-desktop, please note down any other package as you might need to reinstall them)

Run the Monitor System application (under Administration->Monitor
system) and make sure there is no pulseaudio process in the Process tab.
If it is there, kill it.

Run (or restart) Ekiga
Place the call using Ekiga.

To reinstall the system you can use:
$ sudo aptitude install ubuntu-desktop

And finally restart pulseaudio:
$ pulseaudio -D

Best regards,
Yannick

Revision history for this message
Oleksiy Krivoshey (oleksiyk) wrote :

Hi,

Yes, it works fine with pulseaudio disabled for me.

Yannick Defais (sevmek)
Changed in ekiga (Ubuntu):
status: New → Confirmed
summary: - No sound in ekiga
+ No sound in ekiga when used with Pulse Audio
Revision history for this message
Yannick Defais (sevmek) wrote :

Upstream related bug report in Ekiga:
https://bugzilla.gnome.org/show_bug.cgi?id=586034

Revision history for this message
Yannick Defais (sevmek) wrote :

This issue seems to be fixed in Fedora 12:
https://bugzilla.redhat.com/show_bug.cgi?id=489724#c25

Changed in pulseaudio (Fedora):
status: Unknown → Fix Released
Revision history for this message
Julian S (julian-suddaby) wrote :

I'm having the same problem on Karmic amd64. Upgraded from Jaunty, and everything still works fine sound-wise (VLC, Audacity, Skype) with PulseAudio except for Ekiga. This seems a big deal to me...

Changed in ekiga (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Alex (dinesh-email) wrote :

@Yannick: it worked for me what can i do now for make it running? can i configure ekiga for running without pluse audio?

thak you
Alex

Revision history for this message
Yannick Defais (sevmek) wrote :

@Alex,

You can try this:
$ pasuspender -- ekiga
But I tried it on 9.04 and it was not working, *maybe* it works now on 9.10 (I'm quite busy atm and unfortunately I cannot run tests). Otherwise, you'll need to go using our trunk version which has a preALPHA pulse audio plugin.

Best regards,
Yannick

Revision history for this message
Julian S (julian-suddaby) wrote :

Ekiga now works for me with the suspended pulseaudio trick from #15. Thanks!

Revision history for this message
Stefan (stefan-satzenhofer) wrote :

For me there is no diffrence between running ekiaga with or without pasuspender. CPU ussage goes up to 100 % an sound comes soemtimes 'cripled' and soemtimes not at all. didnt try to build the sources from trunk yet. Maybe its possible to do a fix like in Fedora?

Revision history for this message
Yesid Carrillo (yecarrillo) wrote :

Try open (forward) 5060 and 1720 ports in your router as per
http://wiki.ekiga.org/index.php/Internet_ports_used_by_Ekiga

To solve the frontal mic issue, just upgrade your ALSA manually using this script. I doesn't hurt your ALSA packages.
http://dl.getdropbox.com/u/1113424/webupd8/AlsaUpgrade-1.0.x-rev-1.17.tar

For details about this script:
http://ubuntuforums.org/showthread.php?p=6589810#post6589810

Revision history for this message
Stefan (stefan-satzenhofer) wrote :

Hi Carrillo,

thanks for your suggestion. but forwarding the port didnt change anything. Also using the script to download and install the latest alsa disdnt change anything, but disabling the sound in firefox.

Revision history for this message
Stefan (stefan-satzenhofer) wrote :

Stange, strange,

after redo the changes in ALSA via the script everything worked fine for me, except of the front-mic. Seems like something was wrong with the ALSA-Installation after the update.

Revision history for this message
benste (benste) wrote :

HI guys, looks like the issue isn't solved yet, I'm still having the problem but I'm not sure whether it's the very same - cause incomming calls get a ringing tone and my mic is wokring - I just don't hear the one talking on the other end.

Revision history for this message
berend (berenddeboer) wrote :

Same problem here. I'm on karmic, first time I've used Ekiga. Even when I go to sound preferences and play a sound it doesn't work. All output/input devices are set to Default (PTLIB/ALSA). When I make a sound, Ekiga shows up in the playback tab of the pulse volume control, but no sound.

Skype working fine here as well as any other audio.

Revision history for this message
berend (berenddeboer) wrote :

Even upgraded to Ekiga 3.2.6, same thing:

I started it with root, in case there were permission problems. With "-d 1" this is what I get:

2010/05/15 07:56:15.652 0:21.276 AudioEvent...0xb75ccb70 AudioOutputCoreNo secondary audiooutput device defined, trying primary
2010/05/15 07:56:15.726 0:21.349 AudioEvent...0xb75ccb70 ALSA Could not write 0 1764 Success
2010/05/15 07:56:15.780 0:21.403 AudioEvent...0xb75ccb70 ALSA Could not write 0 1764 Success
2010/05/15 07:56:15.805 0:21.429 AudioEvent...0xb75ccb70 ALSA Could not write 0 1764 Success
2010/05/15 07:56:15.809 0:21.433 AudioEvent...0xb75ccb70 ALSA Could not write 0 1764 Success
2010/05/15 07:56:15.812 0:21.436 AudioEvent...0xb75ccb70 ALSA Could not write 0 1764 Success

(same messages with 3.2.5) and this is just trying to play a sound in sound events preferences.

Revision history for this message
berend (berenddeboer) wrote :

At one point I got a scream of highly distorted (played way too fast I reckon) sound. That's all.

Changed in ekiga:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
benste (benste) wrote :

i don't have any issues anymore - 3.2.7
and unsubscribe from this bug report -- you might update you own status as well and check if this bug isn't resolved

Changed in ekiga:
status: Confirmed → Incomplete
Changed in ekiga:
status: Incomplete → Expired
Changed in pulseaudio (Fedora):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.