pidgin freezes while typing a message

Bug #162701 reported by totoki on 2007-11-14
This bug affects 10 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Nominated for Jaunty by Christopher Berner

Bug Description

Binary package hint: pidgin

pidgin just keeps freezing. i have the sounds turned on and ALSA as my sound system (i'm telling this since i think it's got something to do with that). and i'm listening to music with xmms besides.
my output of pidgin --debug is attached.

totoki (a20-totoki) wrote :
Siegfried Gevatter (rainct) wrote :

It also froze many times here, and it kept printing similar messages repeated a lot of times when running it from the terminal:

(pidgin:9106): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

sh: jackd: not found

(pidgin:9106): GStreamer-CRITICAL **:
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.

(pidgin:9106): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:9106): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

Changed in pidgin:
importance: Undecided → Medium
Marek Vančo (marek.vanco) wrote :

I confirm.
Pidgin freeze when roll animation (new message / new line) and the new message is sending from me at this moment.

totoki (a20-totoki) wrote :

well the solution is:

turn off your sounds in pidgin completely. it's got to do something with the busy alsa driver or oss. setup dmix and it should be fine. (see mandriva 2008;-) ...)

der_vegi (m-may) wrote :

I also have the same problem on Hardy (amd64) using pulseaudio. Here is a backtrace. I cannot upload the crash-report as my proxy settings are ignored, so I'll also attach the crash file.

der_vegi (m-may) wrote :
der_vegi (m-may) wrote :

Works for me in Hardy now. I think, the pulseaudio and the settings for it were updated.

Can someone else confirm it's fixed in Hardy ?

Changed in pidgin:
status: New → Incomplete
Siegfried Gevatter (rainct) wrote :

I don't experience this anymore but I'm not using Pidgin much last time so I couldn't really tell...

Siegfried Gevatter (rainct) wrote :

I don't experience this anymore but I'm not using Pidgin much last time so I can't really tell...

I experience the problem in hardy. It could also have something to do with firefox, which doesn't respont often either.
Sry for my probably bad english:)

sandaili (me-sandaili) wrote :

I updated all of my system (yum update) and this keeps happening. Never had an issue before. I will try turning off my sounds, I guess. Fedora 64 bit version 9.


Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you try with version 2.5.1 from my ppa?

Mathieu Marquer (slasher-fun) wrote :

Same behavior with me (including the messages in the console), Ubuntu Intrepid up-to-date, I didn't change the default install regarding PulseAudio and the sound system.

xenesis (wagner-sim88) wrote :

I have the same error here. Pidgin freezes if it tries to play the sound:
(21:59:25) oscar: Sent message to 367285685.
(21:59:25) gstreamer: Failed to connect stream: Invalid argument

I have no sound devices at the moment, so it was unable to play the sound. This seems to lead to a program deadlock

Jared Bunting (jared-bunting) wrote :

I'm having a similar issue in Intrepid. When running in debug mode, I attempt to "Preview" a sound from the Preferences dialog, and I get the following output:

dns[8352]: nobody needs me... =(
dns[8351]: nobody needs me... =(
dns[8350]: nobody needs me... =(
(10:12:31) gstreamer: Failed to connect stream: Invalid argument
dns[8353]: nobody needs me... =(

rihasant (riku.hs) wrote :

This bug is also related to pulseaudio. You can demonstrate this by killing pulseaudio, which makes all applications that use sound work normal again. It's quite sad to see no progress on making pulseaudio handle this kind of situations. See somehow related bugs #226692, #230837.

Next time you encounter the bug try following:
$ pidof pulseaudio
$ kill -9 6163
...and to restart pulseaudio type Alt+F2 ... pulseudio

It's an ugly workaround, but it works at least for me.

Caspar Adriani (thecas) wrote :

I have the same problem, my sound device is not supported by 8.10 and pidgin kept on freezing. Disabling all the sounds solved the problem for me.

ericmc783 (ericmc783) wrote :

I was having a very similar issued as described here. I could launch pidgin, and double-click on a contact to send a message, but as soon as i press enter to send the message, the app freezes, and I have to force quit.

Going to: Tools | Preferences | Sounds and setting the method to "No Sounds" resolved it for me.

Thanks to all who have helped.

Scott Ritchie (scottritchie) wrote :

Marking triaged and high priority since this bug (with PulseAudio causing crashes in Intrepid Pidgin) is quite severe and in a part of the main desktop

Changed in pidgin:
importance: Medium → High
status: Incomplete → Triaged
Ole Rasmussen (eluminex) wrote :

I'm also experiencing this. Pidgin freezes on me when I open a new IM window or sometimes it won't freeze until I send an IM.
Disabling the sounds (Tools -> Preferences -> Method -> No sounds) fixes the issue.

Running Ubuntu Intrepid x64 with an X-FI XtremeMusic soundcard. It's currently not fully supported (I didn't install the buggy drivers yet) so I have no sound devices in Ubuntu.

Aaron Brady (bradya) wrote :


It crashes 100% of the time on a machine with no soundcard (myself and another colleague previously thought this was down to running on 64bit, as we'd used 32bit Pidgin fine on another machine, turns out the common factor was a lack of soundcard + pulseaudio)

maddiekun (madison-leigh) wrote :

my pidgin won't let me instant message after like, 10 seconds.

Hew (hew) wrote :

Received this for the first time with an upgrade to pidgin 1:2.5.5-1ubuntu1 and pulseaudio 0.9.14-0ubuntu11. "pulseaudio -k" fixes the issue.

Christopher Berner (cberner) wrote :

I'm having the same problem, but I can usually send a few (sometimes even dozens of) messages before it freezes. I will try killing pulseaudio next time it happens.

Stas Sușcov (sushkov) wrote :

Pidgin freezes.
Using updated jaunty!

Stas Sușcov (sushkov) wrote :

This might be a solution if you're in jaunty:

Just kill all of your evolution processes!

Christopher Berner (cberner) wrote :

pulseaudio is definitely not the problem for me. but I removed the evolution package and my problem seems to be fixed now, so I suspect that this is an issue with the evolution integration plugin or the evolution-data-server. I noticed that everytime pidgin froze the evolution-data-server was using 100% of my CPU, and I had to kill it

Christopher Berner (cberner) wrote :

This bug was completely solved by uninstalling Evolution. I believe this is not actually a bug in Pidgin.

Robinson Tryon (colonelqubit) wrote :

Pidgin had been working fine for me, but suddenly stopped working in the last couple of days. I could log on to a jabber server without problem, but logging on to IRC (Freenode) would cause the window to hang as soon as I logged in.

After running pidgin on the command line, I found the same gstreamer error:
tryon@mash:~$ pidgin -d | tee pidgin-debug.log

Got me:
(12:34:17) gstreamer: Failed to connect stream: Invalid argument

Disabling sounds (Preferences -> Sounds -> Mute Sounds) fixed the problem for me.

Here's what I'm running:
Ubuntu 8.10 x86_64 (no restricted drivers; fully up to date)
Pidgin 2.5.2 (1:2.5.2-0ubuntu1.1)
Dell XPS m1530 laptop

I'd be happy to upgrade to Jaunty and do some testing to help squash this bug.

Robinson Tryon (colonelqubit) wrote :

Upgrading my system to Ubuntu 9.04 x86_64 (pidgin 1:2.5.5-1ubuntu8) has fixed the problem for me.

To be specific: I can now uncheck "Mute Sounds" and Pidgin will play a happy "do-DOO" sound when it starts up and (automatically) logs into to Freenode.

It's entirely possible that it was not the upgrade to pidgin but something else (maybe Evolution, as raccoonone suggests) that fixed this problem.

darvids0n (darvids0n) wrote :

Confirming the fix of setting "Tools -> Preferences -> Sounds -> No Sounds" in Pidgin for "random" crashes (after sending a message.. EVERY message). This only started happening after I purged config files following another annoying repeat crash bug, after receiving a message in a window that is out of focus. Seemed to occur more frequently if pidgin-libnotify was in use (Jaunty notifications). I'm quite sure it has something to do with pulseaudio now. I never liked that thing..

My crashes occured like this:
Starting program: /usr/bin/pidgin
[Thread debugging using libthread_db enabled]
[New Thread 0x7f886495a7d0 (LWP 18347)]
[New Thread 0x7f8848b3f950 (LWP 18367)]
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
[New Thread 0x7f884323a950 (LWP 18376)]
[New Thread 0x7f8842834950 (LWP 18377)]
[New Thread 0x7f8842033950 (LWP 18378)]
[Thread 0x7f8842033950 (LWP 18378) exited]
[Thread 0x7f8842834950 (LWP 18377) exited]
[Thread 0x7f884323a950 (LWP 18376) exited]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f8848b3f950 (LWP 18367)]
0x00007f8842dfe610 in ?? ()
(gdb) bt
#0 0x00007f8842dfe610 in ?? ()
#1 0x00007f886155e459 in start_thread () from /lib/
#2 0x00007f88612cafcd in clone () from /lib/
#3 0x0000000000000000 in ?? ()

Yeah. In start_thread. How bad is that?! If pthread is throwing exceptions you almost want to reinstall the OS.

komputes (komputes) wrote :

I can't seem to reproduce this.Can anyone confirm that Pidgin in either Hardy, Intrepid or Jaunty still freezes for them when typing or when playing a sound effect?

To confirm that this is still an issue, update your system using System > Administration > Update Manager
Once that is done, run pidgin from a terminal, if you get an error like this in the terminal before the crash, please confirm you are still experiencing this bug:
(pidgin:####): GStreamer-CRITICAL

If you are one of the people who said removing evolution fixed your bug, I think you are not suffering from this bug. Instead you should subscribe to the following bug which explains the issue between evolution and pidgin:

komputes (komputes) wrote :

As there has not be a comment for two months and that I can no longer reproduce the issue, I will assume nobody is having issues with pidgin freezing while typing a message or when a sound effect is played.

If any of the subscribers to this bug can confirm that it is still an issue, please reopen this bug and report it to pidgin upstream or link it to an existing upstream bug on

Changed in pidgin (Ubuntu):
status: Triaged → Incomplete
Changed in pulseaudio:
status: New → Incomplete
arky (arky) wrote :

Able reproduce this problem in lucid, esp when you start video/audio chat .

(01:27:35) jingle-rtp: jingle_rtp_codecs_changed_cb: session_id: audio-session jingle_session: 0x9b5a350
(01:27:35) media: got new local candidate: 1
(01:27:35) media: got new local candidate: 1
(01:27:35) media: got new local candidate: 2
(01:27:35) media: got new local candidate: 2
(01:27:35) media: farsight-component-state-changed: component: 1 state: GATHERING
(01:27:35) media: farsight-component-state-changed: component: 2 state: GATHERING
(01:27:35) mediamanager: gst pipeline error: Cannot identify device '/dev/video1'.
(01:27:35) mediamanager: Debug details: v4l2_calls.c(488): gst_v4l2_open (): /GstPipeline:pipeline0/GstBin:vvconfig-videosrc/GstV4l2Src:vvconfig-videosrc:
system error: No such file or directory
(01:27:35) media: Error with your webcam
(01:27:35) gtkmedia: state: 2 sid: (null) name: (null)
(01:27:35) gtkmedia: pidgin_media_dispose
(01:27:35) gtkmedia: pidgin_media_dispose
(01:27:35) gtkmedia: pidgin_media_finalize
(01:27:35) jingle-rtp: state-changed: state 2 id: (null) name: (null)
(01:27:35) media: purple_media_dispose
(01:27:35) media: purple_media_finalize
(01:27:35) mediamanager: gst pipeline error: Cannot identify device '/dev/video1'.
(01:27:35) mediamanager: Debug details: v4l2_calls.c(488): gst_v4l2_open (): /GstPipeline:pipeline0/GstBin:vvconfig-videosrc/GstV4l2Src:vvconfig-videosrc:
system error: No such file or directory
dns[6021]: nobody needs me... =(
dns[6023]: nobody needs me... =(

komputes (komputes) wrote :

@arky - These symptoms do not have the same output and are most likely caused by different code. Please reproduce the issue, if a crash happens let apport report it otherwise use the command 'ubuntu-bug pidgin' to report the bug. Thank you.

Mynk (mr-mynk) wrote :

I see this issue on Lucid. I have not noticed it in Karmic or Intrepid if I remember right. Disabling sounds worked for me as well -

Going to: Tools | Preferences | Sounds and setting the method to "No Sounds" resolved it for me.

Daniel T Chen (crimsun) wrote :

Mynk, please get a backtrace when it crashes.

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at . Thanks again and we appreciate your help.

Launchpad Janitor (janitor) wrote :

[Expired for pidgin (Ubuntu) because there has been no activity for 60 days.]

Changed in pidgin (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers