Please backport aptitude 0.6.8.1-2ubuntu1 (main) from quantal

Bug #1127601 reported by Florian Schmidt
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Precise Backports
Undecided
Unassigned

Bug Description

Please backport aptitude 0.6.8.1-2ubuntu1 (main) from quantal to precise.

Reason for the backport:
========================
aptitude 0.6.6 as provided with precise does not support multiarch properly. This means that if multiarch is used, aptitude cannot be used properly, and is potentially dangeous because it can suggest bogus package uninstalls. 0.6.8.1 as packaged with quantal solves this problem.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s quantal -d precise aptitude

* precise:
[X] Package builds without modification
 - package requires libapt-pkg4.12 >= 0.9.3, precise only provides 0.8.16
   I also did a no-change backport of apt (0.9.7.5ubuntu5.3) from quantal, after which
   the package built without modification, and all packages installed and ran properly.
[X] aptitude-doc-en installs cleanly and runs
[X] aptitude-dbg installs cleanly and runs
[X] aptitude-doc-fi installs cleanly and runs
[X] aptitude-doc-ja installs cleanly and runs
[X] aptitude-common installs cleanly and runs
[X] aptitude installs cleanly and runs
[X] aptitude-doc-fr installs cleanly and runs
[X] aptitude-doc-it installs cleanly and runs
[X] aptitude-doc-es installs cleanly and runs
[X] aptitude-doc-cs installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of aptitude. For reverse-build-dependencies (-Indep), please test that the package still builds against the new aptitude. For reverse-dependencies, please test that the version of the package currently in the release still works with the new aptitude installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

aptitude-doc-en
---------------

aptitude-dbg
------------

aptitude-doc-fi
---------------

aptitude-doc-ja
---------------

aptitude-common
---------------

aptitude
--------
* tasksel
  [X] precise (Reverse-Depends)
* daptup
  [ ] precise (Reverse-Suggests)
* ppa-purge
  [X] precise (Reverse-Depends)
* ibid
  [ ] precise (Reverse-Suggests)
* febootstrap
  [ ] precise (Reverse-Depends)
  [X] precise (Reverse-Build-Depends)
* libguestfs
  [X] precise (Reverse-Build-Depends)
* apt
  [X] precise (Reverse-Suggests)
* apt-watch-gnome
  [ ] precise (Reverse-Recommends)
* wajig
  [X] precise (Reverse-Depends)
* pkgsync
  [ ] precise (Reverse-Depends)
* dpkg
  [ ] precise (Reverse-Breaks)
* fai-server
  [ ] precise (Reverse-Suggests)

aptitude-doc-fr
---------------

aptitude-doc-it
---------------

aptitude-doc-es
---------------

aptitude-doc-cs
---------------

Revision history for this message
Florian Schmidt (flosch42) wrote :

Sorry if the format is wrong, it's my first backport request (and in fact my first real report overall), and since I couldn't find a howto, I just decided to wing it and emulate other requests in the queue.

I pushed apt and aptitude into a ppa via backportpackage quantal->precise, and could afterwards install and use the new version by adding ppa:flosch42/aptitude-multiarch and doing a dist-upgrade.

summary: - Please backport aptitude (0.6.8.1-2ubuntu1) from quantal
+ Please backport aptitude 0.6.8.1-2ubuntu1 (main) from quantal
Revision history for this message
Iain Lane (laney) wrote :

Hi,

Thanks for your request. You'll see that I rewrote the description - this is according to the output of the 'requestbackport' tool. (For information the documentation is at https://wiki.ubuntu.com/UbuntuBackports). It takes the form of a checklist that shows all of the testing that should be performed before this backport can be approved - basically, confirm that all of the packages install and that none of the packages which depend on these break (give them a small workout to determine this, e.g. install tasksel with the backported aptitude and see if it works)

Cheers!
Iain

description: updated
Revision history for this message
Florian Schmidt (flosch42) wrote :

Thanks for the link to that page, can't believe I missed it! At least I had found backportpackage already.

So I'll go through the checkboxes one after the other and test?

One thing that's not clear to me after reading the page:
The quantal version of aptitude depends (not only build-depends) on libapt-4.12 >= 0.9.3, which is provided by apt and is newer than the version provided with precise.
Would I need to create a second backportrequest from quantal to precise for apt? And then mention in that one that it relates to this request?
(I can't just request porting libapt because backports work by source package, right?)

After checking the output of requestbackport for apt... this would become quite a large request in that case due to reverse deps. ouch.

description: updated
description: updated
description: updated
Dan Streetman (ddstreet)
Changed in precise-backports:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers