Please backport conky 1.9.0-2 (universe) and conky-all 1.9.0-2 (multiverse) from quantal

Bug #1005372 reported by Vincent Cheng
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Precise Backports
Undecided
Unassigned

Bug Description

Please backport conky 1.9.0-2 (universe) and conky-all 1.9.0-2 (multiverse) from quantal to precise.

Reason for the backport:
========================
Conky 1.9.0 is a minor bug-fix version (e.g. fixes #996362), released shortly after precise was released. I don't think any of the bug fixes are important enough to qualify for a SRU, so I'm requesting a backport instead.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s quantal -d precise conky

* precise:
[X] Package builds without modification
[X] conky installs cleanly and runs
[X] conky-cli installs cleanly and runs
[X] conky-std installs cleanly and runs
[X] conky-all installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of conky. For reverse-build-dependencies (-Indep), please test that the package still builds against the new conky. For reverse-dependencies, please test that the version of the package currently in the release still works with the new conky installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

conky
-----
* conky-all
  [X] precise (Reverse-Replaces)

conky-cli
---------
* conky-all
  [X] precise (Reverse-Conflicts)
  [X] precise (Reverse-Replaces)

conky-std
---------
* conky-all
  [X] precise (Reverse-Conflicts)
  [X] precise (Reverse-Replaces)

conky-all
---------
* conky-std
  [X] precise (Reverse-Conflicts)
  [X] precise (Reverse-Replaces)
* conky-cli
  [X] precise (Reverse-Conflicts)
  [X] precise (Reverse-Replaces)
* conky
  [X] precise (Reverse-Depends)

Revision history for this message
Vincent Cheng (vincent-c) wrote :

Full changelog between conky 1.9.0 (quantal) and conky 1.8.1 (precise) can be found here: http://conky.sourceforge.net/changelog.html

Revision history for this message
Iain Lane (laney) wrote :

Accepted and uploaded. Thanks.

Changed in precise-backports:
status: New → Fix Committed
Revision history for this message
Colin Watson (cjwatson) wrote :

Accepted into precise-backports.

Changed in precise-backports:
status: Fix Committed → Fix Released
Revision history for this message
Vincent Cheng (vincent-c) wrote :

Another user has recently just pointed out to me that only src:conky was backported to precise, not src:conky-all. Please consider backporting conky-all 1.9.0-2 (multiverse) from quantal to precise. Thanks!

Changed in precise-backports:
status: Fix Released → New
Revision history for this message
Rohan "HEXcube" Villoth (hexcube) wrote :

i'm using conky-all 1.9.0.2 from your Vincent Cheng's Conky PPA() and it works fine,even better
 than the one in Ubuntu repos conky-all 1.8. It's recommended to use conky 1.9 over 1.8 as the latter has some serious
 problems. Recently conky,conky-std and conky-cli versions 1.9.0.2 were
 backported to Ubuntu Precise repos. But conky-all was left out. Since Vincent Cheng's request had no response for 2 months and conky-all is still the old version in precise, i'm requesting a backport for conky-all 1.9 to Precise. I hope conky-all 1.9 will make it into Precise repos before relese of Ubuntu 12.04.4

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) wrote :

Now that it's way past 12.04LTS's active support period and nearing EOL in one and half years, shouldn't this bug be dropped or marked as won't fix?

Revision history for this message
Micah Gersten (micahg) wrote : Re: [Bug 1005372] Re: Please backport conky 1.9.0-2 (universe) and conky-all 1.9.0-2 (multiverse) from quantal

18 months is a long time, I'm ok backporting things to 12.04 as long as someone does the appropriate testing

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) wrote :

@micahg I can do the testing if it's backported. I haven't erased my old 12.04LTS "Precise" installation yet. Kept it around for testing stuff like this :-)

But I don't think anybody misses the conky-all package on 12.04LTS anymore, coz all the other conky binary packages from π’„π’π’π’Œπ’š source package got backported: https://launchpad.net/ubuntu/+source/conky . Back then conky-all was built from a separate source package π’„π’π’π’Œπ’š-𝒂𝒍𝒍, and so got left out: https://launchpad.net/ubuntu/+source/conky-all . But this problem won't happen again, coz from conky 1.9.0-5 upstream Debian merged π’„π’π’π’Œπ’š-𝒂𝒍𝒍 into π’„π’π’π’Œπ’š source package. See: https://packages.debian.org/source/sid/conky . So they'll get updated together from now on.

Unfortunately, Ubuntu 14.04LTS "Trusty" ships conky 1.9.0-4 . So if trusty gets a backport, there's a chance that this may repeat again :-(

Revision history for this message
Micah Gersten (micahg) wrote :

I can't backport conky-all 1.9.0-2 due to a problematic build dependency:
Package libxnvctrl-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  nvidia-settings-updates:i386 nvidia-settings:i386 nvidia-settings-updates
  nvidia-settings

E: Package 'libxnvctrl-dev' has no installation candidate

It seems this package is no longer virtual in trusty-backports and later.

Changed in precise-backports:
status: New → Incomplete
Revision history for this message
Rohan "HEXcube" Villoth (hexcube) wrote :

@micahg The strange thing is, according to http://packages.ubuntu.com/source/precise/conky-all , the conky-all currently in precise repo (conky-all 1.8.1-6) also has the missing build-dependencies libkvm-dev and libdevstat-dev! libxnvctrl-dev is also missing but nvidia-settings can replace it. Wonder how this package got into precise repos, if it can't be built! o_O The devs must've workarounded it during the 12.04 development cycle.

Trusty also has the same problem of libxnvctrl-dev - http://packages.ubuntu.com/source/trusty/conky-all , but the package is now in trusty-backports: http://packages.ubuntu.com/trusty-backports/libxnvctrl-dev

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers