PPL

move custom code into extensions or commit it

Bug #692156 reported by rejon on 2010-12-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PPL
Critical
Bassel Safadi

Bug Description

right now, ppl is NOT portable. Its a lie.

Christopher has moved all his custom code into /assets/extensions.

Bassel we need the rest of your code in there or it committed to aikicore.

We have to figure out a good method for shipping packages that are built on aiki, but we must must must keep the system/libraries clean from rot and new code.

rejon (rejon) wrote :

It just needs to be done now. It needs to be moved and committed to the git repo for the extensions. This is really important for the health of this project.

Changed in ppl:
status: Confirmed → Triaged
rejon (rejon) wrote :

need this!

Bassel Safadi (bassel) on 2010-12-20
Changed in ppl:
status: Triaged → Fix Released

Bassel, you also need make this change in the gitorious repo. That is, move
import_gmail.php into extensions. In fact, you should make the change there
first and then implement it on the server.

Last time I checked git wasn't installed.

On Mon, Dec 20, 2010 at 7:02 AM, Bassel Safadi <email address hidden> wrote:

> ** Changed in: ppl
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a member of PPL
> Developers, which is subscribed to PPL.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
> move custom code into extensions or commit it
>
> Status in PPL:
> Fix Released
>
> Bug description:
> right now, ppl is NOT portable. Its a lie.
>
> Christopher has moved all his custom code into /assets/extensions.
>
> Bassel we need the rest of your code in there or it committed to aikicore.
>
> We have to figure out a good method for shipping packages that are built on
> aiki, but we must must must keep the system/libraries clean from rot and new
> code.
>
>
>

rejon (rejon) wrote :

I concur. So, now I have to check every bassel fix released for accuracy seems to be the trend. Is that right?

Changed in ppl:
status: Fix Released → Triaged
Bassel Safadi (bassel) wrote :

I don't concur, it does not make sense to me to use bzr in one place and git in other places. so if you want to update ppl software you have to first update with bzr then update with gitorious!!! what?
this should be on launchpad and not gitorious.

Changed in ppl:
status: Triaged → Fix Released
rejon (rejon) wrote :

Our custom code is separate from bzr and launchpad. We decided to use got
for custom code weeks ago. Aiki is left in bzr. Please commit your code to
the fab got repo.

<email address hidden>
http://fabricatorz.com
On Dec 23, 2010 3:26 AM, "Bassel Safadi" <email address hidden> wrote:
> I don't concur, it does not make sense to me to use bzr in one place and
git in other places. so if you want to update ppl software you have to first
update with bzr then update with gitorious!!! what?
> this should be on launchpad and not gitorious.
>
> ** Changed in: ppl
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
> move custom code into extensions or commit it

Bassel Safadi (bassel) wrote :

Aiki apps are bzr based, using git doesn't make any sense since the whole directory is managed by bzr, because using git and bzr on the same folders will create in the near future big problems specially if we started to ship some extensions by default with bzr aka in default aiki installation.
so currently you want to manage apps with git while storing them inside a file system which is managed by bzr. this is totally wrong.
Sorry but I didn't know about this decision weeks ago and don't agree with it.

I'm not going to use git. this is wrong and will fuck up aiki apps in the future

rejon (rejon) wrote :

Got is better than bzr. Launchpad supports both and .bzr and .git can
coexist. Anyway how would bzr work with master report and remote pulls?

Adding Kinkade to this need someone rationale.

<email address hidden>
http://fabricatorz.com
On Dec 23, 2010 9:05 AM, "Bassel Safadi" <email address hidden> wrote:
> Aiki apps are bzr based, using git doesn't make any sense since the whole
directory is managed by bzr, because using git and bzr on the same folders
will create in the near future big problems specially if we started to ship
some extensions by default with bzr aka in default aiki installation.
> so currently you want to manage apps with git while storing them inside a
file system which is managed by bzr. this is totally wrong.
> Sorry but I didn't know about this decision weeks ago and don't agree with
it.
>
> I'm not going to use git. this is wrong and will fuck up aiki apps in
> the future
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
> move custom code into extensions or commit it

Bassel Safadi (bassel) wrote :

this is not about what launchpad supports. it's about having a git repo (the custom files) inside a bzr repo (aiki)
this is also not related to what is better than what. it's about conflicts that might happen when we have the same file on bzr and git in the same time..

rejon (rejon) wrote :

I created aiki folders inside the folders in assets to move to a more
sane solution so we can allow for git or any other solution for
managing assets in that folder.

However, for PPL, we are and have been using git. Please commit the
code you created.

Jon

On Fri, Dec 24, 2010 at 2:01 AM, Bassel Safadi <email address hidden> wrote:
> this is not about what launchpad supports. it's about having a git repo (the custom files) inside a bzr repo (aiki)
> this is also not related to what is better than what. it's about conflicts that might happen when we have the same file on bzr and git in the same time..
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
>  move custom code into extensions or commit it
>

--
Jon Phillips
http://rejon.org/
http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (sf/global)
+86.187.1003.9974 (china)
+65.8330.5807 (singapore)

Changed in ppl:
status: Fix Released → Triaged

The Git repo is now up to date, including the code that Bassel moved in.

The server still doesn't have git though!

Changed in ppl:
status: Triaged → Fix Released
rejon (rejon) wrote :

we are looking at the servers today/tomorrow to make some standard
locations and structure...

Jon

On Thu, Jan 13, 2011 at 6:38 AM, Christopher Adams <email address hidden> wrote:
> The Git repo is now up to date, including the code that Bassel moved in.
>
> The server still doesn't have git though!
>
> ** Changed in: ppl
>       Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
>  move custom code into extensions or commit it
>

--
Jon Phillips
http://rejon.org/
http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (sf/global)
+86.187.1003.9974 (china)
+852.9647,9389 (hongkong)
+65.8330.5807 (singapore)

For one thing, neither contacts.php nor import_gmail.php take advantage of
the extensions/ppl library for interfacing with the database.

Those could also be renamed ppl_contacts.php and ppl_gmail.php.

On Wed, Jan 12, 2011 at 10:40 PM, rejon <email address hidden> wrote:

> we are looking at the servers today/tomorrow to make some standard
> locations and structure...
>
> Jon
>
> On Thu, Jan 13, 2011 at 6:38 AM, Christopher Adams <email address hidden>
> wrote:
> > The Git repo is now up to date, including the code that Bassel moved in.
> >
> > The server still doesn't have git though!
> >
> > ** Changed in: ppl
> > Status: Triaged => Fix Released
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> > https://bugs.launchpad.net/bugs/692156
> >
> > Title:
> > move custom code into extensions or commit it
> >
>
>
> --
> Jon Phillips
> http://rejon.org/
> http://fabricatorz.com/
> chat/skype: kidproto | irc: rejon
> +1.415.830.3884 (sf/global)
> +86.187.1003.9974 (china)
> +852.9647,9389 (hongkong)
> +65.8330.5807 (singapore)
>
> --
> You received this bug notification because you are a member of PPL
> Developers, which is subscribed to PPL.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
> move custom code into extensions or commit it
>
> Status in PPL:
> Fix Released
>
> Bug description:
> right now, ppl is NOT portable. Its a lie.
>
> Christopher has moved all his custom code into /assets/extensions.
>
> Bassel we need the rest of your code in there or it committed to
> aikicore.
>
> We have to figure out a good method for shipping packages that are
> built on aiki, but we must must must keep the system/libraries clean
> from rot and new code.
>
>
>

rejon (rejon) wrote :

ok, can file for 0.3...

On Thu, Jan 13, 2011 at 12:30 PM, Christopher Adams <email address hidden> wrote:
> For one thing, neither contacts.php nor import_gmail.php take advantage of
> the extensions/ppl library for interfacing with the database.
>
> Those could also be renamed ppl_contacts.php and ppl_gmail.php.
>
> On Wed, Jan 12, 2011 at 10:40 PM, rejon <email address hidden> wrote:
>
>> we are looking at the servers today/tomorrow to make some standard
>> locations and structure...
>>
>> Jon
>>
>> On Thu, Jan 13, 2011 at 6:38 AM, Christopher Adams <email address hidden>
>> wrote:
>> > The Git repo is now up to date, including the code that Bassel moved in.
>> >
>> > The server still doesn't have git though!
>> >
>> > ** Changed in: ppl
>> >       Status: Triaged => Fix Released
>> >
>> > --
>> > You received this bug notification because you are a direct subscriber
>> > of the bug.
>> > https://bugs.launchpad.net/bugs/692156
>> >
>> > Title:
>> >  move custom code into extensions or commit it
>> >
>>
>>
>> --
>> Jon Phillips
>> http://rejon.org/
>> http://fabricatorz.com/
>> chat/skype: kidproto | irc: rejon
>> +1.415.830.3884 (sf/global)
>> +86.187.1003.9974 (china)
>> +852.9647,9389 (hongkong)
>> +65.8330.5807 (singapore)
>>
>> --
>> You received this bug notification because you are a member of PPL
>> Developers, which is subscribed to PPL.
>> https://bugs.launchpad.net/bugs/692156
>>
>> Title:
>>  move custom code into extensions or commit it
>>
>> Status in PPL:
>>  Fix Released
>>
>> Bug description:
>>  right now, ppl is NOT portable. Its a lie.
>>
>>  Christopher has moved all his custom code into /assets/extensions.
>>
>>  Bassel we need the rest of your code in there or it committed to
>>  aikicore.
>>
>>  We have to figure out a good method for shipping packages that are
>>  built on aiki, but we must must must keep the system/libraries clean
>>  from rot and new code.
>>
>>
>>
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/692156
>
> Title:
>  move custom code into extensions or commit it
>

--
Jon Phillips
http://rejon.org/
http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (sf/global)
+86.187.1003.9974 (china)
+852.9647,9389 (hongkong)
+65.8330.5807 (singapore)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers