Encoding problem in the email attachments

Bug #586158 reported by mikel on 2010-05-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Power Email
New
Undecided
Sharoon Thomas http://openlabs.co.in

Bug Description

There is also encoding problemas with the email attachments. If the generated file's name has non-english characters it is wrongly encoded in the email and the email clients can't show its name, extension or myme-type.

Here is an example of what is sent qhen the filename has an í and é

Content-Type: application/octet-stream
MIME-Version: 1.0
Content-Disposition: =?utf-8?q?attachment=3B_filename=3D=222010/0003-Armand?=
 =?utf-8?b?byBHYXJjw61hLVZhbGTDqXMgU8OhbmNoZXoucGRmLnBkZiI=?=
Content-Transfer-Encoding: base64

An other encoding problem can also be found in the template name if you use there any non-english character it gives an error when you try to save it.

  File "/usr/lib/python2.5/site-packages/openerp-server/addons/poweremail/poweremail_template.py", line 98, in create
    'context': "{'src_model':'" + src_obj + "','template':'" + vals['name'] + "','src_rec_id':active_id,'src_rec_ids':active_ids}",
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)

can you confirm the version of poweremail?

Thanks

Changed in poweremail:
assignee: nobody → Sharoon Thomas http://openlabs.co.in (sharoonthomas)
mikel (mikel-martin) wrote :

The version is 0.6.3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers