send and receive mail fails

Bug #493597 reported by Gerhard du Toit on 2009-12-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Power Email
Fix Committed
Undecided
Sharoon Thomas http://openlabs.co.in

Bug Description

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/openerp-server/netsvc.py", line 244, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/usr/lib/python2.5/site-packages/openerp-server/netsvc.py", line 73, in __call__
    return getattr(self, method)(*params)
  File "/usr/lib/python2.5/site-packages/openerp-server/service/web_services.py", line 579, in execute
    res = service.execute(db, uid, object, method, *args)
  File "/usr/lib/python2.5/site-packages/openerp-server/osv/osv.py", line 61, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/usr/lib/python2.5/site-packages/openerp-server/osv/osv.py", line 120, in execute
    res = pool.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/usr/lib/python2.5/site-packages/openerp-server/osv/osv.py", line 112, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/usr/lib/python2.5/site-packages/openerp-server/addons/poweremail/poweremail_core.py", line 651, in send_receive
    self.get_mails(cr, uid, ids, context)
  File "/usr/lib/python2.5/site-packages/openerp-server/addons/poweremail/poweremail_core.py", line 540, in get_mails
    if self.save_fullmail(cr, uid, mail, id, mails[0].split()[0],ctx):#If saved succedfully then increment last mail recd
TypeError: save_fullmail() takes exactly 6 arguments (7 given)

Related branches

Can you update to trunk, check and revert?

Changed in poweremail:
assignee: nobody → Sharoon Thomas (sharoonthomas)
status: New → Fix Committed
Gerhard du Toit (gdutoit) wrote :

not crashing anymore . . . but no mail in inbox . . .

Is there any error in the stack trace?
Can you try for a partial mail download?

Receive headers and then full mail option?

Gerhard du Toit (gdutoit) wrote :

Tried both "received headers ON and OFF", same results, then tried it in GTK client end got

"State: Invalid Form, correct red fields but there are none . . .

I mailed you a screenshot

Gerhard du Toit (gdutoit) wrote :

Added a group in the security tab, now I don't get the "Invalid Form, correct red fields!" message anymore bit still no mails in the inbox.

Can you confirm if this issue still exists?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers