Installation Error : View Architecture

Bug #449941 reported by Julian1828
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Power Email
Incomplete
Undecided
Sharoon Thomas http://openlabs.co.in

Bug Description

During installation I am getting this error:

Error occurred while validating the field(s) arch: Invalid XML for View Architecture!

The installation is unsuccessful. I have no idea what this error is. I am using an installation of Ubuntu 9.04 with the latest version of the Openerp server. I know it isn't much but that is all I have.

Thank you!

Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote :

Can you put the stack trace here. It's easier to find the issue.
Is it the trunk you have installed?

Changed in poweremail:
assignee: nobody → Sharoon Thomas (openlabs.co.in) (sharoonthomas)
status: New → Incomplete
Revision history for this message
Julian1828 (julian-lannigan) wrote :

well thats the thing....i do not get any stack trace or anything... all I get is the above error message.

Revision history for this message
Armin Gruber (armin-gruber) wrote :

I've the same error... is this due to a version problem
(i'm using openerp 5.0.1.0 and poweremail 0.6.1)

Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote :

I will repack and release 0.7.

Please update if you still have a bug. However the trunk has no error.

Changed in poweremail:
status: Incomplete → Invalid
Revision history for this message
ed (egeers) wrote :

I'm having the same problem just downloaded the latest trunk

Revision history for this message
Julian1828 (julian-lannigan) wrote :

i just downloaded and tried to install the latest trunk on a completely new database with just the minimal profile. I got this error trackback:

Traceback (most recent call last):
  File "/usr/lib/openerp-server/netsvc.py", line 231, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/usr/lib/openerp-server/netsvc.py", line 74, in __call__
    return getattr(self, method)(*params)
  File "/usr/lib/openerp-server/service/web_services.py", line 552, in execute
    return self._execute(db, uid, wiz_id, datas, action, context)
  File "/usr/lib/openerp-server/service/web_services.py", line 532, in _execute
    return wiz.execute(db, uid, self.wiz_datas[wiz_id], action, context)
  File "/usr/lib/openerp-server/wizard/__init__.py", line 178, in execute
    res = self.execute_cr(cr, uid, data, state, context)
  File "/usr/lib/openerp-server/wizard/__init__.py", line 74, in execute_cr
    action_res = action(self, cr, uid, data, context)
  File "/usr/lib/openerp-server/addons/base/module/wizard/wizard_module_upgrade.py", line 92, in _upgrade_module
    db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/usr/lib/openerp-server/pooler.py", line 61, in restart_pool
    return get_db_and_pool(db_name, force_demo, status, update_module=update_module)
  File "/usr/lib/openerp-server/pooler.py", line 40, in get_db_and_pool
    addons.load_modules(db, force_demo, status, update_module)
  File "/usr/lib/openerp-server/addons/__init__.py", line 715, in load_modules
    r = load_module_graph(cr, graph, status, report=report)
  File "/usr/lib/openerp-server/addons/__init__.py", line 608, in load_module_graph
    tools.convert_csv_import(cr, m, os.path.basename(filename), fp.read(), idref, mode=mode)
  File "/usr/lib/openerp-server/tools/convert.py", line 853, in convert_csv_import
    pool.get(model).import_data(cr, uid, fields, datas,mode, module,noupdate,filename=fname_partial)
  File "/usr/lib/openerp-server/osv/orm.py", line 639, in import_data
    process_liness(self, datas, [], fields_def)
  File "/usr/lib/openerp-server/osv/orm.py", line 518, in process_liness
    ['res_id'])[0]['res_id']
IndexError: list index out of range

Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote : Re: [Bug 449941] Re: Installation Error : View Architecture

What is your version of Open ERP?

On Mon, Oct 26, 2009 at 11:58 PM, Julian1828 <email address hidden>wrote:

> i just downloaded and tried to install the latest trunk on a completely
> new database with just the minimal profile. I got this error trackback:
>
> Traceback (most recent call last):
> File "/usr/lib/openerp-server/netsvc.py", line 231, in dispatch
> result = LocalService(service_name)(method, *params)
> File "/usr/lib/openerp-server/netsvc.py", line 74, in __call__
> return getattr(self, method)(*params)
> File "/usr/lib/openerp-server/service/web_services.py", line 552, in
> execute
> return self._execute(db, uid, wiz_id, datas, action, context)
> File "/usr/lib/openerp-server/service/web_services.py", line 532, in
> _execute
> return wiz.execute(db, uid, self.wiz_datas[wiz_id], action, context)
> File "/usr/lib/openerp-server/wizard/__init__.py", line 178, in execute
> res = self.execute_cr(cr, uid, data, state, context)
> File "/usr/lib/openerp-server/wizard/__init__.py", line 74, in execute_cr
> action_res = action(self, cr, uid, data, context)
> File
> "/usr/lib/openerp-server/addons/base/module/wizard/wizard_module_upgrade.py",
> line 92, in _upgrade_module
> db, pool = pooler.restart_pool(cr.dbname, update_module=True)
> File "/usr/lib/openerp-server/pooler.py", line 61, in restart_pool
> return get_db_and_pool(db_name, force_demo, status,
> update_module=update_module)
> File "/usr/lib/openerp-server/pooler.py", line 40, in get_db_and_pool
> addons.load_modules(db, force_demo, status, update_module)
> File "/usr/lib/openerp-server/addons/__init__.py", line 715, in
> load_modules
> r = load_module_graph(cr, graph, status, report=report)
> File "/usr/lib/openerp-server/addons/__init__.py", line 608, in
> load_module_graph
> tools.convert_csv_import(cr, m, os.path.basename(filename), fp.read(),
> idref, mode=mode)
> File "/usr/lib/openerp-server/tools/convert.py", line 853, in
> convert_csv_import
> pool.get(model).import_data(cr, uid, fields, datas,mode,
> module,noupdate,filename=fname_partial)
> File "/usr/lib/openerp-server/osv/orm.py", line 639, in import_data
> process_liness(self, datas, [], fields_def)
> File "/usr/lib/openerp-server/osv/orm.py", line 518, in process_liness
> ['res_id'])[0]['res_id']
> IndexError: list index out of range
>
> --
> Installation Error : View Architecture
> https://bugs.launchpad.net/bugs/449941
> You received this bug notification because you are a bug assignee.
>
> Status in Power EMail for Open ERP: Invalid
>
> Bug description:
> During installation I am getting this error:
>
> Error occurred while validating the field(s) arch: Invalid XML for View
> Architecture!
>
> The installation is unsuccessful. I have no idea what this error is. I am
> using an installation of Ubuntu 9.04 with the latest version of the Openerp
> server. I know it isn't much but that is all I have.
>
> Thank you!
>

--
Sharoon Thomas
Business Analyst & ERP Consultant

Revision history for this message
Julian1828 (julian-lannigan) wrote :

I am running version 5.0.0

Revision history for this message
ed (egeers) wrote :

any solutions yet...
I realy wouldlike to find a solution
please can someone help out here.

Revision history for this message
Hayssam (hayssam-hoballah) wrote :

Same here, I'm also stuck with this "list index out of range" error...
Any news on that front?

Changed in poweremail:
status: Invalid → Confirmed
Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote :

List index out of range is not a poweremail problem but a problem with the Open ERP module installer. IT will install the module again if you restart the server

Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote :

Please reopen if you think the err still exists

Changed in poweremail:
status: Confirmed → Incomplete
Revision history for this message
Sharoon Thomas http://openlabs.co.in (sharoonthomas) wrote :

Can you update if this issue still exists?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers