Key error in mailman settings page

Bug #1429086 reported by Ashish on 2015-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Postorius
Undecided
Ashish

Bug Description

Steps to reproduce the bug:

1. Setup postorius, mailman-core, mailman client in your system.
2. Start mailman
3. Create a super user
4. Start postorius_standalone ,django server
5. Login through the super user.
6. Click on my settings ( on the top bar)

I am getting this error every time I tried to open my settings page. ( I have tried it with restarting everthing but still it is there)

Error Screenshot : https://www.filepicker.io/api/file/NYKc2pmESwedGsPGS2pI

Traceback:
File "/home/ashish/mailman/mm2/local/lib/python2.7/site-packages/Django-1.7.5-py2.7.egg/django/core/handlers/base.py" in get_response
111. response = wrapped_callback(request, *callback_args, **callback_kwargs)
File "/home/ashish/mailman/mm2/local/lib/python2.7/site-packages/Django-1.7.5-py2.7.egg/django/views/generic/base.py" in view
69. return self.dispatch(request, *args, **kwargs)
File "/home/ashish/mailman/mm2/postorius/src/postorius/views/generic.py" in dispatch
137. self.mm_user = self._get_user(user_id)
File "/home/ashish/mailman/mm2/postorius/src/postorius/views/generic.py" in _get_user
97. user_obj = MailmanUser.objects.get(address=user_id)
File "/home/ashish/mailman/mm2/postorius/src/postorius/models.py" in get
74. return method(**kwargs)
File "/home/ashish/mailman/mm2/mailman.client/src/mailmanclient/_client.py" in get_user
242. return _User(self._connection, content['self_link'])

Exception Type: KeyError at /postorius/accounts/mailmansettings/
Exception Value: u'self_link'

Ashish (coolyashish) on 2015-03-06
description: updated
description: updated
Ashish (coolyashish) on 2015-03-06
Changed in postorius:
assignee: nobody → Ashish (coolyashish)
status: New → In Progress
Ashish (coolyashish) wrote :

Hi,
I have made the changes here. There was an error in mailman.client -> _client.py -> get_user. I have corrected it as below. please have a look at it.

https://code.launchpad.net/~coolyashish/+junk/BUG1429086

Sumana Harihareswara (sumanah) wrote :

Ashish, that link no longer works - is the problem still occurring on your system?

Ashish (coolyashish) wrote :

Sumana, Yes I have updated the repository. It works fine :)

Samuel Cantero (scanterog) wrote :

Hi,

I am still having problem with this bug. I have installed the last version of every package from the ubuntu 14.04 repositories. The packages versions are: mailman 3.0rc1, mailmanclient 1.0.0, postorius 1.0.0. I am using Django 1.7.

Greetings,

Florian Fuchs (flo-fuchs) wrote :

Hi Samuel,

the Postorius version you use shouldn't produce that error. So here are some questions to help us find out where the problem is:

- How did you install the packages (Using pip? Downloading the tarballs from launchpad? Branching the repos with bzr? Using the mailman-bundler?)
- Did you make any updates in between? If so, did you restart the server after updating?
- Have you installed the packages in a virtualenv? If so, is that virtualenv active?

 Florian

Changed in postorius:
status: In Progress → Fix Committed
status: Fix Committed → Incomplete
neufeind (neufeind) wrote :

I experience the same problem. Since the packed mailman-bundler 3.0.0 still has a problem (fix already commited, not yet released) I checked out the current release using bzr.
Testsetup was done using mailman-bundler, installation and startup done according to README.rst.
Creating a domain worked fine for me. But after creating of a list the error occured. Going back, the list seems to have been created. But trying to open the list-details I get the same error. So I think it might not be the list-creation but the display of list-settings afterwards.

Traceback: http://dpaste.com/221P4HS

neufeind (neufeind) wrote :

Solved for me. I used "createsuperuser" on the console, but didn't provide an email-address there. To be honest, I thought it wasn't really needed at that stage :-) But mailman-core seems to reference the user by his/her email-address internally and so some api-calls failed. Since mailman-core answered with a 500-error imho this is something that mailman should fix on their side. So I added a bugreport for them to maybe be a bit more relaxed in such error-cases and not fail hard.
https://gitlab.com/mailman/mailman/issues/127

Solved here?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers