Admin notification not received

Bug #1062963 reported by Ramya Narayanaswamy on 2012-10-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNU Mailman
Undecided
Unassigned
Postorius
High
pjoshi

Bug Description

When the automatic responses settings is set to notify admin for changes made to the mailing list is enabled, the admin did not receive the notifications for changes.

Terri (terriko) wrote :

Need to confirm that the setting is being set correctly in REST, but this may be a Mailman3 bug.

Changed in postorius:
status: New → Triaged
importance: Undecided → High
Barry Warsaw (barry) on 2012-10-13
tags: added: mailman3
Barry Warsaw (barry) wrote :

OP: Can you provide more information? What changes do you expect to get notified on? Do you have a way to reproduce the problem?

There are two attributes which control admin notifications. admin_immed_notify controls whether the admin is notified when a subscription (or unsubscription) request is held for moderator approval. admin_notify_mchanges controls whether the administrator gets a notification when a user is subscribed to the mailing list.

Changed in mailman:
status: New → Incomplete
tags: added: mailman3-suite-blocker
pjoshi (prakhar126) wrote :

hi,
     I think admin should be notify when an user changes subscription settings. Right now admin is not notified about the chages user does in the list subscription.

Mark Sapiro (msapiro) wrote :

@pjoshi If you are talking about MM 2.1, version 2.1.19 (and up) will notify the admin if a user changes her address. If you want other changes such as changing from regular to digest or changing from plain to MIME digest or changing her preferred language, those are not reported and I don't think they need to be.

pjoshi (prakhar126) wrote :

@mark haven't test that yet (the email confirmation on add email address by subscribed user) as there is a bug https://bugs.launchpad.net/postorius/+bug/1430682 and it needs to be fixed first. So let it be done will check that later. :)

pjoshi (prakhar126) on 2015-04-14
Changed in postorius:
assignee: nobody → pjoshi (prakhar126)
Abhilash Raj (raj-abhilash1) wrote :

This bug has been moved to the new gitlab repo here: https://gitlab.com/mailman/mailman/issues/58

Abhilash Raj (raj-abhilash1) wrote :

This bug has been moved to the new gitlab repo here: https://gitlab.com/mailman/postorius/issues/1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers