Held messages show display message body

Bug #1004049 reported by Jeff Marshall on 2012-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Postorius
Undecided
Abhilash Raj

Bug Description

The Held Messages page on Postorius only shows the subject line of the messages. It seems like the body of the message will also be important for reviewing the held message.

According to Barry the body of the message, as a text blob, should be accessible via the REST API:

http://packages.python.org/mailman/src/mailman/rest/docs/moderation.html

Related branches

How do you think that this should work?

Should we always display at least a part of the message as a part of the list? Or should we display only the subject and have a linkage to the body of the message, perhaps as a pop up window?

On May 24, 2012, at 11:50 AM, Jeff Marshall wrote:

> Public bug reported:
>
> The Held Messages page on Postorius only shows the subject line of the
> messages. It seems like the body of the message will also be important
> for reviewing the held message.

I would recommend displaying only the subject line like you are now
and having a button that displays the body in a pop-up modal.

Thanks

On Thu, May 24, 2012 at 10:06 AM, Richard Wackerbarth
<email address hidden> wrote:
> How do you think that this should work?
>
> Should we always display at least a part of the message as a part of the list? Or should we display only the subject and have a linkage to the body of the message, perhaps as a pop up window?
>
> On May 24, 2012, at 11:50 AM, Jeff Marshall wrote:
>
>> Public bug reported:
>>
>> The Held Messages page on Postorius only shows the subject line of the
>> messages.  It seems like the body of the message will also be important
>> for reviewing the held message.
>
> _______________________________________________
> Mailman-Developers mailing list
> <email address hidden>
> http://mail.python.org/mailman/listinfo/mailman-developers
> Mailman FAQ: http://wiki.list.org/x/AgA3
> Searchable Archives: http://www.mail-archive.com/mailman-developers%40python.org/
> Unsubscribe: http://mail.python.org/mailman/options/mailman-developers/marshman%40gmail.com
>
> Security Policy: http://wiki.list.org/x/QIA9

On 24 May 2012, at 18:06, Richard Wackerbarth wrote:
>
> How do you think that this should work?
>
> Should we always display at least a part of the message as a part of the list? Or should we display only the subject and have a linkage to the body of the message, perhaps as a pop up window?
>

I think that an option to display the first n < 5 or so unquoted lines of the body would be useful. Perhaps with a checkbox to toggle that option on the displayed page. Perhaps per thread. Keep it simple, though.

--
Ian Eiloart
Postmaster, University of Sussex
+44 (0) 1273 87-3148

Ian Eiloart (iane) wrote :

On 24 May 2012, at 18:06, Richard Wackerbarth wrote:
>
> How do you think that this should work?
>
> Should we always display at least a part of the message as a part of the list? Or should we display only the subject and have a linkage to the body of the message, perhaps as a pop up window?

Sorry, ignore the "perhaps per thread" comment on my last. I was answering a different question.

I think that, if there's only one message, then display the body. If there are fewer than, say, five, then display a few lines of the body. With more than that, display only the subject line. But, for each message, it should be quick to pop up a few lines of the message body. Perhaps a disclosure triangle, or something.
--
Ian Eiloart
Postmaster, University of Sussex
+44 (0) 1273 87-3148

Florian Fuchs (flo-fuchs) wrote :

On 05/24/2012 07:12 PM, Jeff Marshall wrote:
> I would recommend displaying only the subject line like you are now
> and having a button that displays the body in a pop-up modal.

+1!

There should be some kind of fallback for non-JS users, though. Since the Postorius base template detects JS, I suggest a simplfied CSS-only version for non-JS-clients (possibly depending on the :hover or :active state of the button) and the pop-up modal for JS-enabled ones.

Florian

Changed in postorius:
milestone: none → 1.0.0a2
status: New → Confirmed
Ethan Fremen (mindlace) on 2012-09-05
Changed in postorius:
assignee: nobody → Ethan Fremen (mindlace)
tags: added: mailman3 mailman3-suite-blocker
Aurélien Bompard (abompard) wrote :

Hey Ethan, any news on that improvement?

Changed in postorius:
status: Confirmed → In Progress
assignee: Ethan Fremen (mindlace) → nobody
assignee: nobody → Abhilash Raj (raj-abhilash1)
Changed in postorius:
status: In Progress → Fix Committed
Changed in postorius:
milestone: 1.0.0a2 → 1.0.0
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers