popper is not compatible with Ubuntu 16.04 LTS Xenial Xerus

Bug #1683355 reported by Norbert on 2017-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Popper
Undecided
Unassigned

Bug Description

Steps to reproduce:
1a. Install Popper from PPA (https://launchpad.net/~ralf.hersel/+archive/ubuntu/rhersel-ppa?field.series_filter=precise) to Ubuntu 12.04 LTS. Upgrade previously installed Ubuntu 12.04 LTS to 14.04 LTS and then to 16.04 LTS.
1b. Make clean install of 16.04 LTS and install popper manually with its dependencies (libindicate5_0.6.92-0ubuntu1, libindicate-gtk3_0.6.92-0ubuntu1, popper_0.31.3-0ubuntu1_all, python-indicate_0.6.92-0ubuntu1, python-support_1.0.14ubuntu2).
2. Setup Popper with /usr/share/popper/popper_config.sh.
3. Logout. Login.
4. Notification appeared in the top-right corner of the screen:
"New Emails
You have X new mails.".
but letter icon in the tray is not highlighted, so user can't obtain information about e-mail author, subject and date.

Expected results:
Popper works great on Ubuntu 16.04 LTS with Unity desktop as it did in the Ubuntu 12.04 LTS.

Actual results:
Popper does not work in Ubuntu 16.04 LTS.

Pa_trick17 (trick17) wrote :

Hi Norbert. I'm sorry, but development of Popper is discontinued and only works until Ubuntu 12.04. (https://launchpad.net/popper/+announcement/12042) You may wanna give "mailnotify" (http://savannah.nongnu.org/projects/mailnotify) or "mailnag" (https://launchpad.net/~pulb/+archive/ubuntu/mailnag) a try? Regards, Patrick

Norbert (nrbrtx) wrote :

Thank you for reply, Patrick!
I know about mail-notification. I used it on my old Gentoo system. It seems to be very outdated and ugly.

Mailnag is great. Thank you for suggestion!

Norbert (nrbrtx) on 2017-04-29
Changed in popper:
status: New → Invalid
status: Invalid → Confirmed
Norbert (nrbrtx) wrote :

For everyone interested - I made it working:

See comment on [bug 1683516](https://bugs.launchpad.net/ubuntu/+source/indicator-applet/+bug/1683516/comments/5).

You can do the following:

    sudo apt-get install libindicate-gtk3 libindicate5 python-indicate python-gnomekeyring python-notify

    cd ~/Downloads
    wget http://archive.ubuntu.com/ubuntu/pool/universe/p/python-support/python-support_1.0.14ubuntu2_all.deb
    sudo dpkg -i python-support_1.0.14ubuntu2_all.deb

    wget http://ppa.launchpad.net/ralf.hersel/rhersel-ppa/ubuntu/pool/main/p/popper/popper_0.31.3-0ubuntu1_all.deb
    sudo dpkg -i popper_0.31.3-0ubuntu1_all.deb

    wget http://archive.ubuntu.com/ubuntu/pool/main/i/indicator-messages/libindicator-messages-status-provider1_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb
    sudo dpkg -i libindicator-messages-status-provider1_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb

    wget http://archive.ubuntu.com/ubuntu/pool/main/i/indicator-messages/indicator-messages_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb
    sudo dpkg -i indicator-messages_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb

    wget http://archive.ubuntu.com/ubuntu/pool/universe/i/indicator-messages/indicator-messages-gtk2_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb
    sudo dpkg -i indicator-messages-gtk2_0.6.0-0ubuntu2_`dpkg --print-architecture`.deb

Then `mate-tweak` *-> Panel (Interface) -> Enable indicators*.

Then *Applications -> Internet -> Popper*

    cat <<EOF | sudo tee /etc/apt/preferences.d/pin-indicators
    Package: indicator-messages
    Pin: version 0.6.0-0ubuntu2
    Pin-Priority: 1337

    Package: indicator-messages-gtk2
    Pin: version 0.6.0-0ubuntu2
    Pin-Priority: 1337

    Package: libindicator-messages-status-provider1
    Pin: version 0.6.0-0ubuntu2
    Pin-Priority: 1337

    Package: popper
    Pin: version 0.31.3-0ubuntu1
    Pin-Priority: 1337

    Package: python-support
    Pin: version 1.0.14ubuntu2
    Pin-Priority: 1337

    EOF

Posted solution on the AskUbuntu - see https://askubuntu.com/a/965156/66509 .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers