Clicking on a tweet/message link sometimes does not work

Bug #790565 reported by Conscious User
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Polly
Critical
Unassigned
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Sometimes, clicking a link does not work. The link even receives keyboard focus, but its action never happens.

I'm not sure about the cause of this issue, but it could be related to Bug 687732. Needs some investigation.

Revision history for this message
Conscious User (conscioususer) wrote :

After using Ubuntu Classic an entire afternoon, I'm more or less convinced that this bug only happens when Compiz is activated. I'm going to comment this on Bug 687732.

Changed in schizobird:
status: New → Incomplete
importance: Undecided → High
Changed in schizobird:
status: Incomplete → Triaged
Revision history for this message
Conscious User (conscioususer) wrote :

I would appreciate if a user who is using Polly in Oneiric regularly could report if the bug is still happening in there.

I'm still on Natty, and only using Oneiric occasionally, not long enough to notice if the bug happens there.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Yes, it is still happening in 0.91. I have not yet figured out the difference between those links that are clickable and those that aren't.

Revision history for this message
Conscious User (conscioususer) wrote :

Matthew, just to confirm, Oneiric?

I'm hating this bug for months and still couldn't figure out a pattern...

Revision history for this message
Conscious User (conscioususer) wrote :

Sigh... I just confirmed myself it is happening in Oneiric.

This bug has been annoying me for a long time now, as it really hurts the user experience.

The main problem is its apparent randomness: I couldn't find so far a reliable way to make it happen. It just does unexpectedly.

To make things worse, before I thought unfocusing and focusing worked to fix the issue temporarily, but lately I have to go to the point of minimizing and restoring.

This is just bad. Without more certainty I can't report useful information to upstream (probably Compiz).

I need the help from anyone who can notice patterns of when this bug happens.

description: updated
description: updated
Changed in polly:
importance: High → Critical
Revision history for this message
Conscious User (conscioususer) wrote :

It seems that, while unfocusing+focusing with the mouse is not reliable to make the issue temporarily disappear, unfocusing+focusing with Alt+Tab is quite reliable.

Revision history for this message
cldx (cldx3000) wrote :

Here's what i spotted after juggling with Polly and some other Windows for a while, i don't know if it's really helpful at this point but i'll write it nevertheless:

It does *seem* to be connected to whatever Events get fired right after you closed another Window AND Polly is the Window that should receive focus in the Stack of open Windows.

Recreate:
Open Polly and f.e. a File Browser, the File Browser must have focus, close the File Browser, Polly *should* be the focused Window now but the Links will fail. Clicking around in Polly does nothing, Links still fail. Works in any combination of Polly + Some Window.

Minimizing and re-opening Polly (or switching back and forth between Windows in Alt Tab) fixes the Links.

Another Scenario:
Open Polly, Chrome and another Window, Polly is the bottom Window, next is Chrome and then f.e. Audio Settings, close Audio Settings, Chrome receives Focus, you have to manually focus (or Alt Tab) to Polly and all Links should be fine, so it really seems to be just the case if Polly is the Window that should receive Auto-Focus.

I tested this just in Oneiric with Unity, for the sake of Information ^^ Now I'll go play with it in Gnome Shell (if it's working again) and Unity 2D.

Revision history for this message
Conscious User (conscioususer) wrote :

Ok, Joern, your steps to reproduce seem reliable, even in other applications.

I mentioned this in Bug 687732, let's see if Sam knows what's happening.

Revision history for this message
Sam Spilsbury (smspillaz) wrote :
Changed in compiz-core:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in compiz-core:
milestone: none → 0.9.5.96
Changed in unity:
milestone: none → 4.18.0
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
status: New → Fix Committed
Changed in unity:
status: New → Fix Committed
Changed in polly:
status: Triaged → Invalid
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
David Barth (dbarth)
Changed in compiz (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → ubuntu-11.10
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6-0ubuntu1

---------------
compiz (1:0.9.6-0ubuntu1) oneiric; urgency=low

  * New upstream release 0.9.6:
   - Windows which are marked transients of docks should be treated like docks (LP: #860397)
   - Applications which create multiple windows that are transients of each other can be given invalid stack positions (LP: #858625)
   - race condition in configureXWindow causes unpredicatable window geometry changes (LP: #860304)
   - invisible window when a window is mapped but not yet drawn on by the process mapping it (LP: #860286)
   - resizing bugs with xterm (LP: #854725)
   - Cannot open a window that starts iconified (LP: #732997)
   - maximized windows fail to update their input extents when undecorated (LP: #853734)
   - Clicking on a tweet/message link sometimes does not work (LP: #790565)
   - crash on closing a window (LP: #856015)
   - Windows move to 0,0 on compiz restarts (LP: #858629)
   - windows that are decorated while resizing can cause incorrect resize results (LP: #860306)
   - remove transient window handling from unity-window-decorator (LP: #856096)
 -- Didier Roche <email address hidden> Wed, 28 Sep 2011 14:15:21 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

I have not been able to reproduce this bug with polly 0.93.0-0~385~oneiric1 running on precise with compiz-core 0.9.7 from didrocks PPA.

Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers