Credential-modules missing for compatibility to EDS-POA

Bug #1652256 reported by SB on 2016-12-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Maya
New
Undecided
Unassigned
POA-EDS (Deprecated)
Undecided
Unassigned

Bug Description

On fresh install of loki 0.4 starting maya-calendar gives the following warning

gdb maya-calendar
GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.04) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from maya-calendar...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/maya-calendar
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe06de700 (LWP 2184)]
[New Thread 0x7fffdfedd700 (LWP 2185)]
[INFO 09:38:03.861813] Application.vala:155: Calendar version: 0.4.0.2
[INFO 09:38:03.861855] Application.vala:157: Kernel version: 4.4.0-57-generic
[New Thread 0x7fffdcbf2700 (LWP 2187)]
[New Thread 0x7fffd562c700 (LWP 2188)]
[New Thread 0x7fffd4e2b700 (LWP 2189)]
[New Thread 0x7fffcbfff700 (LWP 2190)]
[WARNING 09:38:03.997999] [e-data-server] e_module_load_all_in_directory: Error opening directory '/usr/lib/evolution-data-server/credential-modules': No such file or directory
[New Thread 0x7fffca31d700 (LWP 2191)]
[New Thread 0x7fffc9b1c700 (LWP 2196)]

It can be resolved by installing
`sudo apt-get install evolution-data-server-online-accounts`
but this installs a lot of dependencies and afaiu POA-EDS should take responsibility to implement all functionality needed for compatibility to EDS-OA

SB (sir-beafy) on 2016-12-23
description: updated
description: updated
Corentin Noël (tintou) wrote :

The right package is evolution-data-server-pantheon-online-accounts but it is not stable yet

summary: - Credential-modules missing for compatibility to EDS-OA
+ Credential-modules missing for compatibility to EDS-POA
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers