Intelligent boot splash greeting tools

script isn't run on startup on certain systems

Reported by Sergey "Shnatsel" Davidoff on 2011-01-02
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
plymouth-greeter
Status tracked in 0.4
0.3
High
Unassigned
0.4
High
Unassigned

Bug Description

As reported at OMG! Ubuntu! (see http://www.omgubuntu.co.uk/2010/12/new-smooth-intelligent-plymouth-boot-screen-for-ubuntu/#comment-120752782), plymouth-greeter script isn't started on boot on certain systems. However, it's started and works properly on shutdown.

Related branches

If you are experiencing this bug, please try the following command:
sudo update-initramfs -u
I'm trying to reproduce the problem now.

I am experiencing the same problem. However in my case the script doesn't seem to start at shut down either. In other words, I don't see the "Good Bye" message either (just the nice fading background). Neither do I see the panel at the bottom.

I ran the command "sudo update-initramfs -u" and rebooted, but that didn't fix the problem.

I just had this thought. You said you tested it on a clean install of Ubuntu. My system isn't clean, as I upgraded from Lucid to Maverick, and I also did some Plymouth tuning in the past. Is it possible that it has something to do with the Plymouth settings I changed? The exact steps I did for tuning Plymouth can be found here: http://www.namanb.com/2010/05/changing-bootup-resolution-plymouth-in-ubuntu-10-04-lucid-lynx.html

I could revert the changes I made and see if it works then.

If you see the fading background on shutdown, it means that the script is run. In the current implementation the script tells the splash that the machine is shutting down (there must be a better way to do it, but I haven't found it yet). There's a mysterious limitation in Plymouth script engine that doesn't let me start text animation before the background animation is finished, I guess your machine shuts down faster than the background fades out to 0.5 transparency. The limitation absolutely mystic and illogical, so probably it's just me. I'm going to investigate it.
Regarding the boot time, I tried to fix to this bug, try version 0.3.2 from the PPA (it will arrive in a few minutes).

Changed in plymouth-greeter:
status: Incomplete → In Progress

I just tested version 0.3.2 from the PPA. It didn't fix the problem. Also, my machine takes quite a while to boot, and the background is visible for at least 5 seconds, so it seems there's enough time for the text animation to be started.

Ubuntu does a hard disk check periodically at boot time. While it's performing the checks, text is displayed on the Plymouth screen. That text interestingly did get displayed correctly on the background while I was using plymouth-greeter.

Disk check messages should be OK even if the greeter script isn't run at all, and they aren't animated in this version of the theme (and I think it will remain so forever for stability's sake).
Could you please post contents of /etc/init/plymouth-splash file in your system? It might help me handle upgraded systems properly. Also, there's a debug version of the script: http://db.tt/RJVefyJ It writes some debug info to /tmp/plymouth-greeter.log, if you could copy its contents to /bin/plymouth-greeter, reboot and post the /tmp/plymouth-greeter.log file, it would be great.

I installed the debug version and rebooted my system twice, but the file /tmp/plymouth-greeter.log was not created. Interestingly, with the debug version the "good bye" message at shut down *does* display. I also noticed the background fading *out* at shut down. This was not the case with the version from PPA, where the background fades in on shut down. It seems some of your changes in the debug version fixed the problem partially.

The greeting text still doesn't display at start up with the debug version.

Also there is no /etc/init/plymouth-splash file in my system:
serrano@saibot:~$ ls /etc/init | cat | grep plymouth
plymouth.conf
plymouth-greeter.conf
plymouth-log.conf
plymouth-splash.conf.disabled
plymouth-stop.conf

Sorry, I meant plymouth-splash.conf. I wonder why it's disabled - how on the earth does Plymouth work without it?! This is VERY interesting, I've never seen anything like that before. Could you post the contents of plymouth.conf, plymouth-log.conf and plymouth-splash.conf.disabled?
Also, in theory the debug version of /bin/plymouth can't affect shutdown, while the updated from PPA plymouth-greeter.conf can. But that's theory... In theory the greeting must work :)
Oh, and the command you used works even without a cat in the middle ;)

I don't understand why plymouth-splash.conf is disabled either. I sure didn't do it. Attaching my .conf files...

Thanks a lot! I'll investigate this ASAP.

Wow, very interesting! The splash is started from plymouth.conf's post-start script, and my script is waiting for the plymouth-splash.conf to be started. That's why it doesn't work. I'll fix it now.

This should be fixed in 0.3.3. Thanks a lot for your help!

Changed in plymouth-greeter:
status: In Progress → Fix Released

I just tested version 0.3.3 but it still doesn't work at startup. I do see the Goodbye message at shutdown.

Wow.
Try sudo update-initramfs -u again... but I doubt it will change anything.

Changed in plymouth-greeter:
status: Fix Released → In Progress
Jonathan Poulter (poulter7) wrote :

I get the same problem - no message on boot, "Goodbye" on shutdown.
For me /etc/init/plymouth-splash.conf is not disabled, however.

All of the Serrano posted are the same on my system:
/etc/init/plymouth.conf
/etc/init/plymouth-splash.conf
/etc/init/plymouth-log.conf

Jonathan Poulter (poulter7) wrote :

I've been tinkering and been able to get the greeter working on boot for me.
This is definitely not a fix but may be a little help to your debugging...

Jonathan's edit did not fix the problem for me. Not even after running
"sudo update-initramfs -u".

Jonathan, thank you very much for the info! Please try this plymouth-greeter.conf, it should also work. This time the start criteria is exactly the same as in plymouth-splash.conf.
Serrano, if even this doesn't fix the problem for you, looks like I'll have to get rid of Upstart completely and provide an alternative way of starting the script. Probably utilizing sysvinit scripts might work, but they're handled by Upstart, too. I'll investigate this.

Serrano, I think there is a solution in your case after all. Try this plymouth.conf.

Sergey, still no luck.

OK, finally I know how workaround this, but it's so ugly by design that the script will become an unmaintainable mess if I write it. Instead I started negotiations with upstream Plymouth developers about inclusion the core of this system into plymouth's script plugin. It will make the code much cleaner and we'll get rid of 98% of possible framework bugs.

I didn't receive any reply in Plymouth mailing list, so I've contacted the Plymouth Script plugin developer directly, I hope we'll sort this out soon. I've marked this bug "Won't fix" in 0.3 series because, as I said, I don't want to keep the current ugly architecture and complicate it even more by this workaround. This bug will be fixed by the architecture revamp which arrives in 0.4 series.

This bug is affecting me only by puting FRAMEBUFFER=y in /etc/initramfs-tools/conf.d/splash. Deleting this file or set to FRAMEBUFFER=n will show the message. But since I use fglrx, the plymouth screen will show up very late and only for a short time.

Christian, thanks for the info! I'd never imagine that the problem can be in that too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers