poldek tries to replace valid application with other

Bug #747010 reported by Arkadiusz Miśkiewicz on 2011-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PLD Linux
Undecided
Unassigned

Bug Description

The situation is like that:
- I have pure-ftpd installed. It is linked with libmysqlclient.so.16
- On ftp there in new mysql with libmysqlclient.so.18. Some apps on ftp are already rebuilt with new libmysqlclient but not pureftpd.
- Trying to upgrade mysql causes poldek to try to replace pure-ftpd with proftpd which is _insane_ thing to do. It shouldn't replace apps just because some dep is not fullfiled.

poldek:/all-avail> greedy-upgrade mysql-*
Processing dependencies...
mysql-libs-5.5.9-6.x86_64 obsoleted by mysql-libs-5.5.10-1.x86_64
  greedy upgrade pure-ftpd-1.0.29-3.x86_64 to proftpd-inetd-1.3.3d-2.x86_64 (unresolved libmysqlclient.so.16()(64bit))
   pure-ftpd-1.0.29-3.x86_64 obsoleted by proftpd-inetd-1.3.3d-2.x86_64
   proftpd-inetd-1.3.3d-2.x86_64 marks rc-inetd-0.17-2.noarch (cap /etc/sysconfig/rc-inetd)
rc-inetd-0.17-2.noarch: required "inetdaemon" is provided by the following packages:
a) inetd-0.17-14.x86_64
b) rlinetd-0.7-1.x86_64
c) xinetd-2.3.14-6.x86_64
Which one do you want to install ('Q' to abort)? [a]

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers