poldek install command line and textui mismatch

Bug #729521 reported by Elan Ruusamäe on 2011-03-05
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PLD Linux

Bug Description

please make "poldek --install" and "poldek> install" behave identically

currently textui seems to do "rpm upgrade", while commandline seems to do "rpm install":

poldek:/all-avail> ins kernel-nogrsecurity- kernel-nogrsecurity-drm- --nohold
Processing dependencies...
kernel-nogrsecurity- obsoleted by kernel-nogrsecurity-
kernel-nogrsecurity-drm- obsoleted by kernel-nogrsecurity-drm-
  greedy upgrade kernel-nogrsecurity-sound-alsa- to (unresolved kernel-nogrsecurity = 3:
   kernel-nogrsecurity-sound-alsa- obsoleted by kernel-nogrsecurity-sound-alsa-
There are 3 packages to install (1 marked by dependencies), 3 to remove:
I kernel-nogrsecurity- kernel-nogrsecurity-drm-
D kernel-nogrsecurity-sound-alsa-
R kernel-nogrsecurity- kernel-nogrsecurity-drm- kernel-nogrsecurity-sound-alsa-
This operation will use 511.0B of disk space.
Need to get 32.1MB of archives (32.1MB to download).


$ poldek --sn carme -i kernel-nogrsecurity- kernel-nogrsecurity-drm- --nohold
Loading [pndir]carme...
1014 packages read
Processing dependencies...
There are 2 packages to install:
I kernel-nogrsecurity- kernel-nogrsecurity-drm-
This operation will use 31.8MB of disk space.
Need to get 30.1MB of archives (30.1MB to download).

Elan Ruusamäe (glen666) wrote :

by identically i mean, do the "rpm install" mode always.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers