autofs package incompatible with older kernels

Bug #406177 reported by Elan Ruusamäe on 2009-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PLD Linux
Undecided
Unassigned

Bug Description

seems autofs misses some kind of R: uname(release) dependency:

+ echo /usr/sbin/automount --timeout 60 /net file /etc/autofs/auto.net-glen
/usr/sbin/automount: kernel protocol version 5.00 or above required.
                                                                                                                                [ FAIL ]
08:36:30 root[load: 0.08]@hellsgate /etc/syslog-ng# uname -r
2.6.25.17-1

08:36:42 root[load: 0.06]@hellsgate /etc/syslog-ng# rpm -qf /usr/sbin/automount
autofs-5.0.2-2.i686

Elan Ruusamäe (glen666) wrote :

also /etc/sysconfig/autofs contained incompatible -g option:

# Additional daemon options
OPTIONS="-g"

+ echo /usr/sbin/automount --timeout 60 -g /net file /etc/autofs/auto.net-glen
/usr/sbin/automount: Ambiguous or unknown options

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers