poldek crashes if there are more than 64k packages in sources

Bug #1571324 reported by Jan Rękorajski on 2016-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
poldek
High
Marcin Banasiak
PLD Linux
Undecided
Unassigned

Bug Description

poldek crashes if there are more than 64k packages available in sources:

# poldek -n th-all
Loading [pndir]th...
Loading [pndir]th-i686...
Loading [pndir]th...
Loading [pndir]th-ready...
Loading [pndir]th-x32...
Loading [pndir]th-x32-ready...
Loading [pndir]th-ready...
Loading [pndir]th-test...
Loading [pndir]th-x32-test...
Loading [pndir]th-test...
Loading [pndir]th-i686-ready...
Loading [pndir]th-i686-test...
67914 packages read
Removed 2 duplicate packages from available set
Segmentation fault (core dumped)

I narrowed it down to file_index_setup() call in pkgset.c:pkgset_index() what is just n_array_sort on a file index.
The problem looks like a memory leak due to internal use of int16_t data, but I'm not familiar enough with the code to find the root cause.

Changed in poldek:
milestone: none → 0.32.2
assignee: nobody → Marcin Banasiak (megabajt)
importance: Undecided → High
Elan Ruusamäe (glen666) wrote :

wasn't this reported already before? mailing list maybe?

Marcin Banasiak (megabajt) wrote :
Changed in poldek:
status: New → Fix Committed
Changed in poldek:
status: Fix Committed → Fix Released
Marcin Banasiak (megabajt) wrote :

Fix is available in 0.32.2 release.

Changed in pld-linux:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers