[needs-packaging] Rigs of rods

Bug #413515 reported by 569874123 on 2009-08-14
98
This bug affects 17 people
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Wishlist
Unassigned
Playdeb
Low
Unassigned
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Rigs of Rods (also known as RoR), is an Open Source truck, car, airplane and boat simulator. You can drive, fly or sail in total freedom in an open environment. What makes RoR different to most simulators is its unique soft-body physics: vehicles chassis and wheels are simulated in real-time as flexible objects, giving the simulation an extremely accurate behavior, while allowing the vehicles to be simply specified by their structural composition, as a network of interconnected nodes (forming the chassis and the wheels). Crashing into walls or terrain can permanently deform a vehicle in a realistic manner. In addition to its unique soft-body physics, RoR also features an advanced flight model based on blade element theory, allowing the accurate simulation of any airplane, base on their physical dimensions and wing airfoils. It also features an accurate buoyancy model based on elemental pressure gradients, enabling boats with complex hulls to move realistically in the swell.
Rigs of Rods is an amateur game developped by Pierre-Michel Ricordel, aka Pricorde, and is a one man hobby development, with a $0 budget, that has started more than two years ago and is still continuing. Recently a second developer, Thomas, has joined the "team". He is also the donator and caretaker of the web sites. A growing community has build up since some time and has contributed many vehicles to the game.

569874123,
http://apt.rigsofrods.com/
It has an APT repo I do think we should take our own route with this one. Nice Game to add to the games.
Regards,
Leo

Changed in playdeb:
importance: Undecided → Wishlist
569874123 (chris569874123) wrote :

First of all, i have to thank all who contributed for such a wonderful project.
@Leo Albert Jackson Jr, thanks for the info about the repo, but it is outdated :(.
PS:Please take a look at my question https://answers.launchpad.net/playdeb/+question/80248

569874123 ,
Hello This not a rejection it is the state we must follow.
1. We confirm that it does not already exist. (If yes we can upgrade if available.) and add to our repo cause we are have the games available in one place. PlayDeb
2. The source is available so we can manage it into a deb package.
3. Licensed under a free license and does not require data or binaries from source purchased and Copyrighted
(permission for these are sometimes granted.) Then it is ok to do so.
4. If a binary is only available then we check if LGPL license so we can package it.
Most client installers are already available and we usually will not be granted permission to the source hence we cannot package it. And there binary are under a license for us not to alter.

Regards,
Leo Jackson Jr
lajjr

Changed in playdeb:
status: New → Confirmed
Changed in playdeb:
assignee: nobody → Leo Albert Jackson Jr (lajjr)
status: Confirmed → In Progress
Christoph Korn (c-korn) wrote :

Package requests for games belong to getdeb.

Playdeb bugs are about the web page.

Changed in getdeb.net:
assignee: nobody → Leo Albert Jackson Jr (lajjr)
importance: Undecided → Wishlist
status: New → In Progress
Changed in playdeb:
assignee: Leo Albert Jackson Jr (lajjr) → nobody
importance: Wishlist → Low
status: In Progress → Invalid
Changed in getdeb.net:
assignee: Leo Albert Jackson Jr (lajjr) → nobody
status: In Progress → Confirmed
João Pinto (joaopinto) wrote :

The game is not complete enough to be released.

Just for reference here is the build depend list:
cmake
libwxgtk2.8-dev
libcegui-mk2-dev
libzzip-dev
nvidia-cg-toolkit
libogre-dev
libopenal-dev
libasound2-dev
libglut3-dev
libxxf86vm-dev
libxrandr-dev
libgtk2.0-dev

Changed in getdeb.net:
status: Confirmed → Won't Fix
Changed in playdeb:
status: Invalid → Won't Fix
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist

FYI, I think RoR will be ready for release very soon, or may already be. They are going to be releasing 0.37 soon so it may make sense to take that into Ubuntu/Debian.

This isn't really a game, it's more of a physics simulator, so the absence of any goals or missions is intentional.

Changed in ubuntu:
status: New → Confirmed
Guest One (g.one) on 2012-10-22
summary: - [needs-packaging] Rigs of rods.
+ [needs-packaging] Rigs of rods
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.