playdeb server unavailable causes apt to crash: "Method gave invalid 400 URI Failure message"

Bug #278635 reported by lopho on 2008-10-05
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Playdeb
High
Unassigned
apturl
Invalid
Undecided
Unassigned
apt (Ubuntu)
Medium
Michael Vogt

Bug Description

sys: Ubuntu 8.04, 8.10, 9.04 32bit

Having the playdeb repository entry in the sources.list file makes the apt fail when catching repository info on ALL repositorys.

Only output is:

" sudo apt-get update
" E: Method gave invalid 400 URI Failure message
" E: Method gave invalid 400 URI Failure message

This happens when the master server is down.

At any rate, this is an apturl bug, not a playdeb one.

That is only partially true, as apt wont have any problems fetching the info if any other server is down (not only talking about the official repros, for example medibuntu or redmoon or gehringnet or whatever)

So if you just might take a look if there is any method of a workaround it would be helpful. I is a pain in the buns to always having to comment out the repro in sources.list.

There is no workaround, this is an apt problem with the distributed mirror
setup.

So how do we fix this even if we removed the playdeb package? It's still giving me the error after removing the package.

Nevermind, forgot to purge the package instead of simply removing.

Purge, wait a few days, hope that apt forgets about it and re-add.

I believe mvo said he'll be helping to debug this apt bug. Playdeb is the
only repository so far to use the dynamic mirror selection apparently, so it
is buggy.

Szymon Życiński (zycinski) wrote :

i also faced this problem, at this moment disabled this repo, hope it will be fixed becouse it gives an apt a knife in the back ;-)

João Pinto (joaopinto) wrote :

Once the server becomes available to force APT to refresh and get the proper mirror the following file needs to be removed before apt-get upgrade:
/var/lib/apt/mirrors/www.getdeb.net_playdeb-mirror_intrepid

Changed in playdeb:
importance: Undecided → High
status: New → Confirmed
Changed in apturl:
status: New → Invalid
Changed in apt:
status: New → Confirmed
Michael Vogt (mvo) on 2008-11-18
Changed in apt:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → jaunty-alpha-2
status: Confirmed → Triaged
Vadim Peretokin (vperetokin) wrote :

Is there any word on this?

Michael Vogt (mvo) on 2009-01-21
Changed in apt:
milestone: jaunty-alpha-2 → jaunty-alpha-4
Germán Pabón (ninboy) wrote :

4 months and still no fix? :S

dotancohen (dotancohen) wrote :

@Vadim: The alpha 4 is out.

Vadim Peretokin (vperetokin) wrote :

I know. Mvo said he'll look into it today if it's an easy fix.

If no - we'll switch to apt's http redirect, which recently got updated to
have it. We're working on the new site and CMS atm for Playdeb.

João Pinto (joaopinto) wrote :

We will be switching to http redirect in the future, this will not be a problem for playdeb.

Changed in playdeb:
status: Confirmed → Invalid
Michael Vogt (mvo) on 2009-03-19
Changed in apt (Ubuntu):
milestone: jaunty-alpha-4 → ubuntu-9.04-beta
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.20.2ubuntu3

---------------
apt (0.7.20.2ubuntu3) jaunty; urgency=low

  * methods/mirror.cc:
    - when download the mirror file and the server is down,
      return a propper error message (LP: #278635)

 -- Michael Vogt <email address hidden> Thu, 19 Mar 2009 15:42:15 +0100

Changed in apt:
status: In Progress → Fix Released
Arie Skliarouk (skliarie) wrote :

I have installed playdeb on Ubuntu 9.04 and when I did "apt-get update" (before even trying to install any of the games (!)), I have got follwoing:

...
E: Method gave invalid 400 URI Failure message
E: Method gave invalid 400 URI Failure message

Psychopump (belowareptile) wrote :

Indeed the playdeb repo still gives the 400 error, but when commented out the problem does NOT persist, so in fact the apt issue IS resolved.
Now all we need is a working repo from playdeb!

lopho (lopho) wrote :

Same here. URI error still persists, even with apt fixed.

Obviously an Playdeb bug!
This is not fixed, nor invalid, this is a serious bug, and pretending the bug doesnt matter or isnt playdebs concern is NOT a good idea.

hopefully there will something be going on regarding this issue.

João Pinto (joaopinto) wrote :

Zweistecken,
The problem happens when using the playdeb mirror the same way it could happen with any other project providing a mirror using the same APT method, yes, it happens when the playdeb master server is not available, however that way it is handled by Ubuntu's package manager has nothing to do with playdeb.

The bug was fixed on apt since Jaunty.

Vadim,
to avoid continuos complains like this we should consider again to shutdown the playdeb site until we can provide the newer site with a working mirror selection.

Vadim Peretokin (vperetokin) wrote :

Yes I guess we should replace with a 'We're coming out with a newer and
better version' sign.

lopho (lopho) wrote :

"The bug was fixed on apt since Jaunty."

true. i am using Jaunty, but still the problem persists when using the playdeb repository

lopho (lopho) on 2009-06-05
description: updated
tags: added: jaunty
Rahul Ghose (rahulg) wrote :

Is this a playdeb problem?

João Pinto (joaopinto) wrote :

No, the described problem is about apt failing when an archive is unavailable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers