Allow hiding the dock only when the active window is maximized

Bug #900814 reported by Sergey "Shnatsel" Davidoff
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Plank
Won't Fix
Wishlist
Rico Tzschichholz
elementary OS
Fix Released
High
Unassigned
0.2-luna
Fix Released
High
Unassigned

Bug Description

Please add an option for hiding the dock only when the active window is maximized. It's required for elementary OS UX.

Revision history for this message
Robert Dyer (psybers) wrote :

Intellihide is good enough.

Changed in plank:
status: New → Won't Fix
Revision history for this message
Rico Tzschichholz (ricotz) wrote :

We will add this option and call this hide-mode elementary. So you can play with it.

Changed in plank:
status: Won't Fix → Triaged
importance: Undecided → Low
assignee: nobody → Rico Tzschichholz (ricotz)
Revision history for this message
Robert Dyer (psybers) wrote :

Let me be completely clear about this: this feature will not go into Plank trunk. I feel that Intellihide is a sufficient option. I was actually planning on removing Autohide from Plank in the near future.

The goal of Plank is to keep it as simple as possible. Less is better. It may not please everyone, but that is not the point of the project and just a trade-off that must be made.

Rico: You are more than free to implement this (or anyone else can), however it will not merge into trunk. If Elementary OS wants this feature in Plank, they will have to maintain a patch, build a custom binary and ship that.

Changed in plank:
status: Triaged → Won't Fix
importance: Low → Wishlist
Changed in elementaryos:
status: New → Confirmed
Revision history for this message
Danielle Foré (danrabbit) wrote :

Based on the fact that Robert doesn't want to implement this feature and we're past the point of feature freeze ourselves, I think this probably isn't getting into Luna.

Untargeting for this milestone.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Re-targeting back to Luna because there's already a patch for this.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

elementary-default-settings sets hide mode to elementary now.

Revision history for this message
Francisco Soares (forbidden404) wrote :

I know I'm very late, but sometimes when the windows is maximized, plank still up, it usually happens with Skype or another chat application

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers