Plank is not GTK3

Bug #836636 reported by Sergio Spinatelli on 2011-08-29
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Plank
Wishlist
Rico Tzschichholz
Frugalware Linux
New
Undecided
Unassigned

Bug Description

The title says kinda everything.. :P

Related branches

Robert Dyer (psybers) on 2011-08-29
Changed in plank:
importance: Undecided → Wishlist

This is actually pretty important visually for elementary if you're keeping GTK menus; the GTK3 menu styling is about 100x nicer than the GTK2 styling. :)

If you're doing custom/themable menus, then I suppose it's less important visually, but it'd still be nice. We're aiming to ship with as much GTK3 (and as little GTK2) as possible. WingPanel, Slingshot, Marlin, Postler, Maya, Dexter, Empathy, BeatBox, Lingo, and Switchboard are all GTK3. :)

Again, this is specific to elementary. I guess GTK2-compatibility is good for users who are on older platforms without GTK3 libraries.

Robert Dyer (psybers) on 2011-10-10
Changed in plank:
status: New → In Progress
assignee: nobody → Rico Tzschichholz (ricotz)
tags: added: gtk3
Changed in plank:
status: In Progress → Fix Committed
Changed in plank:
status: Fix Committed → Fix Released
Robert Dyer (psybers) on 2012-02-16
Changed in plank:
status: Fix Released → In Progress
Changed in plank:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions