Icons disappear from Plank after updates.

Bug #1760433 reported by Richard
54
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Plank
Undecided
Unassigned
plank (Ubuntu)
High
Unassigned

Bug Description

Is this normal behaviour for Plank to remove icons after updating the system?
Yesterday Firefox, Chromium and Libre-office got updates and during the updating process those 3 icons were removed.

I had to put them back in place manually.

I'm running this on Arch, Xfce.

description: updated
summary: - Icons dissappear from Plank after updates.
+ Icons disappear from Plank after updates.
Revision history for this message
Julian Raschke (jlnr) wrote :

I've only experienced this with apps updated via snapd. Every time a new version of IntelliJ IDEA is released, the icon disappears from my Dock. Apps installed via apt or flatpak have been unaffected so far.

Revision history for this message
Tyler Jones (jylertones) wrote :

There's a thread of Manjaro linux users who have the same problem:

https://forum.manjaro.org/t/icons-dissappearing-from-plank-after-updates/43740

What's suspected is that when applications are upgraded, the shortcut is removed and added again in a way that Plank only thinks that a removal has occurred. The best known workaround is to create a copy of the launchers, or to re-add the affected applications to the dock after update.

Revision history for this message
Rico Tzschichholz (ricotz) wrote :
Revision history for this message
Roman (thezub) wrote :

Is the above commit in the version? I still experience this bug and it's a pain in the ass. Ubuntu 18.04.

Revision history for this message
Juan (zubonto) wrote :

I see this commit mentioned above "Increase delay for auto-removal of broken/unavailable applications to 1 min" is included in the latest release (0.11.89).

I still notice this annoying behaviour in Xubuntu LTS 20.04 with package 0.11.89.
Happens when an upgrade happens via snapd or apt.

Package: plank
Version: 0.11.89-1
Priority: optional
Section: universe/utils
Origin: Ubuntu

Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

This is still an issue with updated snaps occurring on Ubuntu MATE 20.04 and 20.10 running plank 11.89-1.

Changed in plank:
status: New → Confirmed
Revision history for this message
awissu (avvissu) wrote :

I confirm this bug on openSUSE TW.
From journalctl log fetching:

[CRITICAL 12:34:09.195527] [ApplicationDockItem:576] file:///usr/share/applications/io.elementary.code.desktop-RPMDELETE: No such file or directory
[WARN 12:34:09.280086] [Utils:119] An error occurred while retrieving file information «/home/awissu/.config/plank/dock1/launchers/.goutputstream-L3YG90»: No such file or directory

cat ~/.config/plank/dock1/launchers/io.elementary.code.desktop

#This file auto-generated by Plank.
#2021-09-08T09:50:15+0000

[PlankDockItemPreferences]
#The uri for this item.
Launcher=file:///usr/share/applications/io.elementary.code.desktop-RPMDELETE

Revision history for this message
Dani Llewellyn (diddledani) wrote :
Changed in plank (Ubuntu):
status: New → Confirmed
tags: added: bionic focal hirsute impish
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "disappearing-entries-on-updates-fix.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in plank (Ubuntu):
status: Confirmed → Triaged
Changed in plank (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plank - 0.11.89-4

---------------
plank (0.11.89-4) unstable; urgency=medium

  [ Mike Gabriel ]
  * debian/control:
    + Bump Standards-Version: to 4.6.0. No changes needed.
  * debian/patches:
    + Add 1001_fix-vala-doc-build.patch. Fix vala-doc generation. Recently,
      image file format has been changed from .png to .svg files. (Closes:
      #997520).
  * debian/libplank-doc.install:
    + Install API doc files to /usr/share/doc/plank/html/.
  * debian/libplank-doc.doc-base:
    + Add file. Register libplank API with doc-base.
  * debian/watch:
    + Switch to file format version 4.

  [ Martin Wimpress ]
  * debian/patches:
    + Add 0002_fix_disappearing_dock_items.patch (LP: #1760433).

 -- Mike Gabriel <email address hidden> Tue, 16 Nov 2021 16:11:07 +0100

Changed in plank (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers