Trash Docklet doesn't open Thunar

Bug #1610183 reported by Gre0
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Plank
New
Undecided
Unassigned

Bug Description

I'm on Linux Mint 18 xfce and i installed Plank through the integrated Repositories.
I want to use the Trash-docklet but when i click on it to open the trash folder...Audacious opens with the following...

Error opening trash: ///:
Unknown URL scheme

After that i remove Audacious, but then nothing happens if i want to open trash with docklet.

Option 'Empty trash' does work fine.

Package: plank
Priority: optional
Section: universe/utils
Installed-Size: 383
Maintainer: Rico Tzschichholz <email address hidden>
Architecture: amd64
Version: 0.11.1-1
Depends: libplank1 (= 0.11.1-1), libc6 (>= 2.4), libcairo2 (>= 1.10.0), libgee-0.8-2 (>= 0.8.3), libglib2.0-0 (>= 2.40.0), libgtk-3-0 (>= 3.10.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libwnck-3-0 (>= 2.91.6)
Filename: pool/universe/p/plank/plank_0.11.1-1_amd64.deb
Size: 81020
MD5sum: cb489db9921bae1f7363b153099e8a41
SHA1: 08bd391a1ddee44f8405355c0346805ecd0e273f
SHA256: e69c43f5c8fab0a3a15fae4d410600364b40f5af414c32d410c9fe4bc5870852

Revision history for this message
Gre0 (gre0) wrote :
Revision history for this message
harunou (harunou) wrote :

The same thing was annoing me for the last week....

I'm using Arch+XFCE. So what I found.

Running Plank in terminal were giving me next errors:
[CRITICAL 15:19:27.034831] [System:201] No application is registered as handling this file
[CRIICAL 15:19:27.034867] [System:206] Unable to use application/file '(null)' for execution.

As Plank relies on GVFS i tried
$ gvfs-open trash://
and the command returned error like "No application is registered as handling this file".

It means we need register application (Thunar) to open 'trash://' URI (here I should say, that with Gnome FM installed there were no problems at all) in GVFS.

I found this article https://help.ubuntu.com/community/DefaultFileManager
tl;tr
last chapter "One more way - for "mousemonkeys", like me" told to open "Preffered applications" manager, where Thunar was already set up as default FM, i closed the window, and OMG the Trash docklet opened the trash folder as well as $ gvfs-open trash://. Still works.

Funny .... yeah...

Revision history for this message
harunou (harunou) wrote :

And a short addition
1. Read Arch wiki (hope works for Mint)
   https://wiki.archlinux.org/index.php/Default_applications
   https://wiki.archlinux.org/index.php?title=Desktop_entries&redirect=no

If TL;TR, bind x-scheme-handler/trash MIME type to file manager desktop entry

$ gvfs-mime --set x-scheme-handler/trash exo-file-manager.desktop
where exo-file-manager.desktop is
[Desktop Entry]
Version=1.0
Type=Application
Exec=exo-open --launch FileManager %u
Icon=system-file-manager
StartupNotify=true
Terminal=false
Categories=Utility;X-XFCE;X-Xfce-Toplevel;
OnlyShowIn=XFCE;
X-XFCE-MimeType=inode/directory;x-scheme-handler/trash;
_Name=File Manager
_Comment=Browse the file system

or

$ gvfs-mime --set x-scheme-handler/trash Thunar-url.desktop
Where Thunar-url.desktop is
[Desktop Entry]
Name=Thunar File Manager
Comment=Browse the filesystem with the file manager
GenericName=File Manager
Exec=thunar %u
Icon=Thunar
Terminal=false
StartupNotify=true
Type=Application
Categories=System;Utility;Core;GTK;FileTools;FileManager;

Revision history for this message
Gre0 (gre0) wrote :

Ok i tried the 'terminal-mouse-monkey'...:D
Just do in terminal...

exo-preferred-applications

then switch to Utilities tab and select File Manager you prefer. And that's all! Now it's working.

So, what we do with this Bug report...is it related to Linux Mint, Plank or a combination of two? I mean, now it works for me but not by default...not every user may read this and expect it to work right after install.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers