Plank crashes when trying to drag icons/ reorder icons

Bug #1505440 reported by James Bulman on 2015-10-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Plank
Undecided
Unassigned

Bug Description

Whenever I try to drag icons around to reorder them or remove them from the dock it crashes and disappears. This happens whether or not the icon is docked or just has a window open
When running it through terminal when it crashes I am faced with this error:

[Gdk] The program 'plank' received an X Window System error.This probably reflects a bug in the program.The error was 'BadWindow (invalid Window parameter)'. (Details: serial 17182 error_code 3 request_code 141 (Composite) minor_code 8) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the GDK_SYNCHRONIZE environment variable to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap

Linux Distribution - Linux Mint 17.2 XFCE variant
Plank Version - 0.10.1
Desktop Environment - xfce4 4.12
Window Management - xfwm4 4.12.3
Desktop - xfdesktop 4.12.2 built on GTK+ 2.24.23, linked with GTK+ 2.24.23
GTK2 = 2.24.23-0ubuntu1.2
GTK3 = 3.10.8~8+qiana
X.Org X Server 1.15.1

I have a dual GTX 680 graphics cards setup running the latest binary drivers (version 352.41) with dual monitors. SLI is currently off and Xinerama is on to make sure both of my monitors work properly. I can provide my xorg.conf if needed.

I installed plank by adding the deb http://ppa.launchpad.net/ricotz/docky/ubuntu trusty main ppa and running apt-get plank

If you require anything else please let me know and I will do my best to provide it. Running gdb --args plank -d returns nothing for some reason even if I run plank via the plank --debug command

Rico Tzschichholz (ricotz) wrote :

I can't do much without a backtrace.

GDK_SYNCHRONIZE=1 gdb --args plank -d
and "run"

Changed in plank:
status: New → Incomplete
James Bulman (jamesbul2009) wrote :

I have switched distribution now to Ubuntu Gnome 15.10 and it is working fine on here, I will try to install The Mint distro I have put above to get the backtrace but It might take a little while.
I have also removed one of my graphics cards so I am no longer running any sort of SLI

Launchpad Janitor (janitor) wrote :

[Expired for Plank because there has been no activity for 60 days.]

Changed in plank:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers