Google Chrome can't be matched to an existing desktop-file

Bug #1415581 reported by Derek Pockrandt on 2015-01-28
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Plank
Undecided
Unassigned

Bug Description

When opening default google chrome link (on the plank) by clicking its icon on the plank, chrome shows itself under another, lower resolution icon. I cannot right click the low res icon and say "keep in dock" or anything like that. If I click the original chrome icon again, it opens another new window session.

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.357+401~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-44.73-generic 3.13.11-ckt12
Uname: Linux 3.13.0-44-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Wed Jan 28 11:45:05 2015
InstallationDate: Installed on 2015-01-08 (20 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors: [WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Derek Pockrandt (derekpock) wrote :
Adolfo Jayme (fitojb) on 2015-01-28
affects: elementaryos → plank
Elvis Dominguez (elvisd79) wrote :

Just a little additional information:
I have installed plank on ubuntu 14.10 (unity), if I start Chrome from plank a new (low-res) icon is created in both plank and unity launcher.
If I launch chrome from Unity launcher the second Icon doesn't appear in unity launcher nor in plank.
So to resume: only when launched from plank an additional icon is created.

Derek Pockrandt (derekpock) wrote :

Got some good updates here!
After startup, clicking on the Chrome icon creates the low-res icon. However, after you close chrome (and apparently on startup), chrome is running in the background. If I run `killall chrome`, then run `google-chrome`, the additional icon is NOT created. If, after that, I close chrome and click on the regular icon, chrome still opens without the additional icon. If I was to do `killall chrome` again, and then click the regular icon on plank, the additional low-res icon appears again, and will always appear until I `killall chrome` again.

Explanation: Chrome opens new windows in the same browser session if chrome is already running in the background. On startup, chrome is running the bad session (the one which will cause the low-res icon to appear). If I kill that and run `google-chrome` with no special options, chrome now runs in a good session. Closing the chrome window does not end the session, but `killall chrome` does. Any chrome shortcut under the Application menu or the Plank will create a bad session if no session is currently running. `google-chrome` creates a good session.

Suggest change the chrome shortcuts file to include no special arguments and just run regular `google-chrome` by default.

Derek Pockrandt (derekpock) wrote :

Correction, after running `killall chrome`. The Applications Menu chrome seems to start a good session.

Derek Pockrandt (derekpock) wrote :

Correction #2, it seems that the only time a bad session is created is on startup. I think what I was that I "keep in dock"ed the bad session icon. After removing it and replacing it with the good session icon in Applications menu (by dragging), it now starts good sessions. Bad sessions are created on startup. Temporary work around is to killall chrome on startup.

Derek Pockrandt (derekpock) wrote :

Sigh...correction #3: After restart, the plank chrome icon starts bad sessions after killall chrome again. Applications menu icon still creates good sessions after killall chrome. Something with the icon/desktop file on plank is being changed from the one in Applications menu. If I open a bad session, I get an explosion of different arguments on the chrome session. See attached file. These are the two different arguments. The goodSession and badSession.

Derek Pockrandt (derekpock) wrote :

This is a long-standing known bug in Google Chrome. https://code.google.com/p/chromium/issues/detail?id=378881

tutuca (tutuca) wrote :

Looks like they passed the ball to gnome-shell folks. <sigh>.

harris (harrismrubin) on 2015-04-05
Changed in plank:
status: New → Confirmed
summary: - google chrome shows additional icon on plank when opening
+ Google Chrome can't be matched to an existing desktop-file
Rico Tzschichholz (ricotz) wrote :

This is not a plank bug, but an error of chrome and its desktop-file.

https://www.google.com/search?q=chrome+plank

Changed in plank:
status: Confirmed → Invalid

I too see errors of the following kind (cf. bug #943083):

Failed to fetch xids: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.ayatana.bamf.application' on object at path /org/ayatana/bamf/application/1932146384

And I too have Chrome in the dock.

I was not actually having any problems with Chrome, except that it took a while for it to appear in the dock - though that besets other applications to - until I tried the fix. The first fix listed in the Google search mentioned above actually caused me to have a blurry Chrome icon, i.e. caused the problem it was meant to prevent!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.