clicking on an app from another workspace does not give it focus

Bug #1167787 reported by Lochlan Bunn on 2013-04-11
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Plank
Low
Rico Tzschichholz

Bug Description

When you click on an app, in Plank, and it is in another workspace, that app is not given focus when the workspaces have switched. Instead, the app is brought to the front and the focus is given to one of the apps in the background. Very confusing behaviour and is a jarring halt for work flows using workspaces.

I'm using Plank 0.2.0.800; Nvidia 310M drivers 310.14.

Changed in plank:
status: New → Confirmed
Robert Dyer (psybers) on 2013-05-16
Changed in plank:
importance: Undecided → Low
thndsr (stijnverwaaijen) wrote :

It seems that this bug has somehow disappeared. Can anyone confirm this?

Lochlan Bunn (loklaan) wrote :

I can confirm it still exists with running up to date packages. Tested with switching *to* a browser or a notepad from a different workspace.

thndsr (stijnverwaaijen) wrote :

Oh I completely forgot I'm not using an Nvidia card anymore. So it's probably Nvidia-specific. Please excuse me.

Robert Dyer (psybers) wrote :

This is almost surely a timing issue related to workspace change animations. If we don't wait for the workspace switch animation to finish and try to focus the window before that, it doesn't receive focus.

Most likely your animation timing changed so it is faster, so you no longer see the bug.

thndsr (stijnverwaaijen) wrote :

That could very well be the case since I disabled animations. :)

Thnx for clearing that up!

Lochlan Bunn (loklaan) wrote :

I've tested switching after reducing/disabling animation of the workplace switch. I used elementary-tweak to change the animation time.

I again used a number of programs that had text input (as the primary focus *within* the application, as that is the cause of grief); browsers, text editors and chat clients. It didn't matter that I reduced/disabled the animation, the bug still persists for me. The only exception was switching to focus a window of Firefox, and that actually *did* give focus to Firefox every time, no matter the testing scenario

i don't really know how else to contribute to helping fix this bug. If anyone has further ideas please comment. :)

Changed in plank:
milestone: none → 0.10.0
Rico Tzschichholz (ricotz) wrote :

Proposed fix in r1284

Changed in plank:
status: Confirmed → Fix Committed
assignee: nobody → Rico Tzschichholz (ricotz)
Changed in plank:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers