Show windows of current workspace only

Bug #1053202 reported by Nishant George Agrwal on 2012-09-20
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Plank
Wishlist
Rico Tzschichholz

Bug Description

Currently, windows from all workspaces are shown in Plank. In Docky, there was an option to show windows of the current workspace only. When enabled, the dock would ignore all windows not in the current workspace, allowing you to forget about them and concentrate exclusively on the windows/tasks at hand. It would be awesome to have this feature in Plank :)

Related branches

Robert Dyer (psybers) on 2012-09-20
Changed in plank:
importance: Undecided → Wishlist
summary: - Feature Request: Show windows of current workspace only
+ Show windows of current workspace only
Changed in plank:
status: New → Triaged
Ari (ari-lp) wrote :

I also think that this would be a very nice enhancement to have. It's a small change that can greatly improve the workflow for people searching for this use case.

skypce (skypce) on 2012-11-22
Changed in plank:
status: Triaged → New
status: New → Incomplete
status: Incomplete → Opinion
Robert Dyer (psybers) wrote :

Please don't change bug status.

Changed in plank:
status: Opinion → Triaged
skypce (skypce) wrote :

ok sorry, i am looking options

Changed in plank:
status: Triaged → Fix Committed
assignee: nobody → Rico Tzschichholz (ricotz)
Robert Dyer (psybers) wrote :

That was by design. If an item is 'pinned' then it should always be visible on the dock.

Changed in plank:
status: Fix Committed → Fix Released
Nishant George Agrwal (niagr) wrote :

Can this feature be improved by modifying the behaviour when a pinned item is clicked, so if the application (say a browser) is opened on a different workspace, then try to launch a new instance of the app instead of taking you back to the other workspace?

Rico Tzschichholz (ricotz) wrote :

@niagr: Please don't hijack a closed bug. Just file a new one.

Nishant George Agrwal (niagr) wrote :

Sorry, I thought this was appropriate as it was related to this feature. I'll file a new one.

baris (bariscepik) on 2017-10-19
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers