Expand dock if a .desktop-file is dragged on dock [$25]

Bug #1007058 reported by Eduard Gotwig on 2012-05-31
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Pantheon Dock
Fix Released
Low
Rico Tzschichholz
Plank
Low
Rico Tzschichholz

Bug Description

When a .desktop file is dragged to Plank, it should expand to accomodate it.

Related branches

Eduard Gotwig (gotwig) on 2012-05-31
description: updated
tags: added: dnd
summary: - Don't hide out launchers in dock if a .desktop file from Slingshot is
- draged there
+ Don't darken launchers if a .desktop-file is dragged on dock
Changed in plank:
status: New → Confirmed
importance: Undecided → Low
summary: - Don't darken launchers if a .desktop-file is dragged on dock
+ Expand dock and don't darken launchers if a .desktop-file is dragged on
+ dock
description: updated

Any progress? I don't see progress in any branch.

Daniel Fore (danrabbit) on 2013-09-27
Changed in plank:
milestone: none → isis-beta1
Changed in pantheon-dock:
status: New → Confirmed
importance: Undecided → Low
milestone: none → isis-beta1
Changed in plank:
milestone: isis-beta1 → none
Daniel Fore (danrabbit) on 2014-03-16
Changed in pantheon-dock:
milestone: isis-beta1 → none
summary: - Expand dock and don't darken launchers if a .desktop-file is dragged on
- dock
+ Expand dock if a .desktop-file is dragged on dock
tags: removed: dnd
description: updated
Changed in plank:
milestone: none → 0.10.0
Changed in plank:
milestone: 0.10.0 → 0.11.0
Daniel Fore (danrabbit) wrote :
summary: - Expand dock if a .desktop-file is dragged on dock
+ Expand dock if a .desktop-file is dragged on dock [$25]
Keith Bailey (kbailey4444) wrote :

I'm not affected by this bug. I have plank version 0.10.0. Under what circumstances does the dock not expand and accept a desktop file?

Rico Tzschichholz (ricotz) wrote :

This is not a bug but a feature request. Expanding is currently only available with enabled zoom.

Changed in plank:
status: Confirmed → In Progress
assignee: nobody → Rico Tzschichholz (ricotz)
Rico Tzschichholz (ricotz) wrote :

Fixed in r1481

Changed in plank:
status: In Progress → Fix Committed
Changed in pantheon-dock:
milestone: none → loki-alpha1
status: Confirmed → Fix Committed
assignee: nobody → Rico Tzschichholz (ricotz)
Changed in pantheon-dock:
status: Fix Committed → Fix Released
Changed in plank:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers