Prompt for manifest collecting will not be available before you answer it

Bug #1443911 reported by Po-Hsu Lin on 2015-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PlainBox (Toolkit)
High
Zygmunt Krynicki

Bug Description

Run it with
$ plainbox run -i "2013.com.canonical.plainbox::collect-manifest"
===============================[ Analyzing Jobs ]===============================
=============================[ Session Statistics ]=============================
This session is about 0.00% complete
Estimated duration cannot be determined for automated jobs.
Estimated duration is 60.00 for manual jobs.
Size of the desired job list: 1
Size of the effective execution plan: 1
===========================[ Running Selected Jobs ]============================
---------------[ Collect the hardware manifest (interactively) ]----------------
ID: 2013.com.canonical.plainbox::collect-manifest
Category: 2013.com.canonical.plainbox::uncategorised
This job interactively asks the user about each manifest entry and stores the
result. This job can be omitted but the manifest may be incomplete unless it
was cached on an earlier run or provided externally.
Pick an action
    => press ENTER to continue
  c => add a comment
  s => skip this job
  q => save the session and quit
[csq]:
... 8< -------------------------------------------------------------------------
Does this machine have this piece of hardware?
 - Thunderbolt Support

Here should have a prompt for tester to answer, but it's only available after you hit enter here.

Related branches

Zygmunt Krynicki (zyga) wrote :

Yep, I reproduced this:

DISPLAY= plainbox run -i "2013.com.canonical.plainbox::collect-manifest"
===============================[ Analyzing Jobs ]===============================
=============================[ Session Statistics ]=============================
This session is about 0.00% complete
Nie można oszacować czasu trwania zadań zautomatyzowanych.
Oszacowany czas trwania zadań ręcznych to 60.00.
Size of the desired job list: 1
Size of the effective execution plan: 1
===========================[ Running Selected Jobs ]============================
---------------[ Collect the hardware manifest (interactively) ]----------------
ID: 2013.com.canonical.plainbox::collect-manifest
Category: 2013.com.canonical.plainbox::uncategorised
This job interactively asks the user about each manifest entry and stores the
result. This job can be omitted but the manifest may be incomplete unless it
was cached on an earlier run or provided externally.
Pick an action
    => press ENTER to continue
  c => add a comment
  s => skip this job
  q => save the session and quit
[csq]:
... 8< -------------------------------------------------------------------------
Does this machine have this piece of hardware?
 - Thunderbolt Support

(yes/y, no/n) Please enter either y or n
Does this machine have this piece of hardware?
 - Thunderbolt Support

Changed in plainbox:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.21
Zygmunt Krynicki (zyga) wrote :

This is caused by line-based IO we do in extcmd. I have a patch that does chunked IO.

Zygmunt Krynicki (zyga) on 2015-04-14
Changed in plainbox:
assignee: nobody → Zygmunt Krynicki (zyga)
status: Confirmed → In Progress
Zygmunt Krynicki (zyga) on 2015-04-15
Changed in plainbox:
status: In Progress → Fix Committed
Changed in plainbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers