need DVD read test after resume from suspend

Bug #1834623 reported by Nara Huang on 2019-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Checkbox
High
Betty Lin

Bug Description

In Stella project we find a bug of DVD ROM not working after suspend:
https://bugs.launchpad.net/stella/+bug/1834574

So QA would like to have check optical read after suspend.
These two are needed in this after suspend test plan:
include:
 optical/read_.* certification-status=blocker
 optical/bluray-read_.* certification-status=blocker

Related branches

Nara Huang (narahuang) on 2019-06-28
tags: added: ce-qa-concern
Jerry Kao (jerry.kao) on 2019-07-04
Changed in plainbox-provider-checkbox:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Betty Lin (bettyl)
Betty Lin (bettyl) wrote :

checkbox-ng: 1.4.0
checkbox-support: 0.41.0
com.canonical.ce:oem: 1.0
certification-client: 0.37.0
plainbox-provider-checkbox: 0.48.0
plainbox-provider-resource-generic: 0.40.0
plainbox-provider-sru: 1.13.0
plainbox-provider-tpm2: 1.10.0

The test cases optical/read_.* and optical/bluray-read_.* don't list by the command:

u@u-Latitude-3590:~$ checkbox-cli list-bootstrapped com.canonical.certification::client-cert-18-04 | grep optical
com.canonical.certification::optical/detect

Because of this problem, add flags "also-after-suspend-manual" can't bring the related after suspend test cases.
Still figure out why the problem is happened.

Betty Lin (bettyl) wrote :

Figure out that only the machine has dvd/bluray, the test case optical/read_.* and optical/bluray-read_.* will show by list-bootstrapped.

Betty Lin (bettyl) on 2019-08-14
Changed in plainbox-provider-checkbox:
status: Confirmed → Fix Committed
milestone: none → 0.49.0
Betty Lin (bettyl) wrote :

Verified the bug passed with:

checkbox-ng: 1.5.0rc3
checkbox-support: 0.42.0rc2
com.canonical.ce:oem: 1.0
certification-client: 0.38.0rc2
plainbox-provider-checkbox: 0.49.0rc4
plainbox-provider-resource-generic: 0.41.0rc2
plainbox-provider-sru: 1.14.0rc1
plainbox-provider-tpm2: 1.11.0rc2

tags: added: cqa-verified
Changed in plainbox-provider-checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers