dmesg-attachment job is empty

Bug #1712103 reported by Jeff Lane on 2017-08-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Checkbox
High
Jeff Lane

Bug Description

See here:
https://certification.canonical.com/hardware/201706-25552/submission/120995/attachments/

While investigating issues with this system I noticed that the dmesg attachment is completley blank, making it useless.

We need to fix this job so that it actually attaches the output of dmesg.

Jeff Lane (bladernr) on 2017-08-21
Changed in plainbox-provider-checkbox:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jeff Lane (bladernr)
tags: added: hwcert-server
Jeff Lane (bladernr) on 2017-08-21
Changed in plainbox-provider-checkbox:
status: Confirmed → In Progress
Jeff Lane (bladernr) wrote :

Appears to be because there is no /var/log/dmesg:

ubuntu@above-ox:~$ ls /var/log/
alternatives.log cloud-init-output.log kern.log.1 syslog.2.gz
apt dist-upgrade lastlog syslog.3.gz
auth.log dpkg.log lxd syslog.4.gz
auth.log.1 fontconfig.log ntpstats sysstat
btmp fsck syslog unattended-upgrades
cloud-init.log kern.log syslog.1 wtmp

(on MAAS deployments at least).

Jeff Lane (bladernr) on 2017-08-21
Changed in plainbox-provider-checkbox:
milestone: none → future
Changed in plainbox-provider-checkbox:
status: In Progress → Fix Committed
milestone: future → 0.40.0
Changed in plainbox-provider-checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers