traceback in boot_mode_test script

Bug #1663665 reported by Jeff Lane on 2017-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Checkbox
Critical
Jeff Lane

Bug Description

Something changed in a library somewhere that breaks the boot mode test.

--------------------[ Test that system booted in EFI mode ]---------------------
ID: 2013.com.canonical.certification::miscellanea/efi_boot_mode
Category: 2013.com.canonical.plainbox::miscellanea
... 8< -------------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/nest-v0qyiyj7.2f48cbb82856f5b503382a7a0a633e31a7d55be478fe05c613a85133fea65702/boot_mode_test", line 121, in <module>
    sys.exit(main())
  File "/tmp/nest-v0qyiyj7.2f48cbb82856f5b503382a7a0a633e31a7d55be478fe05c613a85133fea65702/boot_mode_test", line 118, in main
    return version_check(args.check)
  File "/tmp/nest-v0qyiyj7.2f48cbb82856f5b503382a7a0a633e31a7d55be478fe05c613a85133fea65702/boot_mode_test", line 41, in version_check
    installed_version = int(linux_distribution()[1].split()[0])
ValueError: invalid literal for int() with base 10: '16.04'
------------------------------------------------------------------------- >8 ---
Outcome: job failed

Related branches

Jeff Lane (bladernr) on 2017-02-10
Changed in plainbox-provider-checkbox:
assignee: nobody → Jeff Lane (bladernr)
Jeff Lane (bladernr) on 2017-02-22
Changed in plainbox-provider-checkbox:
milestone: none → 0.35.0
status: In Progress → Fix Committed
Pierre Equoy (pieq) on 2017-03-13
Changed in plainbox-provider-checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers