incompatibility with fwts 2015.07

Bug #1480473 reported by Jeff Lane on 2015-07-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Checkbox
Undecided
Zygmunt Krynicki

Bug Description

Found another missing test...

No such test 'hpet_check', available tests:
ac_adapter acpidump acpiinfo acpitables apicedge apicinstance aspm
autobrightness battery bert bgrt bios32 bios_info boot brightness checksum
cmosdump cpep cpufreq crs crsdump csm csrt cstates dbg2 dbgp dmar dmicheck ebda
ebdadump ecdt erst facs fadt fan gpedump gtdt hda_audio hest hotkey hpet klog
lid lpit madt maxfreq maxreadreq mcfg memmapdump method microcode mpcheck
mpdump msdm msr mtrr nx oops osilinux pcc pciirq plddump pnp power_button
prsdump romdump rsdp rsdt s3 s3power s4 sbst securebootcert slic slit spcr spmi
srat syntaxcheck tcpa uefi uefibootpath uefidump uefirtauthvar uefirtmisc
uefirttime uefirtvariable uefivarinfo version virt waet wakealarm wmi xenv xsdt

use: fwts --show-tests or fwts --show-tests-full for more information.
High Failures: 2
WARNING: The following test cases were reported as high
level failures by fwts. Please review the log at
/home/ubuntu/.cache/plainbox/sessions/pbox-kz1zkdyv.session/CHECKBOX_DATA/fwts_results.log for more information.
 - mpcheck
 - method
Medium Failures: 1
WARNING: The following test cases were reported as medium
level failures by fwts. Please review the log at
/home/ubuntu/.cache/plainbox/sessions/pbox-kz1zkdyv.session/CHECKBOX_DATA/fwts_results.log for more information.
 - klog
Low Failures: 1
WARNING: The following test cases were reported as low
level failures by fwts. Please review the log at
/home/ubuntu/.cache/plainbox/sessions/pbox-kz1zkdyv.session/CHECKBOX_DATA/fwts_results.log for more information.
 - acpitables
Passed: 14
 - apicedge
 - wmi
 - mcfg
 - msr
 - apicinstance
 - checksum
 - nx
 - dmar
 - virt
 - fadt
 - uefirtvariable
 - oops
 - cstates
 - version

Versions:
checkbox-ng 0.20.1~ppa~ubuntu14.04.1
plainbox-provider-checkbox 0.21.2~ppa1~ubuntu14.04.1
python3-checkbox-ng 0.20.1~ppa~ubuntu14.04.1
python3-checkbox-support 0.20~ppa~ubuntu14.04.1
plainbox-insecure-policy 0.22.2+ppa~ubuntu14.04.1
plainbox-provider-certification-server 0.17.1~ppa~ubuntu14.04.1
plainbox-provider-checkbox 0.21.2~ppa1~ubuntu14.04.1
plainbox-provider-resource-generic 0.19+ppa~ubuntu14.04.1
python3-plainbox 0.22.2+ppa~ubuntu14.04.1
fwts 15.07.00-0ubuntu1~t
fwts-efi-runtime-dkms 15.07.00-0ubuntu1~t
libfwts1 15.07.00-0ubuntu1~t
libfwtsacpica1 15.07.00-0ubuntu1~t
libfwtsiasl1 15.07.00-0ubuntu1~t

Related branches

Po-Hsu Lin (cypressyew) wrote :

http://bazaar.launchpad.net/~sylvain-pineau/checkbox/fwts_test_split/revision/3925
It's removed from checkbox in rev 3927.

I guess maybe the name got changed from "hpet_check" into "hpet"

 hpet (4 tests):
  Test HPET base in kernel log.
  Test HPET base in HPET table.
  Test HPET base in DSDT and/or SSDT.
  Test HPET configuration.
And these sub tests consistent to those listed in the HPET test wiki page [1]

[1] https://wiki.ubuntu.com/Kernel/Reference/fwts/hpet_check

Changed in plainbox-provider-checkbox:
status: New → Confirmed
Po-Hsu Lin (cypressyew) wrote :

If we can confirm that they're consistent, we could bring it back.

Ara Pulido (ara) wrote :

This is a different issue.

The problem is that FWTS 15.07 removed that test (well, renamed it) and we moved directly 15.07. This shouldn't be like that.

Reverting to fwts 15.06 should workaround it.

I am going to ask the team to either release the new test now to stable, or revert 15.07.

Thanks,
Ara.

Changed in plainbox-provider-checkbox:
status: Confirmed → Invalid
Zygmunt Krynicki (zyga) on 2015-08-03
Changed in plainbox-provider-checkbox:
assignee: nobody → Zygmunt Krynicki (zyga)
Zygmunt Krynicki (zyga) on 2015-08-03
Changed in plainbox-provider-checkbox:
status: Invalid → In Progress
Zygmunt Krynicki (zyga) wrote :

So I'd like some input on this.

I'm ready to release an update to be compatible with fwts 15.07. The only question is if we should bring the "hpet" test back.

In the single commit that changed this and some other things Sylvain wrote: "Remove the deprecated test hpet_check.". I now wonder if that test is really deprecated or was it just the particular wording but we still care after the "hpet" test.

Thanks
ZK

Changed in plainbox-provider-checkbox:
status: In Progress → Incomplete
Zygmunt Krynicki (zyga) wrote :

18:30 <@zyga> hmm
18:31 <@zyga> I could use some feedback on https://bugs.launchpad.net/plainbox-provider-checkbox/+bug/1480473
18:31 <@zyga> cwayne: ^^
18:31 <@zyga> cwayne: any opinion on this
18:31 <@zyga> cwayne: my feeling says bring hpet back
18:34 < cwayne> zyga, +1, i'd bring it back
18:41 <@zyga> ack,

Changed in plainbox-provider-checkbox:
status: Incomplete → In Progress
Zygmunt Krynicki (zyga) wrote :

I'm marking this as fix committed since trunk works okay with ftws 2015.07 -- we just need to release the set of changes that fix this issue:

I've picked the following patches:

(venv.virtual-fx)zyga@virtual-fx:~/checkbox/providers/plainbox-provider-checkbox$ git log plainbox-provider-checkbox-v0.21.2..HEAD
commit 56bde68458e9d2c47bad4a5dc07e99a77850ed23
Author: Sylvain Pineau <email address hidden>
Date: Thu Jul 30 14:19:31 2015 +0200

    providers:checkbox:firmware.txt.in: Add the fwts logs for HWE.

commit bddbbd06448c6643952741ecfdbc0242f04abb13
Author: Sylvain Pineau <email address hidden>
Date: Thu Jul 30 14:16:37 2015 +0200

    providers:checkbox:firmware.txt.in: Remove fwts_desktop_diagnosis selection

    The tests to run are defined in fwts_test.
    By default all cert test are selected.

commit 81b1ce1780fb41f09e77d722f5045e997211914f
Author: Sylvain Pineau <email address hidden>
Date: Thu Jul 30 14:16:37 2015 +0200

    providers:checkbox:fwts_test: Save logs meant for HWE analysis into a different file

    The selection is mtrr, virt, apicedge, klog, oops and uefibootpath.
    S3 and S4 are already saved in dedicated logs.

commit ea362bc3fa33c7875abc3667e215142809811fc4
Author: Sylvain Pineau <email address hidden>
Date: Thu Jul 30 14:16:37 2015 +0200

    providers:checkbox:fwts_test: Update test selection based on HWE recommendations

    Select all ACPI test with --acpitests, removing doubled values from the initial
    list. The --acpitests is exposed as just acpitests with the -l option as some
    jobs used the --list output as variable name to create new jobs.
    Remove the deprecated test hpet_check.
    Add dmicheck and uefibootpath based on recommendations.

Changed in plainbox-provider-checkbox:
milestone: none → 0.21.3
summary: - missing test error on fwts_test...again
+ incompatibility with fwts 2015.07
Changed in plainbox-provider-checkbox:
status: In Progress → Fix Committed
Zygmunt Krynicki (zyga) on 2015-08-04
Changed in plainbox-provider-checkbox:
status: Fix Committed → Fix Released
Zygmunt Krynicki (zyga) wrote :

I've uploaded the release to the the testing PPA. There are some small build issues (plainbox in the testing ppa was not built for the past two releases without anyone noticing). As soon as those are resolved I will re-upload a ~ppa2 version that will hopefully just work.

The ~ppa2 version has been uploaded.

On Thu, Aug 6, 2015 at 12:29 PM, Zygmunt Krynicki
<email address hidden> wrote:
> I've uploaded the release to the the testing PPA. There are some small
> build issues (plainbox in the testing ppa was not built for the past two
> releases without anyone noticing). As soon as those are resolved I will
> re-upload a ~ppa2 version that will hopefully just work.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1480473
>
> Title:
> incompatibility with fwts 2015.07
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/plainbox-provider-checkbox/+bug/1480473/+subscriptions

Zygmunt Krynicki (zyga) wrote :

Built and copied to all other Ubuntu releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers