Need storage tests for multipath devices.

Bug #1467520 reported by Jeff Lane on 2015-06-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Checkbox
High
Jeff Lane

Bug Description

this is critical to Power8 certifications. We need a storage test similar to the storage_devices_* tests that works on multipath devices internally that are presented via /dev/mapper.

current storage testing only works against physical block devices and doing this against multi-pathing devices can cause data corruption of filesystem destruction as you could try running against sdg only to discover that sdg is also sda, your root filesystem.

So we need some sort of test to make use of a dev/mapper resource to determine the presence of multi-path devices (or more generically, dev/mapper devices, and test them while ignoring block devices.

So the behaviour should be, in order of precedence:

if /dev/mapper/mpathX
  Run storage test against mpathX
else if /dev/sdX
  Run storage test against sdX as we have in the past

for now, an either-or should be sufficient, there is a chance in the future we may need to expand this for multiple storage scenarios, but for now, the simple either/or is enough to do certification testing.

Related branches

Jeff Lane (bladernr) wrote :

this corresponds to https://bugs.launchpad.net/checkbox/+bug/1467521 which outlines the need for the dev/mapper resource

Jeff Lane (bladernr) on 2015-08-05
tags: added: 16.04 hwcert-server
Mike Rushton (leftyfb) wrote :

Attaching output of `udevadm info --export-db`

Jeff Lane (bladernr) on 2016-01-14
Changed in plainbox-provider-checkbox:
status: New → Confirmed
Changed in plainbox-provider-checkbox:
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Sylvain Pineau (sylvain-pineau)
milestone: none → 0.35.0
Pierre Equoy (pieq) on 2017-03-06
Changed in plainbox-provider-checkbox:
milestone: 0.35.0 → 0.36.0
Changed in plainbox-provider-checkbox:
status: In Progress → Fix Committed
Jeff Lane (bladernr) wrote :

Setting this specific one back to Confirmed. The resource job and other changes took care of the other bug, however, while the non-mounted disk tests work fine, the bonnie and stress-ng ones fail because of issues indentifying the filesystem.

So we'll need to modify those to complete this bug.

Changed in plainbox-provider-checkbox:
status: Fix Committed → Confirmed
milestone: 0.36.0 → future
Jeff Lane (bladernr) wrote :

Now that the resource job works, I have a mostly working update for this that takes something like "dm-0" and finds the partitions based on what's in /dev/mapper.

So far it seems to work on both LVM (tested on zvm) and multipath (tested on IBM Tuleta).

further testing in progress

Changed in plainbox-provider-checkbox:
assignee: Sylvain Pineau (sylvain-pineau) → Jeff Lane (bladernr)
Jeff Lane (bladernr) on 2017-04-25
Changed in plainbox-provider-checkbox:
milestone: future → 0.36.0
Jeff Lane (bladernr) on 2017-04-28
Changed in plainbox-provider-checkbox:
status: Confirmed → In Progress
Jeff Lane (bladernr) on 2017-05-01
Changed in plainbox-provider-checkbox:
status: In Progress → Fix Committed
Changed in plainbox-provider-checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments