Comment 4 for bug 1349298

Daniel Manrique (roadmr) wrote :

Sure, the job's requirement is for a TOUCHPAD:

plugin: attachment
id: info/touchpad_driver
requires: device.category == 'TOUCHPAD'
command: touchpad_driver_info

but the script itself has this on line 7:

        if getattr(device, 'category') == 'TOUCH':

so clearly if the system has a touchpad, the script will run, but it will show the information for (for instance) a touchscreen and not the touchpad.

I think it's reasonable to make the requirements equal, setting them both to TOUCHPAD.