Can't install PPCS from dev on s390 because of numactl dependency

Bug #1667343 reported by Jeff Lane on 2017-02-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Canonical Certification Server
Critical
Rod Smith

Bug Description

So the current build of PPCS in dev had a dependency on numactl that is required for some test updates.

However, this breaks the package on s390:

ubuntu@s1lp9g003:~$ apt-cache policy plainbox-provider-certification-server
plainbox-provider-certification-server:
  Installed: 0.32.0~ppa~ubuntu16.04.1
  Candidate: 0.32.0+git201702152008+pkg56~ubuntu16.04.1
  Version table:
     0.32.0+git201702152008+pkg56~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/checkbox-dev/ppa/ubuntu xenial/main s390x Packages
 *** 0.32.0~ppa~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/hardware-certification/public/ubuntu xenial/main s390x Packages
        100 /var/lib/dpkg/status

ubuntu@s1lp9g003:~$ sudo apt-get install plainbox-provider-certification-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plainbox-provider-certification-server : Depends: numactl but it is not installable
E: Unable to correct problems, you have held broken packages.

ubuntu@s1lp9g003:~$ sudo apt-get update
Hit:1 http://us.ports.ubuntu.com/ubuntu-ports xenial InRelease
Get:2 http://us.ports.ubuntu.com/ubuntu-ports xenial-updates InRelease [102 kB]
Get:3 http://us.ports.ubuntu.com/ubuntu-ports xenial-backports InRelease [102 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease [102 kB]
Hit:5 http://ppa.launchpad.net/checkbox-dev/ppa/ubuntu xenial InRelease
Hit:6 http://ppa.launchpad.net/hardware-certification/public/ubuntu xenial InRelease
Get:7 http://ports.ubuntu.com/ubuntu-ports xenial-security/main s390x Packages [179 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe s390x Packages [70.0 kB]
Fetched 555 kB in 0s (975 kB/s)
Reading package lists... Done
ubuntu@s1lp9g003:~$ sudo apt-cache policy numactl
numactl:
  Installed: (none)
  Candidate: (none)
  Version table:

Conversely, on an x86 system:
bladernr@galactica:~$ apt-cache policy numactl
numactl:
  Installed: (none)
  Candidate: 2.0.11-1ubuntu1
  Version table:
     2.0.11-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Jeff Lane (bladernr) on 2017-02-23
Changed in plainbox-provider-certification-server:
assignee: nobody → Rod Smith (rodsmith)
Rod Smith (rodsmith) wrote :

I've added a "dummy" numactl package to the hardware-certification/public PPA. I don't have write access to the checkbox-dev/ppa, so somebody will have to copy the package over. This should at least get the Checkbox packages to install.

Now on to modifying the memory_stress_ng test file so that it won't choke when numactl is not present....

Sylvain Pineau (sylvain-pineau) wrote :

@Rod, I've just done the copy to dev and testing ppa.

Rod Smith (rodsmith) wrote :

Thanks, Sylvain!

Jeff, I've submitted a merge request for a fix to the memory_stress_ng script:

https://code.launchpad.net/~rodsmith/plainbox-provider-checkbox/+git/plainbox-provider-checkbox/+merge/318144

Since you've got access to the s390, could you please verify that this works? Thanks!

Changed in plainbox-provider-certification-server:
status: Confirmed → In Progress
Pierre Equoy (pieq) on 2017-03-06
Changed in plainbox-provider-certification-server:
milestone: none → 0.33.0
status: In Progress → Fix Committed
Pierre Equoy (pieq) on 2017-03-13
Changed in plainbox-provider-certification-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers