disk/smart_sda will fail on a pristine disk

Bug #1392010 reported by Mark W Wenning
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Canonical Certification (Legacy)
Fix Released
High
Rod Smith

Bug Description

Running certification on a Dell R530, got the following failure on disk/smart_sda :
Traceback (most recent call last): File "/tmp/nest-87rxzwdy.f56f5c335d0898316668afae86ba3e4d44df42982ade91867fd5a757b1949231/disk_smart", line 320, in <module> sys.exit(main()) File "/tmp/nest-87rxzwdy.f56f5c335d0898316668afae86ba3e4d44df42982ade91867fd5a757b1949231/disk_smart", line 292, in main previous_entries, returncode = get_smart_entries(disk) ValueError: need more than 1 value to unpack

Turns out this system contained a brand new disk that had never had the smart test run on it before.

In the disk_smart test, the first thing that get_smart-entries does is run "smartctl -l selftest /dev/sda", which will return 0 entries on a pristine disk, and exhibit the above failure.

Workaround is to manually run "sudo smartctl -t short /dev/sda" at least once to create an entry in the SMART selftest table.

File of my notes is attached.

Related branches

Revision history for this message
Mark W Wenning (mwenning) wrote :
Revision history for this message
Daniel Manrique (roadmr) wrote :

I took the liberty of assigning this to Rod, who recently overhauled the smart test and may be in a good position to fix this.

Rod, please let me know if you have time to look into this; if not, feel free to deassign yourself from the bug and I'll retriage it.

Cheers!

Changed in plainbox-provider-canonical-certification:
assignee: nobody → Roderick Smith (rodsmith)
Daniel Manrique (roadmr)
Changed in plainbox-provider-canonical-certification:
status: New → Confirmed
importance: Undecided → High
milestone: none → future
Revision history for this message
Rod Smith (rodsmith) wrote :

Mark, I *THINK* I've fixed this, but I don't have any pristine disks with which to test. If you can get access to such a disk, please test the version of disk_smart in https://launchpad.net/~rodsmith/checkbox/smart-newdisk. (I'll e-mail you the script directly, too.)

Revision history for this message
Mark W Wenning (mwenning) wrote :

I tried the new script on another pristine disk, and it looks like it is fixed.

Rod Smith (rodsmith)
Changed in plainbox-provider-canonical-certification:
status: Confirmed → In Progress
Daniel Manrique (roadmr)
Changed in plainbox-provider-canonical-certification:
milestone: future → 0.12
Rod Smith (rodsmith)
Changed in plainbox-provider-canonical-certification:
status: In Progress → Fix Committed
Changed in plainbox-provider-canonical-certification:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers