installing canonical-certification-server pulls in mysql, 159Mb of pkgs

Bug #1276832 reported by Mark Brown on 2014-02-05

This bug report was converted into a question: question #243429: installing canonical-certification-server pulls in mysql, 159Mb of pkgs.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Provider for Plainbox - Canonical Certification (Legacy)
Low
Sylvain Pineau

Bug Description

I created a minimal server using the daily Trusty build from 5 February. I chose "OpenSSH Server" and nothing else to be installed.

After the install, I did:
sudo add-apt-repository ppa:checkbox-dev/ppa

sudo apt-get update

sudo apt-get install canonical-certification-server

At this point 159Mb of packages were installed, including MySQL server (which then asked me for a password, etc). This was somewhat unexpected.

So we really have that many dependencies?

Daniel Manrique (roadmr) wrote :

Hello!

Our purpose-specific testing utilities usually specify as dependencies all the packages required by related tests. The rationale is that if we define a mysql test that can conceivably be used while testing a server, but our package doesn't take care of installing mysql for you, thus causing the test to not run, it will just be confusing and result in more work for you.

We're definitely open to discussing the list of dependencies, but since they're handled as .deb package dependencies, it's usually an all-or-nothing approach, and in our experience it's best to provide as much as possible, rather than have testers do a lot of extra work to get stuff installed.

To properly handle this bug I'll move it to an incomplete state awaiting your feedback. We have 2 options:
1- It was just a question, my answer clarified things and there's no further action to take. Bug would become "Invalid".
2- You'd like to have a smaller list of dependencies. This would imply extra work for the user but we can certainly discuss an organization that makes sense. Please let me know and we can outline the work to do, then the bug would become "Triaged" pending implementation.

Here's some reference information about where this comes from.

We have one server-related test that does require mysql:

name: services/lamp_test
requires:
 package.name == 'apache2'
 package.name == 'php5-mysql'
 package.name == 'libapache2-mod-php5'
 package.name == 'mysql-server'

This test is not included in our "whitelist" of server tests (which does seem like an oversight; perhaps we could repurpose this bug into "add all these services tests to a whitelist").

The dependencies for canonical-certification-server (expressed as Recommends) are:

Recommends: apache2,
            bind9,
            bonnie++,
            cpu-checker,
            cups,
            dnsutils,
            fwts (>=13.09.00-0ubuntu1),
            iperf,
            ipmitool,
            libapache2-mod-php5,
            mysql-server,
            php5-mysql,
            qemu-kvm,
            qemu-utils,
            samba,
            ssh,
            stress,
            tomcat6,
            winbind

Changed in checkbox:
status: New → Incomplete
Mark Brown (mstevenbrown) wrote :

This clarifies, so the bug should go Invalid.

Changed in checkbox:
status: Incomplete → Invalid
Jeff Lane (bladernr) wrote :

Just my opinion, but those services tests (and anything not covered by the server whitelists already) should NOT be included in canonical-certification-server as a provider.

They may be necessary as a different provider package (perhaps something called Ubuntu Server Validation or whatever). They were not designed, nor intended to be, part of server certification and shouldn't be part of the provider/packaging for server cert.

To that end, I'm setting this to confirmed and LOW because it's not blocking anything, but would be nice to reduce that dependency tree as much as possible.

Changed in checkbox:
status: Invalid → Confirmed
importance: Undecided → Low
Zygmunt Krynicki (zyga) on 2014-04-23
affects: checkbox → plainbox-provider-canonical-certification
Changed in plainbox-provider-canonical-certification:
assignee: nobody → Sylvain Pineau (sylvain-pineau)
status: Confirmed → In Progress
milestone: none → 0.22
Changed in plainbox-provider-canonical-certification:
status: In Progress → Fix Committed
Pierre Equoy (pieq) on 2016-03-21
Changed in plainbox-provider-canonical-certification:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers