libsqlite3-dev and libpq dependencies not checked properly

Bug #408433 reported by Jay Pipes on 2009-08-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gearman Packaging
Medium
Rahmadani bayu aji

Bug Description

Pandora-build related. I got pinged by Aptitude on Ubuntu 8.10 this morning that updates were available for libmemcached and libgearman. After installing these updates, trunk failed to build, with:

libtool: link: cannot find the library `/usr/lib/libsqlite3.la' or unhandled argument `/usr/lib/libsqlite3.la'

After installing libsqlite3-dev, during link, I get:

/usr/bin/ld: cannot find -lpq

After installing libpq-dev, everything built successfully.

Please add proper checks in configure.ac or an m4 in pandora build. Also, please explain why these dependencies are *necessary to build Drizzle*?!

Jay Pipes (jaypipes) on 2009-08-03
Changed in drizzle:
assignee: nobody → Monty Taylor (mordred)
importance: Undecided → Medium
milestone: none → aloha
status: New → Confirmed
Monty Taylor (mordred) wrote :

This is not actually a bug in Drizzle ... it's a bug in the Gearman Debian packaging.

affects: drizzle → pkg-gearman
Changed in pkg-gearman:
milestone: aloha → none
Monty Taylor (mordred) on 2013-08-11
Changed in pkg-gearman:
assignee: Monty Taylor (mordred) → nobody
Changed in pkg-gearman:
assignee: nobody → Skymathrix (asstaroid)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers