Need v30 protocol/keys -- "Pandora does not support your client version"

Bug #771804 reported by Kevin Mehall on 2011-04-27
218
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
Critical
Kevin Mehall
pianobar
Fix Released
Undecided
Unassigned
pianobar (Debian)
Fix Released
Unknown
pianobar (Ubuntu)
High
Luke Faraone
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
pithos (Debian)
Fix Released
Unknown
pithos (Ubuntu)
High
Luke Faraone
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

NB: If you came here from a Google search, please see http://faraone.cc/s/pandoraUbuntuBreakage , the tracker for the latest issue with Pandora. What follows is an older, similar bug.
== SRU INFORMATION ==

Pandora changed their API, so here we provide an update to support API v30. The API change rendered pianobar and pithos unusable. In addition, this upload fixes a gstreamer bug in pithos. (described in bug 759699)

This is low-impact to other apps, because pithos and pianobar have no rev-depends.

=== pithos (gtk) ===
What happens:
On login, "Pandora does not support your client version"

What should happen:
You are logged in and a station loaded.

For natty, pithos release 0.3.9 was adapted (currently shipped in Debian). The release *only* includes the fix to this bug and bug 759699 (gstreamer randomly errored out at the end of songs). Attached is a debdiff including all changes between 0.3.8-1 shipped in the archive and the proposed version.

=== pianobar (cli) ===
What happens:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Error: Protocol incompatible. Please upgrade libpiano.

What should happen:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Ok.

Etc.

Ideally, test with your Pandora.com account.

== END SRU INFORMATION ==

"Pandora does not support your client version"

Changed in pithos:
status: New → In Progress
importance: Undecided → Critical
Luke Faraone (lfaraone) on 2011-04-27
Changed in pianobar (Ubuntu):
status: New → Triaged
Changed in pithos (Ubuntu):
status: New → Triaged
Changed in pianobar (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
Changed in pithos (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
Changed in pianobar (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
Changed in pithos (Ubuntu):
importance: Undecided → High
Fremiet Lara (fremiet) wrote :

pianobar is affected As described in Bug #771793

$ pianobar
Welcome to pianobar (2011.04.10-dev)! Press ? for a list of commands.
(i) Login... Error: Protocol incompatible. Please upgrade libpiano.

***

Sorry, I don't know how to upstream issues to githhub. The developer is following the issue there.

https://github.com/PromyLOPh/pianobar/issues/107

Kevin Mehall (kevin-mehall) wrote :

Have it fixed. Going to do some testing, and will release soon.

Changed in pithos:
status: In Progress → Fix Committed
assignee: nobody → Kevin Mehall (kevin-mehall)

So it seems that Pandora is starting to wise up and do protocol transitions. Let the games begin. :(

Kevin you said that you fixed the issue... have you uploaded the source to LP yet or is this going to be extensive testing before upload and should I just wait till tomorrow to sync to the repo?

Matt

On 04/27/2011 12:52 PM, Matt Eskes wrote:
> Kevin you said that you fixed the issue... have you uploaded the source
> to LP yet or is this going to be extensive testing before upload and
> should I just wait till tomorrow to sync to the repo?

The fix is in Bazaar. After testing, the software will be released, a
SRU prepared for Ubuntu Natty, and a normal upload to Debian Unstable made.

--
Luke Faraone;; Debian & Ubuntu Developer; Sugar Labs, Systems
lfaraone on irc.[freenode,oftc].net -- http://luke.faraone.cc
PGP fprint: 5189 2A7D 16D0 49BB 046B DC77 9732 5DD8 F9FD D506

Kevin Mehall (kevin-mehall) wrote :

It will be uploaded to the PPA as well when I make the release this evening.

Bluelake3 (aserna3) wrote :

Awesome! Thanks for your hard work Kevin! Will be looking forward to that PPA update :)

gwern (gwern0) wrote :

If anyone still cares, I can confirm that pianobar in 10.10 Maverick is broken in this way, and that compiling the HEAD on Github just now results in a pianobar that works fine.

Kevin Mehall (kevin-mehall) wrote :

Uploaded 0.3.9 to the PPA. Looks like the build queue is long. I'll post when packages are built.

Crusty Barnacle (calipengo) wrote :

Thank you Kevin!
And, I am a Pandora One subscriber ;-).

Dave Johnson (dave-scomple) wrote :

I should have checked Launchpad before I emailed you I guess ;)

Thanks again for the quick response to this, it creeps in every now and then. Just like last time, I'll be making another donation to express my thanks.

E D (ericsdigital) wrote :

Working great now, will be donate shortly. Thanks for keeping up with this great app.

Scott Dollins (sdollins) wrote :

The new version appears to only be available in Lucid.

KruyKaze (kruykaze) wrote :

i used the lucid .deb on my maverick box and it worked

On Wed, Apr 27, 2011 at 6:58 PM, Scott Dollins <email address hidden>wrote:

> The new version appears to only be available in Lucid.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/771804
>
> Title:
> Need v30 protocol/keys -- "Pandora does not support your client
> version"
>
> Status in pianobar:
> New
> Status in Pithos:
> Fix Committed
> Status in “pianobar” package in Ubuntu:
> Triaged
> Status in “pithos” package in Ubuntu:
> Triaged
> Status in “pianobar” package in Debian:
> Unknown
> Status in “pithos” package in Debian:
> Unknown
>
> Bug description:
> "Pandora does not support your client version"
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/pianobar/+bug/771804/+subscribe
>

mklimczak (mikeizzel) on 2011-04-28
Changed in pianobar (Ubuntu):
status: Triaged → Fix Released
Rafael Nonato (rafaeln) wrote :

I'm sorry for the noobness, but how do I get hold of the Lucid .deb?

Luke Faraone (lfaraone) on 2011-04-28
Changed in pithos (Ubuntu):
status: Triaged → In Progress
Changed in pianobar (Ubuntu):
status: Fix Released → In Progress
Changed in pianobar:
status: New → Fix Committed
KruyKaze (kruykaze) wrote :

from the ppa page in "packages"

On Wed, Apr 27, 2011 at 7:35 PM, Rafael Nonato <email address hidden> wrote:

> I'm sorry for the noobness, but how do I get hold of the Lucid .deb?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/771804
>
> Title:
> Need v30 protocol/keys -- "Pandora does not support your client
> version"
>
> Status in pianobar:
> New
> Status in Pithos:
> Fix Committed
> Status in “pianobar” package in Ubuntu:
> Fix Released
> Status in “pithos” package in Ubuntu:
> Triaged
> Status in “pianobar” package in Debian:
> Unknown
> Status in “pithos” package in Debian:
> Unknown
>
> Bug description:
> "Pandora does not support your client version"
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/pianobar/+bug/771804/+subscribe
>

Changed in pithos:
status: Fix Committed → Fix Released
Modjor Kochiii (kochiiiiii) wrote :

Thank you Kevin and everybody for providing us with Pithos and the maintenance. You guys ROCK!!!!!!

Luke Faraone (lfaraone) on 2011-04-28
Changed in pithos (Ubuntu Maverick):
status: New → Invalid
Bruce Young (byoung-berkeley) wrote :

Works!!! Thanks so much. (Yesterday was a sad day of silence)

bob sagger (bobsmart3) wrote :

Wait is this fixed? Status is still in progress and doesn't work here via apt-get in ubuntu 10.10 -- yet everyone is commenting that its fixed...what am i missing?

Luke Faraone (lfaraone) wrote :

This patch for natty fixed this bug and bug 705271.

JimmyJam (jamesiarmes) wrote :

apt-get upgrade in Kubuntu 10.10 and it's working great. Thanks!

Luke Faraone (lfaraone) wrote :

This patch for pianobar fixes this bug in maverick.

Luke Faraone (lfaraone) on 2011-04-28
description: updated

Accepted pianobar into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pianobar (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Accepted pianobar into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pianobar (Ubuntu Natty):
status: New → Fix Committed
Luke Faraone (lfaraone) on 2011-04-29
Changed in pianobar:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Accepted pithos into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Natty):
status: New → Fix Committed
meow9th (y-yuan) wrote :

Just updated to pianobar/maverick-proposed. Works great, thanks!

applied pianobar patch and it works as expected.

just waiting for pithos deb file to be available on archive to

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.9-1

---------------
pithos (0.3.9-1) unstable; urgency=medium

  * New upstream bugfix release.
    - Support protocol 30. (LP: #771804, closes: #624324)
    - Enable gstreamer progressive download to improve stream quality.
      (LP: #705271)
 -- Ubuntu Archive Auto-Sync <email address hidden> Sat, 30 Apr 2011 13:31:36 +0000

Changed in pithos (Ubuntu):
status: In Progress → Fix Released
Luke Faraone (lfaraone) on 2011-05-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2011.01.24-1ubuntu0.1

---------------
pianobar (2011.01.24-1ubuntu0.1) natty-proposed; urgency=low

  * Support new XMLRPC api (v30) (LP: #771804)
 -- Luke Faraone <email address hidden> Thu, 28 Apr 2011 18:39:51 -0400

Changed in pianobar (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.9-1~ubuntu1

---------------
pithos (0.3.9-1~ubuntu1) natty-proposed; urgency=low

  * Include Pandora bugfixes from Debian:
    - Support protocol 30. (LP: #771804, closes: #624324)
    - Enable gstreamer progressive download to improve stream quality.
      (LP: #705271)
  * Update maintainer field.
 -- Luke Faraone <email address hidden> Thu, 28 Apr 2011 09:48:53 -0400

Changed in pithos (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2010.10.07-1ubuntu0.2

---------------
pianobar (2010.10.07-1ubuntu0.2) maverick-proposed; urgency=low

  * Support new XMLRPC api (v30) (LP: #771804)
 -- Luke Faraone <email address hidden> Thu, 28 Apr 2011 18:32:01 -0400

Changed in pianobar (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in pithos (Debian):
status: Unknown → Fix Released
Changed in pianobar (Debian):
status: Unknown → Fix Released
Luke Faraone (lfaraone) wrote :

Fixed a while ago in pianobar / oneiric

Changed in pianobar (Ubuntu):
status: In Progress → Fix Released
Daniel Centore (dcentore) wrote :

This problem just began again. I'm not sure if I should start a new report or not, so I'm commenting here. Please fix, this is one of my favorite linux apps :-(

Esteban (wuesteban) wrote :

I am having this problem again, as Daniel wrote.
This makes me #2

Luke Faraone (lfaraone) wrote :

Known issue, bug 856035 created for the issue, and see upstream report in pianobar at https://github.com/PromyLOPh/pianobar/issues/157

Please don't post additional comments here or on the other bugs indicating the issue affects you; it will add to the noise on a bug report and doesn't help move towards a solution.

AlexOnVinyl (justlikepac) wrote :

I as well am having problems

Ubuntu Natty 32bit
Pithos 0.3.9

derrek cooper (derrekcooper) wrote :

Was working yesterday in Natty 64bit, 0.3.10 version, not today. Haven't changed anything, no updates etc.

Luke Faraone (lfaraone) on 2011-11-09
description: updated
Quang (quangvvv) wrote :

Having problems as well

Clint Byrum (clint-fewbar) wrote :

To all those having issues, please see the more recent bug #856035, and if it does not match your symptoms, report a new bug.. this bug was for v30, that one is for v32.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.