Netflix doesn't play after Latest wine-compholio update (1.7.13)

Bug #1283025 reported by Juhani Eskola
52
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Netflix Desktop
Fix Released
Critical
Erich E. Hoover
Pipelight
Fix Released
Critical
Erich E. Hoover
Wine "Compholio" Edition
Fix Released
Critical
Erich E. Hoover

Bug Description

Updated today (21.2.2014) Ubuntu 12.04. Netflix (from Finland) and MTV Katsomo doesn't play any more. Netflix red screen loads 50-98 % and after that I receive Error Code: N8156-6205. Tried Mint Petra wich didn't have updates and that works. VirtualBox Ubuntu 12.04 stopped also working after update. Log file from VirtuaBox Ubuntu.

Revision history for this message
Juhani Eskola (juhani-eskola) wrote :
Revision history for this message
Juhani Eskola (juhani-eskola) wrote :

Addition - same result with both Firefox and Chrome latest stable versions. No matter what recommended user agent used.

Changed in pipelight:
importance: Undecided → Critical
status: New → Triaged
Revision history for this message
deep (deepthought-s) wrote :

Watchever doesnt play after todays update 21.02, using Firfox and Chromium, Ubuntu 13.10

Revision history for this message
Michael Müller (mqchael) wrote :
Revision history for this message
Simon (simontipping21) wrote :

I can confirm this also effects BTSport after the update, will revert back to old package and let you know what happens.

Revision history for this message
Juhani Eskola (juhani-eskola) wrote :

Thnx for packages, that worked and we'll wait fixes. Thanks for Your excellent Pipelight project work. Respect!

Revision history for this message
Simon (simontipping21) wrote :

I have reverted and BTSport works again although I have discovered that using a user agent switcher breaks BTSport, it just stays stuck on loading, using the default user agent it loads fine.

Revision history for this message
Bathynomus (blue-crawdaddy) wrote :

This error is back as of today 02/21/2014 in 13.10 after update. Netflix Error Code: N8156-6205

Revision history for this message
T K (parad0x-r) wrote :

How does one revert to the working version?

Revision history for this message
Sebastian Lackner (slackner) wrote :

To revert to a previous version take a look at comment #4. Basically just download the previous version, and install it with "sudo dpkg -i here_the_file_you_just_downloaded.deb"

Changed in netflix-desktop:
status: New → In Progress
Changed in pipelight:
status: Triaged → In Progress
Changed in wine-compholio:
status: New → In Progress
Changed in netflix-desktop:
assignee: nobody → Erich E. Hoover (ehoover)
Changed in pipelight:
assignee: nobody → Erich E. Hoover (ehoover)
Changed in wine-compholio:
assignee: nobody → Erich E. Hoover (ehoover)
Changed in netflix-desktop:
importance: Undecided → Critical
Changed in wine-compholio:
importance: Undecided → Critical
Revision history for this message
grantdb (grantdb) wrote :

Thanks for the fix, downgrading has worked fine for me.

Changed in netflix-desktop:
status: In Progress → Fix Committed
Changed in pipelight:
status: In Progress → Fix Committed
Changed in wine-compholio:
status: In Progress → Fix Committed
Revision history for this message
deep (deepthought-s) wrote :

Its Working for me, thanks.

Revision history for this message
Felipe Castillo (fcastillo.ec) wrote :

I can also comfirm the bug and that reverting to the previous version fixed the issue.

Revision history for this message
justen r meltz (justen) wrote :

Same as #12 and #13. I think I am going to remove everything related to Netflix/Wine from being auto-updated until Netflix or MS makes another change that breaks stuff.

That being said, thanks for the quick response to the original post with an easy solution.

FWIW, I'm running Chrome 33.0.1750.117 on two Ubuntu 13.10 machines, one 32bit one 64bit.

Revision history for this message
Erich E. Hoover (ehoover) wrote :

Hi justen, it's not their fault - it's mine. The build farm is building fixed packages as we speak.

Revision history for this message
T K (parad0x-r) wrote :

How do you change it so that it doesn't auto-update like Justen just said? New *nix user here, Ubuntu 12.04 LTS. Coming from windows, so noob when it comes to this sort of stuff.

Revision history for this message
Michael Müller (mqchael) wrote :

Hi Tk,

you can put a package like wine-compholio on hold (i.e. preventing it from being updated) with:

sudo apt-mark hold wine-compholio

and allow updating again with

sudo apt-mark unhold wine-compholio

Anyway, I wouldn't suggest you to do this, as the new versions are currently building and you would miss new features and bug fixes. We are for example looking forward to get hardware acceleration working with AMD cards in future versions of wine-compholio and you may forget to unhold it again.

Please note that we also only offer support here for the latest versions.

Michael

summary: - Netflix doesn't play after Latest wine-compholio update
+ Netflix doesn't play after Latest wine-compholio update (1.7.13)
Revision history for this message
Erich E. Hoover (ehoover) wrote :

Hello everyone,

I sincerely apologize for my mistake here, this problem was a single letter typo in the configure script that I did not notice because I did not re-run ./configure before doing final testing. This change was due to a feature request from people running source-based distributions that we provide a configure option to cause the build to fail when extended filesystem attributes are not available. Due to a mistake on my part this change ended up unintentionally disabling extended attributes across the board (leading to the problem you have seen). The fixed build is now posted to the official repo (and the old repo), if you update again then everything should go back to normal.

I would kindly request that you please _not_ disable the auto-updating of the package, the rigorous testing of this package helps us catch these issues quickly so that we can improve the quality of our patches in the hope that we can get them included in upstream Wine. This is important because once these patches are in upstream Wine then it is no longer necessary to use our specially compiled version. It is also important to recognize that mistakes like this are pretty rare events, as we push a new stable release every two weeks (coincident with new Wine releases) and this is probably the first time you've seen an issue. The last time we had a problem like this (1.7.8) we instituted some new build procedures to prevent that class of problem from recurring in the future, and we are currently trying to do the same for this particular type of problem. Also, if you are willing to help prevent these problems from occurring in future releases then you can help us out by testing the daily builds*:
sudo add-apt-repository ppa:pipelight/stable

Again, my sincerest apologies for this problem - hopefully this is the last time that such a mistake will occur.

* Unfortunately, due to some recent launchpad strangeness with having "too many" simultaneous builds we can only do daily builds for Precise, Trusty, and Saucy at the moment. I'm hoping that at some time in the near future that I'll be able to figure out what causes the build to hang and fix that issue so that we can do daily builds for all the supported Ubuntu releases.

Changed in netflix-desktop:
status: Fix Committed → Fix Released
Changed in pipelight:
status: Fix Committed → Fix Released
Changed in wine-compholio:
status: Fix Committed → Fix Released
Revision history for this message
Erich E. Hoover (ehoover) wrote :

Sorry, that was the wrong command above - it should be:
sudo add-apt-repository ppa:pipelight/daily

Revision history for this message
T K (parad0x-r) wrote :

Thanks for all your hard work Erich! It's much appreciated! Not having Netflix support on Linux was one of the main reasons it took me so long to decide to migrate from Windows.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments