DRM error on netflix (error code N8156-6013)

Bug #1240150 reported by TragicWarrior on 2013-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pipelight
Undecided
Unassigned

Bug Description

screenshot showing the problem:

http://www.mediafire.com/view/?v61w9wk43n1v8eo

System:

Firefox 24 on Xubuntu 13.04 64-bit
Latest pipelight installed from PPA

(from about:plugins)
Silverlight Plug-In

    File: libpipelight.so
    Path: /usr/lib/pipelight/libpipelight.so
    Version: 5.1.20513.0
    State: Enabled
    5.1.20513.0

Sebastian Lackner (slackner) wrote :

Hi,

this doesn't have anything to do with the problem itself, but I noticed that this isn't really the latest version of pipelight (the latest version is 0.2.0, which was just released yesterday).

You can use the following command line to find out the latest version of all pipelight related packages (just copy and paste it into a terminal):

dpkg --list | grep "\(wine-.*-installer\|wine-compholio\|pipelight\)" | sed 's/ \+ /\t/g' | cut -f2-3;

Please try to install updates first:

sudo apt-get update
sudo apt-get upgrade

If you get a message that pipelight is not going to be updated (this can appear because the dependencies have changed) you can force it for example with (or just use the Ubuntu software center to install updates):

sudo apt-get install --reinstall pipelight

Besides that I noticed that you're not probably using a user agent switcher (at least there is no menubar icon i recognize). This is required to make the pages think that you're running a Windows machine, the error code you got can be caused by that. Please follow the steps here to install one (and then select a windows version of firefox):
https://answers.launchpad.net/pipelight/+faq/2351

Please report back if it still doesn't work.

Sebastian

TragicWarrior (bryan-christ) wrote :

@sebastian,

shortly after i wrote this i did indeed notice that apt-get had held back a few packages including pipelight. i did a 'dist-upgrade' and that pulled in the latest. here's what i have now (but the netflix problem still happens):

pipelight 0.2.0~ubuntu13.04.1
pipelight-multi 0.2.0~ubuntu13.04.1
wine-browser-installer 0.8.6~ubuntu13.04.1
wine-compholio 1.7.4~ubuntu13.04.1
wine-mpg2splt-installer 0.8.6~ubuntu13.04.1
wine-silverlight5.1-installer 0.8.6~ubuntu13.04.1

Sebastian Lackner (slackner) wrote :

Hi,

your packages seem up-to-date now, but please check again the second thing I wrote above about the user agent switcher - I think its very likely that a missing (or configured incorrect) user-agent-switcher is causing the issue.

After you've followed the FAQ above, you can check your settings on:
http://fds-team.de/pipelight

Please post the output of this page, when it still doesn't work after that.

Sebastian

dchardy (david-planetmind) wrote :

Had the same issue here; fixed it by removing the file "~/.wine-pipelight/drive_c/users/Public/Application Data/Microsoft/PlayReady/mspr.hds"

(there's a space in the path, so use quotes if you copy and paste)

David

TragicWarrior (bryan-christ) wrote :

@dchardy,

thanks for the tip. i removed that file and it fixed the problem for me too. it looks like something installed a new version of that file now.

Michael Müller (mqchael) wrote :

I close the bug report since the problem seems to be solved. The issue that the mspr.hds (the silverlight individualization file) is damaged can happen in rare cases and is also known on windows. The tip to delete the directory containing this file is also shown when opening a bug report:

"Before filling a DRM related bug report, please try to delete the "drive_c/users/Public/Application Data/Microsoft/PlayReady/" directory inside your Wine directory (default location: ~/.wine-pipelight/) and try again. This fixes most of the DRM issues."

Changed in pipelight:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers