Netflix error N8109 when using Firefox

Bug #1213584 reported by Sebastian Lackner on 2013-08-18
This bug affects 3 people
Affects Status Importance Assigned to Milestone

Bug Description

One user reported error N8109 when trying to watch movies on Netflix with Firefox, but everything worked well with Pipelight+Chromium and with Netflix-Desktop (including a windows version of Firefox).

Ubuntu version 12.04 LTS
Firefox version 23
Tested silverlight versions 4, 5.0, 5.1
User-Agent switcher: (v0.7.3)
User-Agent string: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

* Deleting ~/.wine-pipelight and reinstalling Silverlight didn't solve the problem
* Deleting the firefox profile directory didn't solve the problem.
* Other DRM test sites worked fine, but not Netflix.

Do you have the same problem? Please write which user agent switcher you are using and if everything works well on Chromium (might require the installation of another User Agent Switcher, see

Is anybody using exactly the same user agent switcher as above and managed to get Netflix working?

mdd5 (mdd5) wrote :

I had the same exact problem
Seems to be an issue with the User-Agent-Switcher

Because I have tried another
and it worked perfectly.

Michael Müller (mqchael) wrote :

Thanks for the information with the user agent switcher, I updated the FAQ. I will consider this bug as fixed, if someone has still the same problem, feel free to reopen it.

Changed in pipelight:
status: New → Fix Released
importance: Undecided → Low
Tuomas Lähteenmäki (lahtis) wrote :

my firefox 23.0 say in addons pipelight error. if im using wine-browser silverlight working.

Sebastian Lackner (slackner) wrote :


sorry, but this already fixed bug report isn't really related to your issue. Normally the way to ask for help / report a bug is open a new bug report or asking a question, and not just writing something totally unrelated in another topic.

Nevertheless: We really need more information in order to know whats going wrong or what could be the problem.

Please open a NEW bug report / ask a NEW question containing at least the following information:

* Which distribution you are using (Archlinux, Ubuntu, others, ..., self compiled) ?
* Which output do you get when starting "firefox" from a terminal (you should get some debug output there saying whats going wrong)

Moreover we have a whole FAQ entry ( ) to track down such errors, the next release will also include some methods to check everything automatically.


I'm using User Agent Switcher 0.7.3 on Ubuntu 13.10 and Netflix works fine for me on Firefox 24.0 using the user agent "Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20131011 Firefox/23.0". I'm attaching my config file. It's the default with an extra entry for FF.

R. Steve McKown (rsmckown) wrote :

As #5, I too was using User Agent Switcher 0.7.3, but some time in April 2014, Netflix quit working with the dreaded N8109 error. Purged and re-installed and re-configured pipelight with no change. Then remembered the UA switch issue. Uninstalled User Agent Switcher and installed User Agent Overrider (currently 0.2.3), set UA to Windows/Firefox26, and all is well again.

Victor Thompson (vthompson) wrote :

I had the same issue as Steve in #6 and removing User Agent Switcher 0.7.3 and installing User Agent Overrider fixed the issue. Thanks!

Simon Hirscher (codethief) wrote :

Same here, User Agent Overrider did the trick. Thanks, everyone! I'll check whether the alternative addon "UAControl" works, too, as UAControl allows one to set the user agent depending on the website which is slightly more convenient than switching back and forth.

Keith Bowes (zooplah) wrote :

The problem with User Agent Overrider is that it's Firefox only, so not usable by those of us who prefer other Gecko applications. The problem with User Agent Switcher is definitely that Netflix expects an appVersion, but the list from techpatterns has an empty appVersion and User Agent Switcher thus sends a blank appVersion. I've forked it and alerted Chris Pederick about my fix (a blank value causes the pref to be deleted rather than overridden with an empty value). It'll be up to him whether to incorporate my fix or not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers